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MIDAS Family Programs are the group of software packages for structural analysis and design 
developed by MIDAS IT Co., Ltd. 
 
 
MIDAS Family Programs and all associated documentation are copyrighted and protected by the 
computer program protection law. 
 
 
For any enquiry concerning the program or related materials, please contact the following: 
 

 

MIDAS IT Co., Ltd. 
MIDAS IT Tower - Pangyo Seven Venture Valley,  
633 Sampyeong-dong, Bundang-gu, Seongnam-si, Gyeonggi-do, 463-400, 
 KOREA 

MIDAS IT Co., Ltd. 

Modeling, Integrated Design & Analysis Software 
Phone: +82-31-789-2000    
E-mail: info@midasit.com 
http://www.MidasUser.com 

 
 
Trademarks and Registered Trademarks referred to in this User’s Guide are as follows: 
 
ADINA is a registered trademark of ADINA R&D, Inc.  
AutoCAD is a registered trademark of Autodesk, Inc.  
ETABS, SAFE, and SAP2000 are registered trademarks of Computers and Structures, Inc.  
Excel is a trademark of Microsoft Corporation.  
IBM is a registered trademark of International Business Machines Corporation.  
Intel 386, 486, and Pentium are trademarks of Intel Corporation.  
MIDAS is a registered trademark of MIDAS Information Technology Co., Ltd.   
NASTRAN is a registered trademark of the National Aeronautics and Space Administration (NASA).  
NISA II is a trademark of Engineering Mechanics Research Corporation.  
ScreenCam is a trademark of Lotus Development Corporation.  
Sentinel is a trademark of Rainbow Technologies, Inc.  
STAAD Pro is a trademark of Research Engineers, Inc.  
Windows is a trademark of Microsoft Corporation.  
Internet Explorer is a trademark of Microsoft Corporation. 
  

http://www.midasuser.com/�
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PROGRAM VERIFICATION AND PRECAUTIONS BEFORE GETTING STARTED 
 
MIDAS Family Programs produce accurate analysis results based on up-to-date theories and numerical 
techniques published in recognized journals. The programs have been verified by thousands of examples 
and comparative analyses with other S/W during the development.  
 
Since the initial development in 1989, MIDAS Family Programs have been accurately and effectively 
applied to over 5,000 domestic and overseas projects. 
 
A strict verification process of the Computational Structural Engineering Institute of Korea has 
scrutinized MIDAS Family Programs. 
 
Due to the complex nature of structural analysis and design programs, which are based on extensive 
theories and design knowledge, the sponsors, developers and participating verification agencies do not 
assume any rights or responsibilities concerning benefits or losses that may result from using MIDAS 
Family Programs. The users must understand the bases of the programs and the User’s Guide before 
using the programs. The users must also independently verify the results produced by the programs.  
 
 
 
DISCLAIMER 

 
Developers and distributors assume no responsibility for the use of MIDAS Family Program (midas Civil, 
midas FEA, midas FX+, midas Gen, midas Drawing, midas SDS, midas GTS, SoilWorks, midas NFX ; 
hereinafter referred to as “MIDAS package”) or for the accuracy or validity of any results obtained from 
the MIDAS package. 
 
Developers and distributors shall not be liable for loss of profit, loss of business, or financial loss which 
may be caused directly or indirectly by the MIDAS package, when used for any purpose or use, due to 
any defect or deficiency therein. Accordingly, the user is encouraged to fully understand the bases of the 
program and become familiar with the users manuals. The user shall also independently verify the results 
produced by the program. 
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Preface 
 
Welcome to the midas Civil program.  
midas Civil is a program for structural analysis and design in the civil engineering domains. The program 
has been developed so that structural analysis and design can be accurately completed within the shortest 
possible time. The name Civil represents Civil structure analysis and design. 
 
 
 
About midas Civil and MIDAS Family Programs 

 
midas Civil is a part of MIDAS Family Programs that have been developed since 1989. 
MIDAS Family Programs are a group of Package Software that systematically integrates the entire 
design process generally encountered in the design of structures. MIDAS Family Programs consist of 
the following entities: 
 

Bridge  
Engineering 

midas Civil Integrated Solution System for Bridge and Civil Engineering 

midas FEA Advanced Nonlinear and Detail Analysis System 

midas FX+ General Pre-Processor for Finite Element Analysis 

Geotechnical 
Engineering 

midas GTS Geotechnical and Tunnel Analysis System 

SoilWorks Geotechnical Solutions for Practical Design 

Building  
Engineering 

midas Gen Integrated Analysis and Design System for General Structures 

midas SET Structural Engineer’s Tools 

Midas DShop Auto-Drafting Module for midas Gen 

midas FX+ General Pre-Processor for Finite Element Analysis 

Mechanical 
Engineering 

midas NFX Total Solutions for True Analysis-driven Design 

Nastran FX Practical Solutions for True Analysis-driven Design 

 
Among MIDAS Family programs, “midas Civil”, “midas FEA”, “midas Gen”, “midas Set”,  “midas 
FX+”, “midas GTS” and “midas SoilWorks” are currently in use and have been applied to over 5,000 
projects.  
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Advantages and Features of midas Civil 
 
MIDAS Civil has been developed in Visual C++, an object-oriented programming language, in the 
Windows environment. The program is remarkably fast and can be easily mastered for practical 
applications. By using the elaborately designed GUI (Graphic User Interface) and the up-to-date Graphic 
Display functions, a structural model can be verified at each step of formation and the results can be 
directly set into document formats. 
 
During the development process, MIDAS Civil has been verified through numerous examples. Each of 
the functions has been verified by comparing the results with theoretical values and output from other 
similar programs. The program has been applied to over 5,000 projects and the reliability and 
effectiveness have been established. 
 
Representative examples are in the Verification Manual. The latest theories form the bases for the finite 
element algorithm that determines the accuracy of analysis results. Excellent results are achieved 
compared to other similar programs.  
 
 
 
Closing Remarks 

 
MIDAS Civil has been conceived as a result of the cooperation and efforts by a number of engineers and 
professors. We expect that midas Civil users will be pleasantly surprised with satisfying results. The users 
are encouraged to contact MIDAS IT to suggest any improvements that they feel can be implemented in 
subsequent versions. 
 
In closing, we extend our gratitude to everyone who participated in the development of midas Civil.  
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About the User’s Guide 
 
The User’s Guide for midas Civil consists of the following 3 volumes and the On-line Manual: 
 

Volume 1 Getting Started  
Summary of the program contents and items to become familiarized 
before getting started  
 

Volume 2 Analysis 
Explanation of the analysis backgrounds 
 

Volume 3 Verification Examples 
Illustration of verification examples 
 

On-line Manual Detailed directions and explanations for each built-in function 
 
 
 
Understanding the User’s Guide is essential in effectively learning the characteristics and functions of 
midas Civil. The following is a recommended reading sequence before getting started with the program. 
 
First, read the commentaries on the structural analysis and design functions of midas Civil in Volume 2. 
Volume 2 describes the fundamentals necessary to perform finite element analysis using midas Civil. Some 
technical journals have reported that the probability of incurring errors exceeds 90% when programs are 
used with poor knowledge of analysis theories and of the programs. 
 
Install midas Civil following the procedure described in the “Installation” section of Volume 1. Read 
other parts of Volume 1, which outline the fundamental concepts necessary to run midas Civil. Also 
contained in Volume 1 are the following: the directions for various functions to run midas Civil 
efficiently, functions for modeling such as “Preferences setting”, “Input Data”, “Manipulation of Model 
Window”, “Selection Functions and Activation/Deactivation Functions”, and functions required for real 
analysis operations such as “Modeling”, “Analysis”, “Interpretation of Analysis Results”, etc. 
 
Detailed directions and explanations for each function are described in the On-line Manual that can be 
accessed from the Help Menu of midas Civil. 
 
Execute the documents of the “Tutorials” included in the midas Civil CD. The “Tutorials” supply the 
modeling, analysis and results interpretation processes of simple structural examples. Practice midas 
Civil following the procedures described in the “Tutorials”. The Tutorials are organized so that when all 
the step-by-step stages from modeling to the analysis and design of practical examples are followed, the 
user understands and acquires the capabilities of the program. If, at any time, some contents remain 
misunderstood, the user may refer to the relevant sections contained in the On-line Manual. 
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Volume 3 presents Verification Examples. The results of midas Civil have been verified by comparisons 
with theoretical values and results from other programs. Representative examples have been selected and 
included in the Verification Manual. Contemporary theories have been applied to the finite element 
algorithm that determines the accuracy of analysis results. Compared to the results from other similar 
programs, midas Civil produces excellent results. 
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About midas Civil 
 
 
 
 
 
 

Summary 
 
midas Civil is the ultimate Integrated Civil Engineering Solution for designing 
bridges and general civil structures. It retains construction stage analysis 
capabilities for Prestressed/Post-tensioned concrete, Suspension, Cable Stayed, 
Specialty and Conventional bridges and Heat of hydration. 
 

 
Completed analysis model of a suspension bridge 
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midas Civil, developed in the object-oriented programming language Visual 
C++, fully exploits the advantages and the characteristics of the 32bit Windows 
environment for technical computations.  
 
The user-oriented input/output functions are based on sophisticated and intuitive 
User Interface and up-to-date Computer Graphics techniques. They offer 
excellent facilities and productivity for the modeling and analysis of complex, 
large-scale structures. 
 
The technical aspects of structural analysis functions necessary in a practical 
design process are substantially strengthened. Nonlinear elements such as Cable, 
Hook, Gap, Visco-elastic Damper, Hysteretic System, Lead Rubber Bearing 
Isolator and Friction Pendulum System Isolator are included in the Finite 
Element Library, which will surely improve the accuracy and the quality of 
results. Construction stages, time dependent material properties and 
geometric/boundary nonlinear analyses are some of the new inclusions. 
 

 
                                        Eigenvalue analysis results of Suspension Br. for seismic design 
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Detail analysis of a cable anchor connection 

 

 
Detail analysis of a tunnel junction with auto-generated mesh and soil springs 
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The MIDAS in-house researchers have developed an efficient CAD modeling 
technique, which is a totally new concept. Powerful automatic modeling 
functions such as Auto Mesh Generation and Bridge Wizards are introduced. 
Once the basic section and bridge information and tendon placement data for the 
case of a PSC bridge are provided, the Wizard creates the completed bridge 
model as well as the construction stage models. Also, a new Multi-frontal Sparse 
Gaussian solver has been added lately, which has accelerated the analysis speed 
dramatically. 
 
midas Civil has the following areas of applications: 
 

 Analysis and design of all types of bridges 
3-D Reinf. conc., Steel, Composite, Post-tensioned, Suspension & 
Cable stayed bridges  

 Heat of hydration analysis of Mass concrete 
Abutments, Piers, Breakwaters, Subways, Foundations  

 Underground structures 
Subways, Culverts, Sewage & Water treatment facilities, Tunnel linings  

 Plant & Industrial facilities 
Power plants, Transmission towers, Pressure vessels, Water tanks  

 Public facilities 
Airports, Seaports, Train stations, Stadiums, Dams, Ports, Transportation 
facilities 
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Acceleration of Bridge by construction stages 

 

 
Detail analysis of a Transverse tube  
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Detail analysis of a cable anchor Plug-in 

 

 
T-type bridge pier 
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Cutting Plane of heat of hydration analysis results 
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Installation  
 
System Requirements 
 
 
midas Civil operates on IBM compatible Personal Computer (PC) in the Windows 
environment.  
 
In addition, midas Civil requires the following minimum configuration:  
 
 
 
 
 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Operating System 

Microsoft Windows 2000 / XP / VISTA / Windows 7 
MS Internet Explorer Version 6.0 or later version 
 
<Warning> In Windows Vista Operating System, program 
compatibility issue occurs in some functionality.   

CPU Pentium IV or better performing PC processor  
 (Pentium IV 3GHz or greater recommended) 

Memory (RAM) 1GB (2GB  or greater recommended) 

HDD Space 5 GB (30GB or greater recommended) 

Video Memory 128 MB or greater 

Video Card 
GeForce NVIDIA type video card recommended  
 
(On-board video card is not recommended.) 
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Installation Sequence 
 
 
Installing midas Civil 
 
Follow the steps below to install midas Civil. 
 
 

1. Insert midas Civil CD into the CD-ROM drive.  
 
2. midas Civil Installation  

 
 When the automatic installation does not proceed, select the Run 

command in the Start menu of Windows. Once the CD-ROM drive 
is assigned, enter the following command: 

 
E:\setup 
(Note: this is the case where CD-ROM drive is assigned to the 
directory E) 

 

 
Installation dialog box of midas Civil 
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3. Once the installation program is initiated, the dialog box shown in the 
figure above is displayed and the installation of midas Civil begins. 
The installation will proceed step-by-step to the subsequent phases 
following the displayed information. To proceed to the next step, click 

. To return to the previous step, click . 
 

4. midas Civil will be installed only in the system where Internet Explorer 
version 6.0 or higher has been installed. Install Internet Explore if not 
already installed and install midas Civil. 

 
midas Civil information dialog box 

 
5. When the license agreement dialog box is displayed, read the agreement 

carefully. If the terms and conditions are agreeable click , and 
the installation will continue. 

 
6. Enter the user’s registration information and click . 

 
7. The directory selection dialog box will appear. Select the folder in which 

midas Civil will be installed. midas Civil can be installed in   the default 
folder by clicking . To change the folder, click  and 
choose the folder in which to install midas Civil. 

 
8. Once the program folder selection dialog box is displayed, select a 

folder name for the registration of midas Civil icons and other related 
programs. Click the  button and copying the files will begin. 

 
9. Once the copying of the files is complete, the “installation completed” 

message dialog box will appear. Click  and the installation 
process now will be completed. If at this time “Review animations of 
Tutorials” is checked and  is clicked, then the installation will 
be completed and the animation file will be executed immediately.  
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Installing Sentinel/pro Driver  
 
 
The Sentinel Driver is used to drive the Lock key of Sentinel hardware. To run 
midas Civil and the Lock key the driver has to be installed. The Sentinel Driver 
is installed automatically during the installation process of midas Civil. For 
upgrading or replacing a damaged Lock driver, follow the procedure outlined 
below. 
 
To install the Sentinel Driver manually follow these steps. 
 
 

1. Press the left side Shift key and insert the midas Civil CD in your CD-
ROM drive.  

 
2. Select the Run command in the Start menu. Once the CD-ROM drive is 

assigned, enter the following command: 
 

E:\civil_ install\protection drivers\setup 
(Note: this is the case where CD-ROM drive is assigned to the 
directory E) 

 
 
 
 
To uninstall the Sentinel Driver follow these steps.  
 
 

1. Press the left side Shift key and insert the midas Civil CD in the CD-
ROM drive.  

 
2. Select the Run command in the Start menu. Once the CD-ROM drive is 

assigned, enter the following command: 
 

E:\civil_ install\protection drivers\setup 
(Note: this is the case where CD-ROM drive is assigned to the 
directory E) 
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Registering the Protection Key  
 
 
To operate midas Civil properly, register the serial number after connecting the 
protection key to the parallel port.  
 
 

1. Connect the Protection Key to the Parallel Port. 
 

2. Execute midas Civil. 
 

3. Select  Register Protection Key in the main menu. 
 

4. Enter the Protection Key ID provided in the Program CD Case in the 
Protection Key field. 

 
5. Click . 
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How to Use the On-line Manual 
 
When using midas Civil, pressing F1 key or clicking the Help menu can always 
allow us to access the On-line Manual.  
 
Every category of help is connected to related keywords by hyperlink, and all the 
detailed explanations and information in connection with the keyword may be 
obtained. 
 
A summary of the help contents and an index of the main keywords are arranged 
systematically in the On-line Manual of midas Civil. Read it as a reference in 
the order presented in the summary. Alternatively, the information regarding the 
desired item may be directly obtained using the Search function of the 
keywords. 
 

 
On-line Manual of midas Civil 

  Symbol in On-line 
manual signifies that the 
Mouse editor is 
supported for the 
corresponding data entry 
field. The Mouse editor 
replaces the keyboard 
function for defining 
materials, distances, etc. 
on the screen. 
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Recognition of Input/Output Files 
 
The types of files, their purposes and the generation process are as follows:  
 
 
 
Data Files 
 
 

fn.mcb Binary The basic data file of midas Civil 
 
During the initial generation, use >New Project. 
When opening an existing file, use >Open Project. 
 

fn.mct Text The basic data file of midas Civil 
 
If necessary, it can be modified using Text Editor. 
The user may transform the data generated by midas 
Civil into a format suitable for other S/W. The data 
file can also be used for MCT Command Shell. 
 
 >Export>Civil MCT File creates a file and  

>Import>Civil MCT File recalls the file in the 
format used by midas Civil model data. 

 
 

Refer to Tools>MCT 
Command Shell in On-line 
Manual. 
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Analysis Output Files 
 
 

fn.ca1 Binary Data file obtained from a static/dynamic analysis process 
File generated automatically by Analysis>Perform 
Analysis  

fn.ca2 Binary Analysis results generated for each time step from a  time 
history analysis and a heat of hydration analysis 
File generated automatically by Analysis>Perform 
Analysis  

fn.ca3 Binary File for all the data obtained from a moving load analysis, 
influence line/influence surface and support settlement 
analyses 
File generated automatically by Analysis>Perform 
Analysis  

fn.ca4 Binary File for all the analysis data generated in the process of a 
geometric nonlinear analysis 
File generated automatically by Analysis>Perform 
Analysis  

fn.ca5 Binary File for all the analysis data generated in the process of a 
pushover analysis 
File generated automatically by Design>Perform Pushover 
Analysis  

fn.ca6 Binary File for all the analysis data generated in the process of 
construction stage analysis 
File generated automatically by Analysis>Perform 
Analysis  

fn.anl Text File containing structural analysis results (reactions, 
displacements, element forces, stresses, etc.) which has been 
arranged by the user’s preference. This file is useful for 
verifying analysis results and preparing calculation sheets.  
File generated automatically by Results>Text Output  

fn.out Text All kinds of messages or related data produced during a 
structural analysis process 
File generated automatically by Analysis>Perform 
Analysis 

fn.cd8 Binary File for all the design data generated in the process of PSC 
design 
File generated automatically by PSC>Perform Design  
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Graphic Files 
 
 

fn.color Binary Color data file of midas Civil   
Click  in Color and Print Color tabs from 
the View>Display>Display Option.  

fn.emf Binary Graphic data file of the model window in the EMF 
(Enhanced Meta File) format   
File generated automatically by >Print Meta File  

fn.bmp Binary Graphic data file of the model window in the BMP 
(Bitmap) format  
File generated automatically by >Graphic File  

fn.jpg Binary Graphic data file of the model window in the JPEG  
format  
File generated automatically by > Graphic File  

fn.mgf Binary Graphic data file produced by Graphic Editor of 
midas Civil  
File generated automatically by the Save function of 
Tools>Graphic Editor 

 
 
 
Data Transfer Files 
 
 

fn.dxf Text AutoCAD DXF file compatible with data for midas 
Civil 
 

fn.s90 Text Data file of SAP90 compatible with data for midas 
Civil 
 

fn.s2k Text Data file of SAP2000 compatible with data for midas 
Civil 
 

fn.std Text Data file of STAAD compatible with data for midas 
Civil 
 

fn.gti Text Data file of GT STRUDL compatible with data for 
midas Civil 
 

 

Refer to “File>Import/ 
Export/Data Conversion” 
of On-line Manual.  
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Other Files 
 
 

fn.bak Binary Back-up data file of midas Civil  
Select Make Backup File in Tools>Preferences to 
create the file automatically while saving the model 
data in progress.  

fn.bom Text Weight data file of every element included in the 
modeling and bill of material  
File generated automatically by Tools>Bill of 
Material  

fn.sgs Text Seismic data file produced by the seismic acceleration 
and response spectrum generation module of midas 
Civil   
It uses Tools>Seismic Data Generator.  

fn.spd Text Response spectrum data file required for a response 
spectrum analysis.  
File produced by Load>Response Spectrum Analysis 
Data>Response Spectrum Functions  

fn.thd Text Time History Function data file required for a time 
history analysis  
File produced by Load>Time History Analysis Data 
>Time History Functions  

fn.bog Binary File containing the data entered in the Batch Output 
Generation dialog box  
Among the checking features of analysis results of 
the Results menu, the  button of the 
Batch Output Generation dialog box generates the 
file, which can be accessed by the  
button. 
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Organization of Windows and Menu System 
 
The Menu System of midas Civil permits an easy access to all the functions 
related to the entire process of input, output and analysis and minimizes the 
mouse movement. 
 
The Works tab of Tree Menu systemizes the entire design process, which allows 
us to review the status of input at a glance while the Drag & Drop type of 
modeling capability allows us to readily modify the data during the modeling 
process.  
 
The organization of the working windows of midas Civil and the Menu system 
are as follows:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Organization of the working windows and the Menu system of midas Civil 
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Main Menu 
 
 
The commands and shortcut keys for all the functions necessary to run midas 
Civil are built-in.  

File File, print, data transfer and related functions 

View 
 

Visual presentation method and manipulation functions, 
selection functions, Activation/Deactivation functions, etc. 

Structure 
 

Entering model data and automatic generation of grids, 
groups, etc. 

Node/Element Entering nodes and elements 

Properties Enter material, section, inelastic properties 

Boundary Enter supports, spring supports, links, release conditions, 
offset, etc. 

Load Enter all types of static loads, dynamic loads, thermal loads, 
automatic generation functions, etc. 

Analysis Enter all types of control data necessary for analysis process 
and analysis execution functions. 

Results Enter load combinations, plotting analysis results (reactions, 
displacements, member forces, stresses, vibration modes, 
buckling modes, etc.), verification and analysis functions, 
etc. 

PSC Automatic design of PSC Box girders for ultimate limit 
state and service limit state verification 

Pushover Pushover analysis for seismic design 

Design Automatic design of structural steel, SRC, RC and footings, 
code checking, etc. 

Query Status verification functions for nodes, elements and related 
data 

Tools Assignment of unit system and preferences setting, MCT 
Command Shell, computation of bill of material, extraction 
of seismic data, Sectional Property Calculator, General 
Section Designer, etc. 

 
 

When running CIVIL for 
the first time, the use of 
Main Menu is 
recommended to 
understand the built-in 
functions and the 
working environment. 
Once the user becomes 
familiar with CIVIL, the 
use of Icon Menu or 
Context Menu will be 
more effective. 
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Tree Menu 
 
 
The entire procedure for modeling from data entry to analysis, design and 
preparation of calculations are systemically organized. An expert as well as a 
novice can efficiently work without making errors by accessing the related 
dialog boxes, which provide the procedural guidance. 
 
Also, Works Tree allows the user to glance over the input status of the current 
model data, which can be revised by the Drag & Drop capability. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Drag & Drop capability of Works Tree tab changes the PC beams graphically  
 
 
 
Context Menu 
 
In order to minimize the physical motions of the mouse, simply right click the 
mouse. midas Civil automatically selects a menu system, which offers related 
functions or frequently used functions reflecting the working circumstances of the 
user. 

Drag & Drop 
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Model Window 
 
The working window deals with the modeling, interpretation of analysis results 
and design by means of GUI (Graphic User Interface) of midas Civil. 
 
The Model Window may present several windows simultaneously on the screen. 
Because every window operates independently, different user coordinate systems 
can be assigned to the individual windows to create a model. In addition, each 
window shares the same database and as such, the work performed in a window 
updates the other windows simultaneously. 
 
The Model Window can represent common model shapes as well as shapes 
generated by up-to-date features such as hidden lines, removal of hidden 
surfaces, shading, lighting, dispersion of color tone, etc. The model, analysis and 
design results may be displayed in rendering views. The input status of the 
model or each type of analysis and design results can be visually verified by 
“walking through or flying over” the interiors of structures using the Walk 
Through Effect. 
 
Table Window 
 
Table Windows display all types of data entry, analysis and design results in the 
Spread Sheet format. Various kinds of data modification, additional input, 
compilation, arrangement for different characteristics and searching capabilities 
are provided in Table Windows. They allow transfers with common database 
S/W or Excel. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Data exchange with Microsoft Excel 
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Message Window 
 
 
Message Window displays all types of information necessary for modeling, 
warnings and error messages.  
 
 
 
Status Bar 
 
 
Status Bar presents matters related to all kinds of coordinate systems, unit systems 
conversion, select filtering, fast query, element snap control, etc., which enhance 
the work efficiency. 
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Toolbar and Icon Menu  
 
 
Icon Menu helps the user promptly invoke functions frequently used in midas 
Civil. Each icon is regrouped with the icons of similar purposes in various 
Toolbars. Each Toolbar may be easily dragged with the mouse to the desired 
position on the screen. They may be edited to appear selectively on the screen or 
modified by using Tools>Customize>Customize. For more information on any 
icon in the Toolbar, place the mouse cursor on the icon in question and Tool Tip 
will provide a short description.  
 
Refer to “APPENDIX A. TOOLBAR AND ICON MENU” for more information 
regarding the Toolbars and the corresponding Icons. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Default positions of the Toolbars and status tabs in the window 
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Dialog box of Tools>Customize
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Preferences Setting 
 
 
 
 
 
 

Assignment of Unit System and Conversion 
 
In practice, there are diverse working conditions and forms of data entry. midas 
Civil is designed to operate concurrently under a specific system of units or a 
combination of several types of unit systems. For instance, “m” unit for the 
geometry data and “mm” unit for section data may be used in the same model. 
The “SI” unit system used in the data entry process can be converted into the 
“Imperial” unit system for the analysis and design results.  
 
The thermal unit system requires a consistent unit system for the data. The units 
for moment, stress or modulus of elasticity which combine length units and force 
units are automatically adjusted by the program according to the types of length 
and force units selected by the user.  
 
The user may use Tools>Unit System or the unit system conversion function of 
Status Bar located at the bottom of the screen to assign or convert the system of 
units. 
 

 
 
 
 
 
 
 
 
 
 
 
 
Dialog box of Unit System Setting 
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Preferences Setting 
 
Generally, each project is unique. The size and the material characteristics of a 
structure differ from one another, and it is convenient to define the modeling 
environment in advance when starting a new project. 
 
As the scale of the structure becomes apparent during the initial stage of a new 
project, it is possible to assign the grid spacing using Grid in advance. This will 
avoid additional and cumbersome adjustments of the screen dimensions. 
 
Tools>Preferences of midas Civil allows the setting of the basic data required 
to run the program in advance. 
 
When the Preferences function is selected, the dialog box shown below is 
displayed. Select the entities desired from Tree Menu on the left side and enter 
the required data. 
 
Environment 

General  Provide the user’s name, company logo & set the 
automatic file saving defaults.  

View  Set the default window and its size.  
Data Tolerance  Assign the bounds of nodal combination and the 

upper limit of numerical values to be recognized as 
zero (0).  

Property  Assign the basic database for materials and sections.  
Design  Assign applicable design standards for different 

material type properties.  
Load  Save the database for the floor loads 

 
 
 
 
 
 
 
 
 
 
 
 
 
 

Dialog box for Preferences 
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Output Formats  
Formats  Assign the effective number of decimal points for the 

model data and analysis results. 
 

Refer to On-line Manual for detail information regarding each of the above-
mentioned Preferences. The View function is necessary to set the working 
window at the initial stage of the work as described below. 
 
Initial Model Boundary Size  

Assign the size of the working window. For example, if the length unit is set 
to “m” and “10” is entered, the vertical length of the new window will be set 
to 10m. 

 
Initial Point Grid  

Assign the spacing of point grids to display in the window.  
Grid Space x  Spacing of point grids in x-direction in user 

coordinate system  
Grid Space y  Spacing of point grids in y-direction in user 

coordinate system  
Grid On  Option to display the point grids in the window 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Default window of midas Civil 

Refer to “Preferences 
Setting for Modeling” in 
Getting Started & 
Tutorials 
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Initial View Point  
Assign the window coordinate system to correspond to either an isometric 
view (Iso View) or the global X-Y plane coordinate system. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Initial window after setting the preferences 
 
Notice that the initial window appears as shown in the figure above after 
specifying the following: The length unit is set to “m” in Tools>Unit System. 
The size of the default window is 10m in View of Tools>Preferences. The grid 
spacings in the x & y directions of the coordinate system are set to 1m and 2m 
respectively. 
 
 
Snap 
 
 
Snap is used to assign the snap state. Multiple Snap functions may be assigned 
at a time. When nodes or elements are being entered with the mouse, Snap 
automatically sets the mouse-click point to the closest grid, node or element. 
 
The types of the Snap functions supported by midas Civil are as follows: 

Refer to “Snap” in 
“Nodes and Elements 
Generation” of the 
“Modeling” section. 
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 Point Grid Snap 
Search the point grid contiguous to the mouse cursor. 
Set the point grid by  Define Point Grid of Structure>Grids. 

 
 Line Grid Snap 
Search the intersection of line grids contiguous to the mouse cursor. 
Set the line grid by  Define Line Grid of Structure>Grids. 

 
Node Snap 
Search the node contiguous to the mouse cursor. 

 
Element Snap 
Search the midpoint of the element contiguous to the mouse cursor. 
In the case of a line element, the position of the snap may be adjusted by 
using the Snap point assignment function to the right of the status bar located 
at the bottom of the window. For example, the user may locate the snap at the 
third points of an element ( ). This is an extremely convenient 
feature when a line element is already set up and another line element has to 
be connected to a particular point on that existing element. 

 
 Snap All 
Select all the above-mentioned snap functions. 

 
 Snap Free 
Release all the snap functions. 

 

 
Examples of Snap applications 

Line Element means 
elements of Line Type 
constituted by two 
nodes such as truss or 
beam elements. 

To release Snap types 
separately, click the 
relevant Icon so that it 
switches to Toggle Off 
state. 
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Modeling Preferences Setting 
 
Coordinate Systems 
 
The coordinate systems used in midas Civil are as follows: 
 

 Global Coordinate System (GCS)  
 Element Coordinate System (ECS)  
 Node local Coordinate System (NCS) 

 
The GCS uses the X, Y and Z-axes of the Conventional Cartesian Coordinate 
System with the right-hand rule. The axes are denoted by the capital letters (X, Y, 
Z). Nodal data and the majority of data entry related to nodes, nodal displacements 
and nodal reactions are in GCS. 
 
The GCS is used for the geometric data for the structure. The Reference Point is 
automatically set to the coordinates X=0, Y=0 and Z=0. 
 
In midas Civil, because the vertical direction of the screen is set parallel to the 
Z-direction of the global coordinate system, it is more convenient to coincide the 
vertical direction of the structure (the direction opposite to the direction of 
gravity) with the GCS Z-direction. 
 
The ECS uses the x, y and z-axes of the Conventional Cartesian Coordinate 
System with the right-hand rule. The axes are denoted by the lowercase letters. 
(x, y, z) 
 
Element internal forces, stresses and the majority of data entry related to elements 
are in ECS. 
 
The NCS is used to assign Inclined Support Condition at a particular node. NCS 
uses the x, y and z-axes of the Conventional Cartesian Coordinate System with 
the right-hand rule. The axes are denoted by the notations x, y and z. 
 
Once the Node Local Axes define the node coordinates, the following boundary 
conditions and forced displacements are entered according to the defined node 
coordinates: 
 

 Supports  
 Point Spring Supports  
 General Spring Supports  
 Surface Spring Supports  
 Specified Displacements of Supports 

Refer to Analysis for 
Civil Structure> 
Numerical Analysis 
Model> Coordinate 
Systems and Nodes. 

Refer to Analysis for 
Civil Structure> 
Numerical Analysis 
Model> Coordinate 
Systems and Nodes. 



 
 
 
 

Preferences Setting 
 

31 

User Defined Coordinates and Grids 
 
 
The User Coordinate System (UCS) is the coordinate system additionally 
defined by the user to ease the modeling task. The UCS is defined relative to the 
GCS and can be useful when the geometry is complex. 
 
Generally, the majority of structures in practice are constituted in 3-D with 
various unit-planar structures. The structure is decomposed into a number of 
planes. For each plane, apart from the GCS, a coordinate system convenient for 
the modeling task is assigned. Once the individual segments are modeled, these 
planes are reassembled with respect to the GCS, and the overall 3-D shape now 
becomes effectively complete. The UCS is used mainly for such purpose and 
assigns a local coordinate system for each unit-planar structure. 
 
User-defined Coordinate System may be saved with pre-defined titles (Named 
UCS), which can be recalled interchangeably with GCS. 
 
 

 
 UCS and the grid layout 

  

Refer to “Open File and 
Setting of Preferences> 
Working Plane and 
Grids” in Tutorial 1 to 
understand this 
procedure. 

An example of UCS and 
Grid Line assignment for 
entering beam elements 
located at different 
angles 
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When entering coordinates or elements, assign the grids to coincide with the 
UCS x-y plane. Such technique is extremely convenient for modeling. 
 
midas Civil supports the following two types of grid system: 
 

 Point Grid  
 Line Grid 

 
The point grid represented by a series of points on the UCS x-y plane is parallel 
with the x & y-axes, and each point is set equally apart. Generally, during the 
initial stage of modeling, set the point grid by Tools>Preferences. Depending on 
the work conditions, use View>Grids>Define Point Grid to reassign the grid. 
 
The line grid, as a grid represented by lines at right angles on the UCS x-y plane, 
is positioned parallel with both x and y directions. The spacing may be unequal. 
 
Set the line grid by  Define Line Grid. 
 
Each grid system can be positioned at the same time, and it is convenient to use 
Snap to automatically locate the mouse cursor to a contiguous grid. 
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Entering Data 
 
 
 
 
 
 

General 
 
All the data are entered with the Dialog Box, Table Window, MCT Command 
Shell and Model Window in midas Civil. Using the Dialog Box, the data can be 
entered by both mouse and keyboard. The keyboard is mainly used for the Table 
Window and MCT Command Shell, and the mouse is mainly used for the Model 
Window. 
 
In the Dialog Box, the following buttons are used to reflect or cancel the data entry 
in the model. 
 

 Reflect the data entry in the model and, at the same time, close 
the corresponding operation and the dialog box. 
 

 Reflect the current data entry in the model and continuously 
accept any additional data entry and modification maintaining 
the dialog box active. 
 

 Cancel the current data entry and close the dialog box. 
 

 Close the dialog box. 

 
When shifting the focus from one data entry to another in a Dialog Box, use the 
Tab key on the keyboard to move successively from one data field to the next, or 
directly specify data by placing the mouse cursor over the desired data field. 
 
If the Shift+Tab key is used, the input sequence will be reversed. 
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Dialog box in the form of dialog bar                                 Dialog box 
 
The Table Window is a Spread Sheet type window where all the data entry and 
design results can be viewed at a glance. It allows the user to make any additional 
data entry or modification. 
 
MCT Command Shell is a unique modeling feature, which allows the user to 
enter data by text type commands. 
For more details concerning the applications, refer to the On-line Manual. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Elements’ table window  

Table Window of midas 
Civil offers data 
input/output and 
modification capabilities. 
In addition, it provides all 
types of selection 
functions, Filtering, 
Sorting and Graph 
functions, data 
exchange with Excel, 
etc. 
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Data Input Commands 
 
For convenience, midas Civil provides the following data entry options: 
 
 

 Where several numerical data are entered consecutively in a data field, 
these data can be distinguished by a “,” (Comma) or a “  ” (Blank) 

 
 <Example> ‘333, 102, 101’ or ‘333 102 101’ 

 
 Position data, element sections and properties and other relevant data 

can be entered by simple assignments in the Model Window.  
 

 Length or directional increments can be specified using the mouse by 
choosing the relevant origin and ending points in the Model Window 
rather than typing these data directly on the keyboard. 

 
 Where the same length is repeated, the entry can be simplified by 

“number of repetition @ length” instead of repeating the same number.  
 

 <Example> 20, 25, 22.3, 22.3, 22.3, 22.3, 22.3, 88  20, 25, 5@22.3, 88 
 
The keyboard may be used to enter selected data directly. The related node 
numbering or element numbering may be an arithmetic progression in series or 
the progression may be incremental. Then, the data entry can be simplified by 
“start number to (t) final number” or “start number to (t) final number by 
increment”.  
 

< Example> 21, 22, … , 54, 55, 56  “21 to 56”, “21 t 56” 
 

< Example> 35, 40, 45, 50, 55, 60  “35 to 60 by 5”, “35 t 60 by 5” 
 

 Numbers and mathematical expressions can be used in combination. 
The majority of the operators and parentheses applied in engineering 
computation can be used. 

 
<Example> π × 202  PHI * 20^2 

 

<Example> 




 ++×+  30sin30cos230sin335 22  

“35 + 3 * (sin(30) + 2 * SQRT(cos(30)^2+sin(30)^2))” 
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Notation Content Remarks 

( Open parenthesis – 

) Close parenthesis – 

^ Power of n 
( ^2→square, ^3→cube) Ex.: 23 = 2 ^ 3 

+ Addition – 

– Subtraction – 

* Multiplication – 

/ Division – 

PI π 3.141592653589793 

SQRT  Ex.: 2  = SQRT(2) 
SIN Sine Unit: Degree 

COS Cosine Unit: Degree 

TAN Tangent Unit: Degree 

ASIN Arc Sine Ex.: sin-1(0.3)=ASIN(0.3) 

ACOS Arc Cosine Ex.: cos-1 (0.3)=ACOS(0.3) 

ATAN Arc Tangent Ex.: tan-1 (0.3)=ATAN(0.3) 

EXP Exponential function Ex.: e0.3 =EXP(0.3) 

SINH Hyperbolic Sine Ex.: sinh(1)=SINH(1) 

COSH Hyperbolic Cosine Ex.: cosh(1)=COSH(1) 

COTAN Cosine/Sine Ex.: cotan(1)=COTAN(1) 

LN Natural Logarithm – 

LOG Common Logarithm – 

Built-in operators in midas Civil 
 
§ Highlights of usage  

1. Operators accept the mixed use of capital and lowercase letters. 
 

2. As the operators are similar to that of an engineering calculator, the 
hierarchy of operations follows the rules of common mathematical 
operations. 
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Manipulation of 
Model Window 

 
 
 
 
 
 
midas Civil offers various Model Window Handling capabilities for 
sophisticated and realistic visual representation of the model generation, analysis 
and design results. 
 
Model Window Handling functions can be invoked from the View menu or by 
simply clicking the icons in Toolbar. 
 
 
 

Model Shape Representation 
 
The Model Shape Representation functions of midas Civil such as Wire Frame, 
Hidden, Shrink, Perspective and Render View present the model in diverse 
shapes and views. These functions help the user grasp the input state of the 
model and manipulate the model as much as desired.  
 
The Model Shape Representation functions of midas Civil are as follows: 
 

 Shrink 
Display the modeled elements in proportionally reduced sizes. 

 
 Perspective  
Display a perspective 3-dimensional view of the model. 

 
 Hidden  
Display the model shape reflecting the sectional shapes of elements and their 
thicknesses as it would truly appear. 

 

  Shrink is typically 
used to check the 
connectivity of nodes 
and elements. 
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Arch Bridge: Shrink, Perspective and Hidden Views 
 
 

 Render View 
Display the model shape reflecting the sectional shapes of elements and their 
thicknesses with a shadowing effect as it would truly appear. 

 
 Rendering Option 
Modulate the effects of lighting and shadowing of Render View. 

 
 Display 
Display in the working window the nodal and element numbering, material 
and sectional designation, the loading input state, etc.  

 
 Display Option 
Control all the graphics displayed in the working window including all types 
of display modes such as the color palette of characters, the displayed size, 
etc. 

 
 

Refer to Model>Verify 
input results>  
Display Option section. 

The Size and Draw tabs 
in  Display Option 
controls the Factor and 
Scale adjustment, and 
the reflection of the 
thickness related to 
Model Shape 
Representation. 

The Rendering function 
is provided in the 
window, and the Render 
View is used to apply the 
functions such as 
Blending. 

This model is viewed 
with Shrink, Perspective 
and Hidden using the 
Model  
Shape Representation 
Toolbar. 
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Render View: Model of Cable Stayed Bridge  
 
 
 

Zoom in/out and Motion Control  
(View Manipulation Functions) 

 
All the View Manipulation functions of midas Civil with the  Render View 
function assist the user to accurately grasp the three-dimensional views of the 
model input state and the analysis and design results through diverse view angles 
and points. 
 
The View Manipulation functions of midas Civil are as follows: 
 
View Point 
 

 Iso View 
Represent the model in a three-dimensional space. 

 
 Top View 
Represent the model as viewed from the +Z direction. 
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 Right View 
Represent the model as viewed from the +X direction. 

 
 Front View 
Represent the model as viewed from the +Y direction. 

 
 Angle View 
Represent the model as viewed from a specified viewpoint. 

 
 
Rotate 
 

 Rotate Left 
Rotate the model to the left (clockwise about Z-axis). 

 
 Rotate Right 
Rotate the model to the right (counterclockwise about Z-axis). 

 
 Rotate Up 
Rotate the model upward from the horizontal plane. 

 
 Rotate Down 
Rotate the model downward from the horizontal plane. 

 
 
Zoom 
 

 Zoom Fit 
Fit the model to the screen size by scale up/down. 

 
 Zoom Window 
Assign the desired size of the window by dragging a corner of the window 
with the mouse. 

 
 Zoom In 
Magnify the current window gradually. 

 
 Zoom Out 
Reduce the current window gradually. 
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Pan 
 

 Pan Left 
Move the model window to the left. 

 
 Pan Right 
Move the model window to the right. 

 
 Pan Up 
Move the model window upward. 

 
 Pan Down 
Move the model window downward. 

 
 
 

Dynamic View Manipulation 
 
The Dynamic View of midas Civil provides Zoom, Pan and Rotate functions. It 
displays realistic views of the structure in real time from the desired viewpoint 
by keeping the mouse left-shifted and dragging the mouse. 
 
By linking Dynamic Zoom/Rotate and Render View, we can look inside and 
walk through the structure (Walk Through Effect) or fly over the structure. 
 
 
 
 
 
 
 
 
 
 
 
 
 

Zoom Dynamic Illustration 
 
 
 

The proportioning of 
screen manipulation for 
Zoom, Pan and Rotate is 
controlled in the Size tab 
in  Display Option. 

Keeping the mouse left-
shifted and dragging the 
mouse downward or to 
the left reduces the 
window. 

Keeping the mouse left-
shifted and dragging the 
mouse upward or to the 
right magnifies the 
window. 
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Pan Dynamic View 
 
Example of Rotate Dynamic application

Using  Rotate 
Dynamic, drag the 
mouse cursor downward 
or upward. 
The View Point will 
move downward or 
upward following the 
drag direction. 

Using  Rotate 
Dynamic, drag the 
mouse cursor to the left 
or right. The View Point 
will move to the left or 
right following the drag 
direction. 

By keeping the mouse 
left-shifted and moving 
the mouse cursor, the 
model window will 
follow the course of the 
mouse. 

Mouse Drag Direction 

Model Rotation Direction 

Model Rotation 
Direction 

Model Rotation 
Direction 
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Selection and 
Activation / Deactivation 

 
 
 
 
 
 

Selection 
 
The Selection functions are extremely important and indispensable for the overall 
task of generating a model. It allows duplication of nodes and/or elements, with or 
without the same attributes such as loading or boundary conditions, activation of 
special parts, verification of input and output data, etc.  
 
The Selection functions supported by midas Civil are as follows: 
 

 Select Identity-Nodes  Select Identity-Elements 

 Group  Select Single 

 Select Window  Select Polygon 

 Select Intersect  Select Plane 

 
Select Volume  Select All 

 
Select Previous  Select Recent Entities 
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Graphical Selection 
 
 

 Select Single 
 

Select the desired entities by clicking the mouse once each time. To unselect 
the selected entities click them once again. The Select Window feature can be 
effected by dragging the mouse left-shifted from a fixed point. 

 
 Select Window      Unselect Window  

 
Click the diagonal corners of a window containing the entities with the mouse 
cursor and select or unselect the desired nodes or elements. 

 
When assigning the window, select only the nodes and elements completely 
contained within the window by dragging the mouse cursor from left to right. 

 
When assigning the window, select all the elements that are contained inside 
the window as well as the elements intersecting the boundaries of the window 
by dragging the mouse cursor from right to left.  

 
 

 
Select plate elements successively one by one with Select Single 
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Select by Window 

Drag the mouse cursor 
from left to right. The 
elements that are not 
completely contained in 
the window boundaries 
will not be selected. () 

Drag the mouse cursor 
from right to left. Even 
those elements crossing 
the window boundaries 
will be selected. () 

 

Mouse Dragging Direction 

Mouse Dragging Direction 
 
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 Select Polygon      Unselect Polygon 
 

Select or unselect the desired nodes and/or elements by successively clicking 
the corners of the polygon containing the relevant entities with the mouse 
cursor. 

 
When clicking the final corner, left-click the mouse twice. The polygon linking 
the final corner and the starting point is created, and all the nodes and elements 
contained inside the polygon are selected. 

 

 
 Select Polygon 
 
 

 Select Intersect      Unselect Intersect  
 

Select or unselect elements by crossing a series of lines that intersect the 
desired elements with the mouse cursor in the Model Window. When clicking 
the final point of the last line, left-click the mouse twice. This terminates the 
selection process. 

 
 
 
 
 
 
 
 
 
 
Select Intersect 
 

To enter a loading 
acting on an inclined 
roof, select only the 
beam elements on the 
slope. 

To modify the boundary 
conditions at the 
supports, select only 
the supports by forming 
a polygon. 

In the process of 
element meshing, plate 
elements can be readily 
selected by Intersect. 

To modify the element 
types, select the vertical 
and diagonal members 
of the truss roof. 



 
 
 
 

Selection and Activation / Deactivation 
 

47 

 Select Plane      
 

By assigning a particular plane, select or unselect all the nodes and/or 
elements contained in the plane. 

 
Observe the following methods to select a plane: 

 
3 Points 

Specify 3 points located in the desired plane. 
 

XY Plane 
For a plane parallel to the X-Y plane, specify a Z coordinate of the desired 
plane. 

 
XZ Plane 

For a plane parallel to the X-Z plane, specify a Y coordinate of the desired 
plane. 

 
YZ Plane 

For a plane parallel to the Y-Z plane, specify an X coordinate of the 
desired plane. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

     Select Plane by 3 Points 

Planes non-parallel to 
GCS or UCS can be 
easily assigned by 
means of 3 Points. The 
figure shows an inclined 
roof lying in a plane 
assigned by 3 Points 
placed on the grids. 
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 Select Volume   
 

To assign a particular hexagonal volume, select and/or unselect all the nodes 
and elements contained in the volume. 

 
Observe the following methods to select a hexagonal volume: 

 
 

 
       Select Volume  

Click  and 
select the volume by 
modifying only the 
necessary coordinates. 
The part of the structure 
contained within the 
minimum and maximum 
coordinates will appear. 
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2 Points 
Select two points of the diagonal corners of the desired hexagonal 
volume. 

 
XYZ Limit 

Enter the coordinates of the range of the desired hexagonal volume for 
each axis. 

 
 

 Select All      Unselect All 
 

Select or unselect all the nodes and/or elements. 
 
 
 
Specified Selection 
 
 
  Select Identity  
 

Select the desired entities by physical or geometrical identities, i.e., select 
nodes or elements with identical attributes, types or groups.  

 
Entities can be selected by each identity separately or multi-identities 
simultaneously. 

 
The types of identities that can be selected are as follows: 

 
Element Type Selection by type of element 

 
Material Selection by type of material attribute 

 
Section Selection by type of section 

 
Thickness Selection by type of thickness 

 
Named Plane Selection by name of plane 

 
Story Selection by ID of story 

 
Supports Selection of nodes by support condition 

 
Beam End Release Selection of beams by beam end release condition 

 
Wall ID Selection by wall combination numbering 

 
Structure Group Selection by element group 

 
Boundary Group Selection by boundary group 

 
Load Group Selection by load group  

Specified Selection 
 

 Select Identity-Nodes 
 Select Identity-

Elements 
 Group Selection 
 Select Previous 
 Select Recent Entities 
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Select the desired types in the Identity list shown in the figure above. Select or 
modify the selected entities subsequently and selectively as required. Alternatively, 
one of the elements having the identity in the Model Window can be selected with 
the mouse cursor. 
 

 
Select Identity – Section 
 
 

 Select Previous 
 

Reselect the entities selected in the previous step.  
 

 Select Recent Entities  
 

Select the nodes or elements most recently generated during the modeling 
exercise. 

 
 

A section type is  
selected to modify 
Element Type using  

 Select Identity-
l t  
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Group 
 
 

 Group 
 
midas Civil allows us to define Structure group by grouping nodes and 
elements and Boundary Group and Load Group for boundary conditions and 
loadings attributed to the nodes and elements. The three groups are subsequently 
used in combination for defining construction stages. 
 
First, assign a structure group name and designate relevant nodes and elements 
by various Select functions. Using Drag & Drop under the Group tab of Tree 
Menu, we can assign the relevant nodes and elements appropriate group names. 
In particular, it is extremely useful for modeling complex structures by selecting 
and activating certain groups without a repetitive process of selection. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Group dialog bar 
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The common procedure for applying Structure Group is as follows: 
 
Register the desired nodes and elements as a Group 
 
 

1. Select Model>Group>Define Structure Group (or click  Group, 
select Structure Group from the Group tab of Tree Menu and select 

 after right-clicking the mouse. 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Define Structure Group 

 
2. Enter a group name in the Name field with Suffix numbers and click the 

 button to create a number of structure groups simultaneously. 
 

3. Using the selection functions, select the relevant nodes and elements to 
be assigned to the structure groups. 

 
4. Define structure groups using Drag & Drop of Tree Menu. 
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Define Boundary Groups and Load Groups similarly. 

 

 
Group Selection (Element Selection using Tree Menu) 
 

Change of section properties by a simple operation of Drag & Drop of Works 
Tree tab  

Using Model>Group> 
Change Boundary 
Group/Change Load 
Group the existing 
boundary conditions 
and loading groups can 
be copied, moved and 
deleted to create other 
groups. 

Double-click the 
selected group in Tree 
Menu to select the 
corresponding nodes 
and elements. 

Right-clicking in the 
selected group of Tree 
Menu permits us to 
carry on many different 
tasks. 
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Filtering Selection 
 
 
Filtering Selection chooses line elements selectively based on the elements’ 
directional orientation while applying the Graphical Selection or Specified 
Selection features. When the desired entities are selected by Graphical Selection, 
only the line elements satisfying the Filtering Condition are selected upon 
defining the direction of axis or plane from the filter selection field illustrated in 
 below. 
 
To apply Specified Selection, define the desired entities and click the Filtering 
button ( ) illustrated in  below to select only the elements satisfying the 
Filtering condition among the selected line elements.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

When y-axis is selected 
in the Filter selection field 
and specific selection 
functions are executed, 
only the elements parallel 
to the y-axis will be 
selected. 

 Filter selection 
 

 Filter selection 
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Model Activation/Deactivation  
 

 Active /  Inactive is used to partially activate or inactivate specific parts of 
a structure. 
 
Active represents a state in which the modeling tasks are permitted. Modeling 
tasks such as selection, addition and modification are not allowed for the 
inactivated parts. Unless this function is deliberately invoked the total model is 
always in an activated state. 
 
Inactivated Object under the Draw tab in View>Display Option allows the 
inactivated parts to either appear or disappear on the screen. 
 
This function can be effectively used for modeling complex, large-scale 
structures or post-processing tasks.  
 
 
 
 
 
 
 
 
 

 
                                         Active/Inactive 

Model Window is 
simplified by 
deactivating the cables 
in a cable stayed bridge 
model. 

Only the main girder, 
arch rib and hangers 
are activated to check 
the moments in the 
girder. 



 
 
 
 
GETTING STARTED 
 

56 

For instance, by only activating the deck part of a bridge on the screen, can our 
modeling task become much more manageable. This function remarkably 
simplifies tasks such as adding or modifying nodes or elements, interpreting 
analysis results by selective activation of specific element types, section or 
attribute types, etc. Analyzing the maximum or minimum member forces will 
require much less effort. 
 
The Active/Inactive function is used in connection with Selection. After 
selecting the desired parts, activate or inactivate the relevant selections by using 
the functions outlined below. 
 
 

 Active  
Activate only the selected part while the remaining parts are inactivated. 

 
 Inactive  
Inactivate only the selected part while the remaining parts are activated. 

 
 Inverse Active  
Reverse the current active and inactive parts to inactive and active parts 
respectively. 

 
 Active All  
Transform all the nodes and elements in an inactivated state into an activated 
state. 

 
 Active Identity 
Activate the assigned entities on the current UCS x-y plane that contains the 
origin, a particular story, the named plane or the Group, etc.  

 
 Active Previous 
Return to the previous active or inactive state. 
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Nodes and Elements Generation 
 
midas Civil enables us to readily create nodes and elements as if we were 
drawing drawings using the majority of functions used in CAD programs. 
 
The following two methods are mainly used for generating elements in midas 
Civil: 
 

 Enter the nodes first and then enter the elements using these nodes.  
 Enter the nodes and elements simultaneously using the predetermined 

grids. 
 
 
The second method is generally recommended for expediency. Grids are generated 
first. The presence of the grids significantly reduces the risk of making mistakes 
during the modeling. This is highly efficient as nodes and elements are created at 
the same time. 
 
The first method is used when the geometric arrangement of elements is so 
irregular that the application of grids is not expected to offer any advantage. This 
method is used to perform a partial, detail analysis of planar elements.  
 
The grids are laid out in the x-y plane of the UCS. The procedure to layout the 
Point Grids is simple enough since the grid spacing is regular in each direction of 
the axes, but unsuitable for modeling an irregularly spaced structure. In such a 
case, the use of Line Grids is more effective. 
 
During the modeling task, because various functions are alternately used to 
create nodes and elements, it is convenient to use Model Entity Tab at the top of 
the dialog bar located on the left of the screen. The desired function in the 
function list can be selected or the Toolbars on the right of the working window 
can be used rather than using the Main Menu. 
 

You may move the 
toolbars to any position 
by dragging the mouse. 
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The distance, coordinate, directional vector or node number can be directly typed 
on the keyboard in the dialog bar. Alternatively, the relevant distance or position 
can be conveniently assigned in the Model Window with the mouse cursor. When 
the mouse cursor is used to enter the above entities, click the relevant data field 
once and the background color of the data field will change to pale green. Then, 
enter the relevant data in the Model Window (Mouse Editor function). 
 
When duplicating or moving nodes and elements the relevant attributes may be 
selectively included. The relevant attributes for nodes are nodal loading, support 
conditions, etc. The relevant attributes for elements are element loading, element 
boundary conditions, etc. (Copy Node Attributes, Copy Element Attributes). 
 
When duplication is required with modification of material or section properties, 
the modification can be accomplished by specifying increments from the number 
being copied. 
 
 
 
 

Refer to the coordinates 
appearing in the Status 
Bar at the bottom of the 
screen while undertaking 
nodes/elements 
generation with the 
mouse. 
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Translate Elements  
 
 

  
Translate Elements dialog bar 

Specify whether or not 
to include the relevant 
attributes when 
duplicating nodes or 
elements. 

When duplicating 
distance, use the 
mouse cursor instead of 
typing a numerical 
value in the data field. 

Copy: Assign to copy 
Move: Assign to move 

Use when duplicating or 
moving elements while 
the material and section 
properties are altered. 
(Applicable also where 
column sections change 
while a building is 
modeled by copying 
each story.) 



 
 
 
 
GETTING STARTED 
 

60 

Nodes Generation 
 
 
Use Model>Nodes or Node Toolbar to generate nodes. 
 
For detailed information concerning the directions, refer to On-line Manual. 
 

 Create Nodes  
Create new nodes and additional nodes by duplicating the new nodes at given 
spacings simultaneously. 

 
 Delete Nodes 
Remove nodes. 

 
 Translate Nodes  
Duplicate or move the existing nodes with equal or unequal spacings. 

 
 Rotate Nodes  
Duplicate or move the existing nodes by rotating about a given axis. 

 
 Project Nodes  
Duplicate or move the existing nodes by projecting on a particular line or 
surface (plane, conic surface, spherical surface, elliptic surface, etc.). 

 
 Mirror Nodes 
Duplicate or move the existing nodes symmetrically with respect to a 
particular plane.  

 
 Divide Nodes 
Create additional nodes by dividing a straight line between two nodes into 
equal or unequal spacings. 

 
 Merge Nodes 
Merge contiguous nodes into one node. 

 
 Scale Nodes 
Reduce or magnify the spacings between two existing nodes by a specified 
ratio. 

 
 Compact Node Numbers 
Adjust the missing node numbers that have been removed, and arrange the 
node numbers in a consecutive order. 

 
 Renumber Node ID 
Renumber the existing node numbers either partially or in its entirety. 

 
 Start Number 
Assign the start number for new nodes to be created. 

  Undo cancels an 
unlimited number of 
previous tasks. 

 Redo recovers the 
previous tasks canceled 
by Undo. 

Project Nodes projects 
specific nodes onto a 
selected line or plane to 
copy or move the nodes. 
This becomes useful 
when modeling 
complicated parts of a 
structure. 
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Elements Generation  
 
 
Use Model>Elements or Element Toolbar to generate elements. The menu for 
material and section properties need not be accessed separately. By clicking the 

 button to the right of the material and section properties list in the dialog bar 
for the elements, the related attributes can be added or modified. If necessary, 
new material and section numbers can be assigned to the elements while being 
duplicated. 
 

 Create Elements 
Create new elements. 

 
 Create Line Elements on Curve 
Create line elements along the traces of a circle, a circular arc, an elliptical 
circle, a parabola, etc. 

 
 Delete Elements 
Remove elements. 

 
 Translate Elements 
Duplicate or move existing elements with equal or unequal spacings. 

 
 Rotate Elements 
Duplicate or move existing elements by rotating about a given axis. 

 
 Extrude Elements 
Create one-dimension higher geometric elements (line elements, plate 
elements and solid elements) by expanding existing nodes, line elements and 
plate elements as follows: 
• Create a line element along the path created by the motion of a node.  
• Create a plate element along the path created by the motion of a line 

element.  
• Create a solid element along the path created by the motion of a plate 

element. 
 Mirror Elements 
Duplicate or move existing elements symmetrically with respect to a 
particular plane.  

 
 Divide Elements 
Divide existing elements into equal or unequal sub-elements. 

 
 Merge Elements 
Merge elements of identical attributes (materials, section properties, element 
types, etc.) into one element. 

  Undo cancels an 
unlimited number of 
previous tasks. 

 Redo recovers the 
previous tasks canceled 
by Undo. 
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 Intersect Elements 
Divide automatically existing line elements intersecting one another relative 
to the intersection points. 

 
 Change Element Parameters 
Change the attributes of elements. 

 
 Compact Element Numbers 
Adjust the missing element numbers that have been removed, and arrange the 
element numbers in a consecutive order. 

 
 Renumber Element ID 
Renumber existing elements either partially or entirely. 

 
 Start Number 
Assign the start number for new elements to be created. 
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Model of an arch-portal frame 
 

 
Model of a Bin 

Extrude the plate 
elements created by 
midas FX+ into solid 
elements. 

Extrude the temporary 
beam elements, which 
represent a section of a 
bin to form a complete 
bin reinforced with 
stiffeners. 

The Shrink function 
reduces the element 
sizes and thus enables us 
to readily verify the inter-
connection of the 
elements. 
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Modeling sequence of a T-shaped pier using Extrude (Projection) 

Generate plate 
elements in the upper 
portion of the coping 
and select the 
projecting plane below.  

Extrude the upper plate 
elements onto the lower 
projecting plane to 
create solid elements.  

Divide the solid 
elements vertically to 
generate finer sub 
elements. 

Complete this T-shaped 
pier model by adding 
the footings and 
columns. 



 
 
 
 

Modeling 
 

65 

Structure Wizard functions 
 
Depending on the characteristics of a structure in question, the Structure Wizard 
functions may simplify the data entry, thereby increasing productivity.  
 
Especially, Bridge Wizard simplifies modeling and reduces the modeling time 
for various types of Cable Stayed, Suspension and Post-tensioned Box bridges.  
 
Structure Wizard 
 

 Beam  Column 
 Arch  Frame 
 Truss  Plate 
 Shell  Suspension Bridge 
 Cable Stayed Bridge  ILM Bridge 
 FCM Bridge  MSS Bridge 
 FSM Bridge  Transverse Model 
 Grillage Model  RC Slab Bridge 
 RC Frame/Box  PSC Bridge 

 
 

 
 

Structure Wizard dialog boxes 
  

Refer to “Structure> 
>Wizard” of this 
Manual. 
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 Material and Section Properties Generation 
 
midas Civil provides various material and section database, and we are also free 
to define User-defined material and section properties. In the case of a composite 
structural steel bridge girder, the section properties of non-composite and 
composite sections can be reflected in the analysis. Sectional Property 
Calculator calculates section properties for an irregularly shaped section. 
 
 
Material Properties 
 
midas Civil supports the following material properties: 
 
Steel 

ASTM (American Society for Testing Materials) 
CSA (Canadian Standards Association) 
BS (British Standards) 
DIN (Deutsches Institut für Normung e.V.) 
EN (European Code) 
UNI (Ente Nazionale Italiano di Unificazione) 
GOST(Russian: ГОСТ): Russian National Standards (государственный 
стандарт) 
IS (Indian Standards Institution) 
CNS (Chinese National Standards) 
KS-Civil (Korean Industrial Standards) 
KS (Korean Industrial Standards) 
JIS-Civil (Japanese Civil Standards) 
JIS (Japanese Industrial Standards) 
GB (Guojia Biao Zhun(China)) 
JGJ (Jian Zhn Gong ye Jian Zhn Biao Zhun(China)) 
JTJ (Jiao Tongbu Jian She Bia Zhun(China)) 
JTG (Jiao Tongbu Gong Lu Biao Zhun) 

 
Concrete 

ASTM (American Society for Testing Materials) 
CSA (Canadian Standards Association) 
BS (British Standards) 
EN (European Code) 
UNI (Ente Nazionale Italiano di Unificazione) 
GOST(Russian: ГОСТ): Russian National Standards (государственный 
стандарт) 
IS (Indian Standards Institution) 
CNS (Chinese National Standards) 
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KS-Civil (Korean Industrial Standards) 
KS01-Civil (Korean Industrial Standards)  
KS01 (Korean Industrial Standards) 
JIS (Japanese Industrial Standards) 
JIS-Civil (Japanese Civil Standards) 
GB (Guojia Biao Zhun(China)) 
JTG (Jiao Tongbu Gong Lu Biao Zhun) 
 
 

Reinforcing Steel 
ASTM (American Society for Testing Materials) 
CSA (Canadian Standards Association) 
BS (British Standards) 
EN (European Code) 
UNI (Ente Nazionale Italiano di Unificazione) 
GOST(Russian: ГОСТ): Russian National Standards (государственный 
стандарт) 
IS (Indian Standards Institution) 
CNS (Chinese National Standards) 
KS-Civil (Korean Industrial Standards) 
KS01-Civil (Korean Industrial Standards)  
KS01 (Korean Industrial Standards) 
JIS (Japanese Industrial Standards) 
JIS-Civil (Japanese Civil Standards) 
GB (Guojia Biao Zhun(China)) 
JTG (Jiao Tongbu Gong Lu Biao Zhun) 

 
SRC 

Combinations of the above-mentioned steel and concrete materials 
 
User Defined 

The user may define the properties directly as well as defining the properties 
of Isotropic Material and Orthotropic Material. 
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To enter material properties, use Properties> Material Properties. 
 
At the convenience of the user, enter material properties by the following methods: 
 

 
 
                               Dialogue box for Material Properties 
 
 
The following is a method of assigning material properties by selecting from the 
predefined materials list specified at the elements generation stage after defining 
the general material properties: 
 
 

1. Click  Material Properties for material data input. 
 

2. Select the desired material properties from the list of material properties 
of the dialog bar used for the generation of elements. 

 
3. Use the automatic incremental numbering function for material properties 

in the dialog bar used for the duplication of elements. This is convenient 
where properties of the duplicated elements are different from that of the 
elements being duplicated. 

 
 
 

When additional 
material properties data 
are to be entered during 
the elements generation 
process, use the  
button to the right of the 
material properties list 
of the Create Elements 
Dialog Bar. 
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The following is a method of assigning arbitrary material numbers to the 
elements being generated irrespective of the true material data. The assigned 
materials are subsequently revised. 
 
 

1. Click  Material Properties for material data input. 
 

2. Create elements without assigning material data concurrently. 
 

3. Use View>Select or the related Icons to select the elements whose 
material properties are to be assigned or modified. 

 
4. Use Node/Element> Change Parameters to assign new material 

numbers. Alternatively, assign material properties by Drag & Drop 
after selecting relevant material properties from Works Tree. 

 
 
Only a few material properties are used for modeling real structures. The first 
method is generally more practical. Use  Change Parameters to modify 
material data subsequently. 
 
For effective management of modeling, assign material numbers based on the 
element types (beam, column, wall, brace, etc.) even if the material types are 
identical. 
 
Similar material data used in other model files (fn.mcb) may be imported 

 for entering material properties. 

It makes no difference if 
steps 1 and 2 are 
reversed. If elements 
are created without 
specifying the material 
data, the material 
number “1” is assigned 
automatically. 
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Time Dependent Material Property Data 
 
 
When a construction stage analysis is required for a long span bridge structure to 
reflect shrinkage and long-term deflection, or a structure is analyzed for heat of 
hydration, time dependent material properties must be incorporated. 
 
The following outlines the method of defining the time dependent material 
properties. 
 
 

1. Define material property data for creep and shrinkage in Properties> 
Creep/Shrinkage. 

 
Selection of Code for defining Material Properties 

 
If User Defined is selected, the user is required to directly specify 
relevant creep and shrinkage functions in Properties> User Define. 

 
2. Define a function of modulus of elasticity of concrete in Properties> 

Comp. Strength. 
 

 
Variation of Modulus of Elasticity of Concrete 
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3. Relate the time dependent material properties to the general material 
properties previously defined in Properties> Material Link. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Time Dependent Material Link dialog bar 

 
4. If Properties>Change Property is used, the Notational Size of Member, 

“h”, defined at the time of defining the time dependent material 
properties is replaced with the changed “h”. The “h” value defined in 
Time Dependent Material (Creep/Shrinkage) is ignored. 
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Section Properties 
 
midas Civil supports the following section property data: 
 
DB Selection among international standard section databases 
 AISC  American Institute of Steel Construction 
 CISC Canadian Institute of Steel Construction 
 BS British Standards 
 DIN Deutsches Institut für Normung e.V. 
 UNI  Italian National Standard 
 GOST  Russian National Standard 
 STO_ASChM  Russian National Standard 
 IS84  Indian Standards 
 JIS  Japanese Industrial Standards 2000 
 KS  Korean Industrial Standards 
 GB-YB  Guojia Biao Zhun-Yejin Bu Biao Zhun 
 Pacific(SI)  Bentley Pacific Standards(SI Unit: kN, m, mm) 
 CNS91  Taiwan Standards 
User Key dimensions of standardized sections 
Value Section properties defined by the user 
SRC SRC sections 
Combined Combined sections made up of two section types 
PSC Prestressed concrete sections 
Tapered Tapered sections 
Composite Section properties of before and after composite action 

 
The section data in midas Civil is entered using Properties> Section 
Properties. 
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Dialogue Box Section
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Depending on the user’s preference, section data in midas Civil can be entered 
by the following methods: 
 
Selecting sections from the list of section data defined in advance and assigning 
them to the elements being created: 
 
 

1. Click  Section Properties to enter the section data. 
 

2. Select the desired sections from the list of sections of the dialog bar 
used for the generation of elements. 

 
3. Use the automatic incremental numbering function for sections in the 

dialog bar used for duplicating elements where the sections of the 
duplicated elements and the original elements are different. 

 
 
 
Revising the temporary section data assigned to the elements whose section 
numbers are arbitrarily assigned to create the elements: 
 
 

1. Click  Section Properties to enter the section data. 
 

2. Create elements without assigning section data concurrently. 
 

3. Use View>Select or the related Icons to select the elements whose 
section data will be modified or assigned. 

 
4. Use Node/Element> Change Parameters to assign new section 

numbers.  
 
 
The first method may be advantageous for a relatively simple structure with only 
a few section types. The second method may be more practical for general 
structures with many section types.  
 
Similar section data may be imported  from the MCB files (fn.mcb) 
used in other models. The user may expedite the sectional data entering process 
by establishing a DB in an MCB file containing built-up sections and other 
frequently used sections. This may also come in handy as the DB can be applied 
to the automatic design of steel structures.  

When section data are 
additionally required 
while creating elements, 
it will be more 
convenient to use the 

 button to the right of 
the section list in the 
Create Element Dialog 
Toolbar  

There is no difference if 
the steps 1 and 2 are 
reversed. If elements 
are created without 
specifying the section 
data, the section 
number “1” is assigned 
automatically. 
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midas Civil computes the following section properties automatically: 
 
 

 
DB/User Section 

 
Value Section 

 
 

 
Combined Section 

 
SRC Section 

 

It is not necessary to 
enter sectional 
dimensions for 
elements with varying 
cross sections. 

Defining Offset in 
Section Properties here 
eliminates the need to 
define offset again in 
defining boundary 
conditions. 

Section dimensions 
need not to be entered 
when Value is defined. 
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PSC Section 
 
 

 
Tapered Section 

 
Composite Section 
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Applicable Section Shapes 
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 Properties>Tapered Group automatically calculates the section properties of 
tapered (non-prismatic) elements in a zone of section variation. 
 
Prior to analysis, input tapered elements by assigning them to a  Tapered 
Section Group to calculate the section properties of the individual tapered 
elements, and then ungroup to retain the individual section properties. The 
ungrouping reduces analysis time, especially in a construction stage analysis 
where repetitive sub-analyses are internally performed. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Tapered Section Group 
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Thickness Data 
 
 
The thickness data for plate elements in midas Civil are considered in the 
following two ways: 
 

 Applying the same thickness to compute the stiffness for both in-plane 
and out-of-plane directions.  

 Applying different thicknesses to compute the stiffness for in-plane and 
out-of-plane directions. 

 
For plane stress elements, only the in-plane behavior is taken into account, and 
as such only the in-plane thickness data are applied regardless of the data 
entered. The Out-of-plane stiffness is irrelevant. 
 
midas Civil has the capability of entering stiffened or reinforced (ribbed) plates, 
which may often be used in the flanges of steel box bridge girders. 
 

Entering thickness data (Stiffened) 
 

Entering thickness data (Value) 
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Sectional Property Calculator (SPC) 
 
 
midas Civil provides SPC, which calculates stiffness data for any shape or form. 
The section shape can be drafted, or a DXF file can be imported. Invoke 
Tools>Sectional Property Calculator from Main Menu, and the section 
properties calculated are imported in Section when modeling a structure. 
 

 Import a section shape through AutoCAD DXF. 
 

 Simple entry of a section shape by various modeling tools. 
 

 Optimized mesh is automatically created for calculating the section. 
 

 The properties of a hybrid section consisted of a number of different  
materials can be calculated. 

 
 
   

A number of sections are arranged in the order of sizes, and the section 
properties are individually calculated for each section 
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Sectional Property Calculator calculates the section properties of the section 
shapes read in from AutoCAD DXF files 
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Section Properties calculated from SPC 
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Boundary Conditions Input 
 
midas Civil provides unique boundary conditions such as General Spring 
Supports to account for lateral stiffness of piles, Compression-only boundary 
elements to reflect foundations and Tension-only boundary elements. 
 
 
Boundary Conditions 
 

 Supports 
 

 Point Spring Supports 

 Define General Spring Type 
 

 General Spring Supports 

 Surface Spring Support 
 

 Elastic Link 

 General Link Properties 
 

 General Link 
 

 Beam End Release 
 

 Beam End Offset 

 Plate End Release 
 

 Rigid Link 

 Panel Zone Effect 
 

 Node Local Axis 
 

 Effective Width Scale Factor 
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Display of equivalent soil springs auto-generated for a tunnel lining 
 
 
Surface Spring Supports is applied in the case where a structure is in contact 
with soils such as a foundation mat or a tunnel. The effective contact area of 
each node of plate and solid elements and the modulus of sub-grade reaction are 
used to automatically calculate and input the equivalent spring stiffness. 
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Display of boundary conditions of a curved bridge at lane widening 
 
 
Elastic Link can be applied to represent an elastic bearing on a bridge pier, 
which eliminates the need for incorporating a fictitious beam element in the 
modeling. All that is required is just the stiffness in the relevant direction, which 
then produces the reaction. 
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Rigid Link representing offset between the main girder and bridge pier 
 
 
Plate End Release and Beam End Release represent the inability of resistance in 
certain degrees of freedom at the element ends.  
 
Node Local Axis is used to represent skewed boundary conditions relative to the 
Global Coordinate System, such as a bridge supported on skewed supports. 
 
Nonlinear Link can model base isolators and dampers in structures representing 
the behaviors of nonlinear damping history. Nonlinear Link Element is 
composed of 6 linear or nonlinear springs linking two nodes, which represent 
one axial spring, two shear springs, one torsional spring and two bending 
springs. 
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Loads Generation 
 
The types of loading implemented in the analysis tasks in midas Civil are as 
follows:  
 
 

 Static Loads 
 

 Moving Loads 
 

 Dynamic Loads 
 
 
The static loads are used to perform static analyses for unit loading conditions. 
The moving loads are used for structural analyses related to static moving traffic 
loads for which influence line analyses or influence surface analyses are carried 
out. The dynamic loads are used to perform response spectrum analyses or time 
history analyses.  
 
 
 
Static Loads 
 
 
The following two steps specify static loads in midas Civil: 
 
 

1. Use Load>Static Load Cases to enter the static unit loading conditions. 
 

2. Enter the loading data using various static loading functions provided in 
Load. 

 
 
A static analysis is performed for each static unit loading case. Use the Results> 
Combinations function to combine analysis results during the post-processing 
mode.  
 
It is also possible to carry out the structural analysis after converting the loading 
combination conditions entered in Load> Using Load Combinations into 
individual loading cases. 

When modifying or 
adding unit loading 
conditions in the 
process of entering 
loads, click the  
button located to the 
right of the Load Case 
Name field of the 
corresponding load 
dialog bar for quick 
changes. 

Load Group is applied 
to the Construction 
Stage Analysis in which 
groups of loads are 
activated and inactivated 
at different stages of 
construction. 

This is an extremely 
useful tool for entering 
loading cases when 
nonlinear elements are 
used in the analysis 
model.  
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Entering static unit loading conditions  
 
 
 
midas Civil supports the following types of static loading:  
 

 Self Weight 
Element self weight  

 
 Nodal Loads 
Nodal concentrated loads  

 
 Specified Displacements of Supports 
Forced displacements of supports 

 
 Element Beam Loads 
Concentrated or distributed loads acting on beam elements 

 
 Line Beam Loads 
Beam loads on a number of consecutive beam elements aligned in a straight 
line 

 
 Typical Beam Loads 
Common types of beam loads resulting from floor loading  

 
 Define Floor Load Type 

 
 Assign Floor Loads 
Floor loads on the top of beam or wall elements 

The type field is used to 
automatically create the 
loading combinations 
according to various 
design codes in different 
countries. It supports a 
list of 24 types of loads. 
For detail information, 
refer to On-line Manual. 

Specify the name of a 
static unit loading 
condition in the name 
field. This name is an 
identification used for 
loading combinations 
and specifying loading 
conditions required for 
the geometric stiffness 
matrix formation in a 
buckling analysis or a 
P-Delta effect analysis.  
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 Define Plane Load Type 
Define the type of loads on a plane, which will be applied to the nodes of 
plate/solid elements and any desired location irrespective of element type. 

 
 Assign Plane Loads 
Apply the defined planeloads to the plane in which the plate/solid elements 
are located. 

 
 Prestress Beam Loads 
Pre-stress loads in beam elements 

 
 Pretension Loads 
Pretension loads in truss elements, cable elements and tension/compression-
only elements 

 
 Tendon Prestress Loads 
Define tendon prestress loads 

 
 Pressure Loads 
Pressure loads acting on the thicknesses or surfaces of plate and solid 
elements 

 
 Hydrostatic Pressure Loads 
Pressure loads resulting from the potential energy of fluid 

 
 System Temperature 
The final temperature of the entire structure necessary for thermal stress 
analysis 

 
 Nodal Temperatures 
Nodal temperatures for thermal stress analysis 

 
 Element Temperatures 
Temperatures on elements for thermal stress analysis 

 
 Temperature Gradient 
Temperature gradient between the top and bottom of beam elements or plate 
elements 

 
 Beam Section Temperatures 
Define a temperature difference on a section of a beam element 

 
 Time Loads for Construction Stage 
Assigning specific elements with construction time duration to elapse at a 
specific construction stage 

  

Surface pressure loads 
can be applied to even 
Plane Stress elements 
for Geometric Nonlinear 
Analysis. 
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 Creep Coefficient for Construction Stage 
Assigning creep coefficients to specific elements at a specific construction 
stage 

 
Initial Forces Control Data 
Saving initially entered axial forces as the results of a separate loading 
condition 

 
 Initial Force for Geometric Stiffness 
Imposing initial axial forces to specific elements for calculating geometric 
stiffness 

 
 Settlement Group 
The magnitudes of settlements for individual settlement groups to automatically 
consider them for settlement analysis for bridges 

 
 Settlement Load Cases 
Nodal settlements for settlement analysis 

 
 Pre-Combined Load Cases for Composite Bridge 
Load cases pertaining to the pre-composite sections of an analysis, which 
reflects pre and post-composite sections 

 
Ambient Temperature Functions 
For Heat of Hydration Analysis 

 
Convection Coefficient Functions 
For Heat of Hydration Analysis at the boundary surface of a structure 

 
Element Convection Boundary 
Boundary condition for heat transfer by convection on the surface of a 
structure 

 
Prescribed Temperature 
Constant temperature condition independent of time 

 
Heat Source Functions 
For Heat of Hydration Analysis 

 
Assign Heat Source 
Heat source function assigned to each element 

 
Pipe Cooling 
Pipe cooling data for the reduction of temperature 

 
Define Construction Stage for Hydration 
For Heat of Hydration Analysis 

 
Loading Sequence for Nonlinear Analysis 
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Assign loading application order for nonlinear analysis 
 

 Define Construction Stage 
Define analysis models for each construction stage. 

 
 Select Construction Stage for Display 
Activate the selected stage on the screen. 

 
 
 
Hydrostatic Pressure Load automatically calculates lateral loads acting on plate 
or solid elements due to soil or fluid. The applied loads are automatically 
converted even when the elements are divided or merged. 
 
Temperature loads (changes) can be applied to the total structure as well as to 
individual nodes. Temperature gradients along the ECS axes of line elements 
may be also specified. 
 

Pressure Load: Exterior basement wall supporting soil pressure 
 
 
 

  

Soil or hydraulic 
pressures acting on 
basement walls or 
retaining walls can be 
easily generated by 
means of Hydrostatic 
Pressure Loads. 
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Moving Loads 
 
 
midas Civil generates traffic moving loads in the following five steps: 
 
 

1. Arrange the traffic lanes or surfaces in the model reflecting the traffic 
moving path, the number of traffic lanes and the traffic lane width. Use 
beam elements or beam elements with variable sections for traffic lanes, 
and plate elements for traffic lane surfaces. Use Load>Moving Load 
>Traffic Line Lanes and Traffic Surface Lanes for the layout of traffic 
lanes and surfaces respectively. 
 

2. Define the traffic load, which will act on the traffic lanes or the traffic 
lane surfaces by using Load>Moving Load >Vehicles. The traffic loads 
can be generated from the database as per AASHTO, Caltrans, etc. The 
user can also define wheel loads or traffic lane loads separately. 

 
3. Use Load>Moving Load>Vehicle Classes menu to load a number of 

moving loads simultaneously. 
 

4. Assign the support locations in Load>Moving Load>Lane Supports. 
 

5. Define the moving load cases by entering the load conditions 
subsequent to defining the traffic lanes or surfaces to be loaded using 
Load>Moving Load Analysis Data>Moving Load Cases. These load 
cases are then combined with other analysis results in Results> 
Combinations. 

 
 
Refer to Analysis Manual and Tutorials for the concept of moving load analysis.  
 
midas Civil contains the following types of standard traffic loadings: 
 

Standard Designation of the standard traffic loading 

AASHTO Standard 
H15-44, HS15-44, H15-44L, HS15-44L 
H20-44, HS20-44, H20-44L, HS20-44L, 
AML  

AASHTO LRFD HL93-TRK, HL93-TDM, HS20-FTG 

Caltrans Standard P5, P7, P9, P11, P13 

PENNDOT PHL-93TRK, PHL-93TDM, PHS20-FTG, 
P-82, ML-80, TK-527 

The support data are 
used only for continuous 
bridges to calculate the 
maximum negative 
moment. Concentrated 
lane loads of equivalent 
magnitude are 
simultaneously applied 
to two contiguous spans 
on each side of the 
support. 

Moving Load Cases 
can be defined without 
assigning Vehicle 
Classes. 
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Canada Standard 
CL-625 Truck, CL-625 Lane,  
CL-625-ONT Truck, CL-625-ONT Lane, 
BCL-625 Truck, BCL-625 Lane 

BS 5400, BD37/01 HA & HB, Pedestrian Load 

Eurocode Load Model 1~4, Fatigue Load Model, 
Rail Traffic Load 

Russia Standard SK, SK Fatigue, AK, N14, N11,  
Subway Trains, Tramcars, NK-80, NG-60 

India Standard Class A, Class B, Class 70R, 
Class 40R, Class AA, Footway 

Taiwan Standard 

HS20-44(MS18), HS15-44(MS13.5),  
H20-44(M18), H15-44(M13.5), H10-44(M9), 
HS-20-44(MS18), HS-15-44(MS13.5), 
H-20-44(M18), H-15-44(M13.5),  
H-10-44(M9), C-AML 

Australia Standard CE-80, UIC80, M1600, S1600 

KS Standard Load 
(Specification for Roadway 

Bridges) 

DB-24, DB-18, DB-13.5, DL-24, DL-18, 
DL-13.5 

KS Standard Train Loads L-25, L-22, L-18, L-15,S-25, S-22, S-18,  
S-15, EL-25, EL-22, EL-18 & HL 

 

  
 
Live load input from the database and User defined load input 
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Dynamic Loads 
 
 
The data entry process for the response spectrum analysis consists of the 
following: 
 
 

1. Define the response spectrum data in Load>Seismic>RS Functions. 
 

The response spectrum data can be defined using the following four 
methods: 

 
• The user directly enters the spectral data for each period. 
• The design response spectrum database is selected from the built-in 

database (AASHTO-LRFD, Eurocode, etc.). 
• The seismic response spectrum is extracted from the records of 

seismic accelerations using Seismic Data Generation. 
• A file containing response spectrum data is imported. 
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2. Enter the response spectrum load case in Load>Seismic>RS Load 
Cases. At this point, select the response spectrum defined in Step 1, and 
assign the direction of application, Scale Factor and the mode 
combination method. 

 
 
Refer to Analysis Manual for the concept and features of Response Spectrum 
Analysis. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Response Spectrum Function 
 
The sequence of data entry for time history analysis is as follows: 
 

1. Define Load>Seismic>Time History Functions.  
 

The Time History Functions can be defined by the following four 
methods:  

 
• The user directly enters the loading data for each time step. 
• A selection is made from the built-in earthquake records database 

(32 types, such as El Centro earthquake, 1940, 270°). 
• A file containing the Time History Load is imported. 
• The Time History Function is defined by entering Sinusoidal 

Function coefficients. 
 

2. Enter the title of the time history analysis condition and the data for 
analysis control in Load>Seismic>Time History Load Cases. 
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3. When an earthquake analysis is planned, assign the time history analysis 
condition and the Time History Load representing the ground motion to be 
considered in Load>Seismic>Ground Acceleration. 

 
 
When performing a typical time history analysis, assign the time history analysis 
condition and the Time History Load to be considered using 
Load>Seismic>Dynamic Nodal Loads. 
 
Refer to Analysis Manual and On-line manual for the concept and input process 
of Time History Analysis. 
 
 

Time History Function: Sinusoidal 
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Bridge Wizards for Bridge Modeling 
 
midas Civil provides Bridge Wizards for modeling various types of bridge 
construction encountered in practice. The wizards can quickly create the models 
of completed structures as well as construction stage models. 
 
 
Suspension Bridge Wizard 
 
 
Suspension Bridge Wizard finds the initial equilibrium state of a suspension 
bridge. It calculates the coordinates of the cables and the initial forces in the 
cables, hangers and towers upon specifying basic dimensions such as sags and 
hanger spacings and the self-weight acting on the cables. The resulting tensions 
in the cables and hangers are transformed into Initial Forces for Geometric 
Stiffness and become formulated into the geometric stiffness automatically. 
 
The input and usage of Suspension Bridge Wizard are as follows: 
 
 

1. Invoke the Structure >Suspension Bridge menu. 
 

2. Enter the basic coordinates in Node Coordinates & Heights for the 
cable sags, towers, start points of the girders, cable anchor locations, 
etc. 

 
3. Assign the defined material and section properties in the Material and 

Section selection fields. 
 

4. Enter the offset distances between the towers and girders if the girders 
are “simply supported” in Distances from Deck to Pylon. 

 
5. Specify the longitudinal slopes of the girders in the side and center 

spans in Shape of Deck. 
 

6. Enter the hanger spacings in Hanger Distances. 
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Suspension Bridge Wizard dialog box 

Suspension bridge model created by Suspension Bridge Wizard  
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Cable Stayed Bridge Wizard 
 
 
midas Civil provides Cable Stayed Bridge Wizard that quickly creates the model 
of a completed structure. It permits the modeling of symmetrical and non-
symmetrical bridges and truss and box girders reflecting the longitudinal profile. 
 
The input and usage of Cable Stayed Bridge Wizard are as follows: 
 
 

1. Invoke the Structure> Cable Stayed Bridge menu. 
 

2. Select the symmetry condition, and enter the basic coordinates and 
dimensions in Node Coordinates & Heights for the towers and the start 
points of the girders, etc. 

 
3. Assign the defined material and section properties to the cables, girders 

and towers in the Material and Section selection fields. 
 

4. Select either truss or cable element type in Select Cable & Hanger 
Element Type. 

 
5. Enter the offset distances between the towers and girders if the girders 

are “simply supported” in Distances from Deck to Tower. 
 

6. Specify the longitudinal slopes of the girders in the side and center 
spans in Shape of Deck. 

 
7. Enter the cable spacings in the spans and towers in Cable Distances & 

Heights. 
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Cable Stayed Bridge Wizard dialog box 
 

Cable Stayed bridge model created by Cable Stayed Bridge Wizard 
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ILM Bridge Model Wizard 
 
 
ILM Bridge Model Wizard constructs the modeling of an ILM bridge based on 
the geometry, launching and boundary information related to nose, girder, 
prefabrication plant, etc. 
 
 

1. Define the material and section properties of the nose and girders. 
 

2. Select Structure>ILM Bridge Model. 
 

3. Define the information related to the nose and girders and the boundary 
conditions of the completed stage and the prefabrication plant. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
ILM Bridge Model Wizard dialog box-ILM Model tab 
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4. Define the tendons placed in the top and bottom of the girders in the 
Top & Bottom Tendon tab. 

 

ILM Bridge Model Wizard dialog box - Top & Bottom Tendon tab 
 

5. Define the tendons in the web in the Web Tendon tab. 
 

ILM Bridge Model Wizard dialog box - Web Tendon tab 
 

6. Click  to finish ILM Bridge Model Wizard after completing 
the input, and enter additional data. 
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ILM Bridge Stage Wizard 
 
 
ILM Bridge Stage Wizard automatically composes each construction stage 
based on the input data related to the change of boundary conditions. 
 
 

1. Select Structure>ILM Bridge Stage. 
 

2. Define the boundary conditions after completion in Piers of Final 
Structure System. 

 
3. Define the launching direction and the start point of the nose. 

 

ILM Bridge Stage Wizard dialog box 
 

4. Click  to finish ILM Bridge Stage Wizard after completing 
the input, and enter additional data. 
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FCM Bridge Wizard 
 
 
FCM Bridge Wizard is used to prepare the construction stage analysis model of 
an FCM bridge. The procedure for composing a construction stage analysis 
model using the wizard is as follows: 
 
 

1. Specify the general bridge information and element segment 
information under the Model tab of FCM Bridge Wizard. Use the 
Advanced options to model a non-symmetrical FCM bridge. 

 
 
 
 
 

 
 
 

 
 
 
 
 
 
 
 

FCM Bridge Wizard dialog box-Advanced Dialogs 

FCM Bridge Wizard box-Model tab 
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2. Enter the PSC (post-tensioned concrete) box section dimensions and 
the weight of the Form Traveler under the Section tab of FCM Bridge 
Wizard. 

 

FCM Bridge Wizard dialog box-Section tab 
 

3. Place the tendons and enter the jacking forces under the Tendon tab of 
FCM Bridge Wizard. Click  to place the tendons in the 
webs of the PSC box. 

 

FCM Bridge Wizard dialog box-Tendon tab 
 

4. Click  to finish FCM Bridge Wizard after completing the 
input, and enter additional data. 

 



 
 
 
 
GETTING STARTED 
 

106 

Construction Stage model of an FCM Bridge Wizard created by FCM Bridge Wizard 
 
 
 
MSS/FSM Bridge Wizard 
 
 
MSS/FSM Bridge Wizard is used to prepare the construction stage analysis 
model of an MSS or FSM bridge. The procedure for composing a construction 
stage analysis model using the wizard is as follows: 
 
 

1. Under the Model tab of MSS/FSM Bridge Wizard, select the bridge 
type, either MSS or FSM, and enter the concrete material, spans, 
segmenting information, etc. If MSS is selected the weight of the wet 
concrete is automatically considered. 

 
2. Enter the PSC (post-tensioned concrete) box section dimensions at the 

center and construction joint under the Section tab of MSS/FSM 
Bridge Wizard. 
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MSS/FSM Bridge Wizard dialog box-Model tab 
 

3. Enter the tendon profiles and jacking forces under the Tendon tab of 
MSS/FSM Bridge Wizard. 

 

MSS/FSM Bridge Wizard dialog box-Tendon tab 
 

4. Click  to finish MSS/FSM Bridge Wizard after completing 
the input, and enter additional data. 
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Construction Stage model of an MSS Bridge Wizard created by MSS Bridge Wizard 
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Construction Stage Modeling Feature 
 
midas Civil provides three types of stages; Base Stage, Construction Stage and 
Post-construction Stage. The characteristics of each stage type are as follows: 
 

 Base Stage 
General analysis is carried out at the Base Stage if the Construction 
Stage is undefined. If the Construction Stage is defined, structural 
modeling is prepared, and Structure Groups, Boundary Groups and 
Load Groups are defined and composed at the Base Stage without the 
execution of analysis. 

 
 Construction Stage 

Analyses for construction stages actually take place. The boundary and 
load conditions of the activated Boundary Groups and Load Groups of 
each corresponding stage are established. 

 
 Post construction Stage 

Being the last stage of the construction stages, special analyses are 
carried out at the Post construction Stage for conventional/moving 
loads, response spectrum analysis, etc. in addition to the analysis for the 
construction stage loads. 

 
Construction Stages are composed of Structure Groups, Boundary Groups and 
Load Groups by Activation and Deactivation of relevant entities. Accordingly, 
each stage consists of activated geometry, boundary and load conditions 
pertaining to that particular construction stage. 
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Construction Stage Modeling for a General Structure 
 
 
The general modeling procedure for the construction stage analysis of a structure 
is as follows: 
 

1. Prepare a structural model except for the boundary and load conditions. 
 

2. Define Structure Groups in Structure>Structure, and assign to each 
Structure Group relevant elements that will be constructed or removed 
together. 

 
3. Define Boundary Groups in Structure>B/L/T>Define Boundary 

Group. 
 

4. Define Load Groups in Structure>B/L/T >Define Load Group. 
 

5. Compose Construction Stages by clicking the  button in 
Load>Construction Stage>Define C.S. You may click the  
button to define a number of Construction Stages of identical duration and 
click the  button to compose each construction stage. 

 
Define Construction Stage dialog box 

 
6. Specify Duration and whether or not to save the results in the Compose 

Construction Stage dialog box. Define Additional Steps if time variant 
loadings are applied within the same structure Group. 
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Compose Construction Stage dialog box  
 

7. From the Group List of the Element tab, select the applicable element 
groups to be included in or excluded from each construction stage 
through activation or deactivation. Age represents the initial maturity of 
each element group. Element Force Redistribution represents the 
redistribution of the forces of each element group being deleted or 
inactivated into the remaining elements. 

 
8. From the Group List of the Boundary tab, select the applicable 

boundary groups to be included in or excluded from each construction 
stage through activation or deactivation. 

 
9. From the Group List of the Load tab, select the applicable load groups 

to be included in or excluded from each construction stage through 
activation or deactivation. Active Day and Inactive Day represent the 
dates of applying and removing each load group. 

 
10. Once the construction stages are composed, we may switch around the 

construction stages in Stage Toolbar and input the boundary and load 
conditions of the Boundary Groups and Load Groups corresponding to 
each construction stage. 

 
 

We can minimize input 
errors by inputting the 
load and boundary 
conditions in each 
corresponding 
construction stage. 
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Time Dependent Material Properties 
 
 
The modeling procedure for reflecting the time dependent material properties of 
concrete is as follows: 
 
 

1. Define the Creep and Shrinkage properties of concrete, which vary with 
maturity in Properties>Creep/ Shrinkage. midas Civil contains the ACI 
and CEB-FIP codes for defining creep and shrinkage properties of 
concrete and allows us to directly enter any test data. 

 
2. Define the time variant compressive strength gain properties of concrete 

in Properties>Comp. Strength. midas Civil contains the ACI and CEB-
FIP codes for defining compressive strength gain properties of concrete 
and allows us to directly enter any test data. 

 
3. Relate the time dependent material properties to the general material 

properties in Properties>Material Link. When the two types of material 
properties are linked, the time dependent material properties will be used 
for construction stage analyses according to the maturity, and the general 
material properties will be applied to general analyses. 

 
4. Notational Size of Member (h=2×Ac/u) required for calculating the 

time dependent material properties of concrete is entered in 
Properties>Change Property for each member. Alternatively, Auto-
Calculate “h” for all the members. 

 
5. Use Load>C.S Loads>Creep Coefficient for Construction Stage if creep 

coefficients other than the values automatically calculated by midas Civil 
are desired. Input creep coefficients for each element at each construction 
stage in the form of loads. When the corresponding load groups are 
activated, the construction stage is created using the specified creep 
coefficient. 
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For the case of an FCM bridge where two or more structural components are 
separately erected in the same construction stage and yet the maturities are 
different as they are connected, midas Civil provides Load>Time Load for 
Construction Stage to account for the different timing effect. Time Load for 
Construction Stage thus enables us to impose time passage to specific elements, 
which is input as a type of load. 
 
 
 
Prestress Input 
 
 
midas Civil permits construction stage analyses reflecting the pre-stress effects 
of tendons exerted on a structure. It also considers the immediate pre-stress 
losses such as tendon/sheath friction, anchorage slip and elastic shortening; and 
long term losses such as creep/shrinkage of concrete and tendon relaxation in 
construction stage analyses. The procedure for entering pre-stress is noted 
below. 
 
 

1. Specify the material properties of tendons in Properties>Material. 
midas Civil does not consider the tendons as independent elements, and 
as such only the modulus of elasticity of the tendons need be entered. 

 
2. Enter the cross sectional area, pre-stress loss coefficients, duct diameter 

and strength of tendons in Load>Temp./Prestress>Tendon Property. 
 

3. Define the tendon profile in Load>Temp./Prestress>Tendon Profile. A 
tendon profile is defined as a curvature relative to an imaginary local x-
axis, and the insertion point for the origin of the x-axis and the direction 
of the x-axis are assigned. The local x-axis may be in the form of a 
straight line or curved line. A profile already defined can be repeatedly 
copied, and the origin and direction of the x-axis can be revised to 
define a number of different tendons.  

 
A web tendon profile can be created on a vertical plane and projected 
onto a sloped plane by specifying the angle of inclination to model the 
tendon placed in an angled web. Tendons can be also placed in sloped 
elements by simply specifying the slope (gradation) angles.  

 
4. Define pre-stress loads in Load>Temp./Prestress>Tendon Prestress. 

The pre-stress loads can be in the form of either force or stress. The 
timing of grouting tendons can be also specified to affect the 
transformed section properties. 
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T 
 

Tendon Profile & Pre-stress Load Input 
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Modeling Functions for Heat of Hydration Analysis 
 
midas Civil provides Heat of Hydration Analysis capabilities reflecting concrete 
pour sequence and pipe cooling effects. The modeling procedure for Heat of 
Hydration Analysis is as follows: 
 
 

1. Specify the integration factor, initial temperature, stress output location, 
and whether or not to consider creep & shrinkage in Analysis>Heat of 
Hydration. 

 
2. Specify the ambient temperature function in Load>Heat of 

Hydration>Convection Boundary>Ambient Temperature Functions. 
 

3. Specify the convection coefficient function in Load>Heat of 
Hydration>Convection Boundary>Convection Coefficient Functions. 

 
4. Assign the specified ambient temperature and convection boundary 

condition to the concrete surface in contact with atmosphere in 
Load>Heat of Hydration>Convection Boundary>Element Convection 
Boundary. 

 

Ambient Temperature Functions & Convection Coefficient Functions 
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5. Assign a constant temperature to parts that do not experience 
temperature variation with time in Load>Heat of Hydration 
>Prescribed Temp. 

 
6. Define the heat source function, which reflects the state of heat 

generation representing the process of concrete hydration in Load> 
Heat of Hydration >Assign Heat Source>Heat Source Functions. 

 
7. Assign the defined heat sources to the corresponding concrete in Load> 

Heat of Hydration >Assign Heat Source>Assign Heat Source. 
 

Heat Source Functions 
 

8. Specify the pipe cooling related data, if used, in Load>Heat of 
Hydration > Pipe Cooling. 

 
9. Define the element groups and boundary groups pertaining to each 

construction stage, and specify the time for heat of hydration analysis in 
Load> Heat of Hydration >Define CS for Hydration. 
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Construction Stage for Hydration 
 
 
 



 
 
 
 
GETTING STARTED 
 

118 

Other Modeling Functions 
 
A typical structural analysis modeling entails generating nodes and elements, 
and assigning material properties and boundary conditions. Apart from the 
typical method of preparing an analysis model, midas Civil provides the user 
with various features to efficiently and accurately carry out the structural 
analysis and design. Some of which are data conversion of other programs, 
merging several model data and text type data entry. 
 
Non-conventional features of midas Civil related to modeling are as follows: 
 

 Import/Export 
 

 Merge Data File Function 
 

 MCT Command Shell  
 
 
Import/Export  
 
 
Use Import/Export when importing model data saved in another format 
incompatible with midas Civil or generating a file in another format 
incompatible with fn.mcb.  
 
Use File>Import or File>Export to invoke Import/Export. 
 

 midas Civil MCT File 
Export a file containing the model data in a text format by creating an 
MCT (midas Civil Text) or import an MCT file. 

 
 AutoCAD DXF File 

Export a fn.mcb to a DXF file or import the geometric shape of a model 
(nodes, elements, etc.) from a DXF file to use it as the model data for 
midas Civil. 

 
 SAP90, SAP2000 File 

Import a model data file of SAP2000 to use it as a model data file for 
midas Civil after converting it into an MCT format. Export a fn.mcb as 
a data file for SAP2000. midas Civil functions not supported by 
SAP2000 are removed from the model data. 

  

Refer to File>Import > 
SAP2000 File of On-line 
Manual. 
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 STAAD File 
Import a model data file of STAAD to use it as a model data file for 
midas Civil after converting it into an MCT format. Export a fn.mcb as 
a data file for STAAD. midas Civil functions not supported by STAAD 
are removed from the model data. 

 

 
 
MCT File opened by Text Editor 
 
 
Merge Data File Function 
 
In order to expedite the modeling task of a complex structure where the 
geometric configuration is irregular, complicated and large, divide the structure 
into several sub-models and prepare the geometric shape of each sub-model 
separately. Then, combine them into a single model and perform the structural 
analysis. Use File>Merge Data File. 
 

Refer to File> Import> 
STAAD File of On-line 
Manual. 
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Merge Data File 
 
 
 

                                        MCT Command Shell 
Enable the modeling of a structure by the MCT format command, which is a text                                         
format model data file for midas Civil. 
Use Table Window or improve the efficiency of modeling by using the MCT 
command of MCT Command Shell when the task involves a simple repetition 
under the GUI environment or the task consists of modifying an existing model 
continuously. 
 

 

MCT Command Shell 
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Input Results Verification 
 
midas Civil supports a variety of verification and reference functions, which 
readily verify the current status of all the model data. These functions are: 
 
 

 Display and Display Option  
 

 Project Status  
 

 Fast Query 
 

 Query Nodes 
 

 Query Elements  
 

 Node Detail Table  
 

 Element Detail Table 
 

 Mass Summary Table 
 

 Load Summary Table 
 

 Group Activation of Construction Stage 
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Display and Display Option  
 
 
Display provides graphical representation of all types of data entries such as 
node/element numbers, material properties, section names, loadings, support 
conditions, end release conditions, rigid body connection conditions, design 
parameters, etc. These representation capabilities enable the user to verify the 
status of data entries by graphics in the working window. For instance, Check & 
Remove Duplicate Elements and Display Free Edge (Face) are used to detect 
and correct errors.  
 
Use View>Display or click  Display in the Toolbar. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Display of section ID’s 
 
 
  
 
 
 
 
 
 
 
 
 
 
 
 
Display of traffic lanes 
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Display Option controls the representation mode of all the graphic and 
alphanumerical data presented in the Model Window. It has 5 dialog boxes:  
 

Font tab: Assign the type, size and color of all the alphanumerical   type of 
data such as node numbers, element numbers, analysis results 
related to nodes and elements, numerical load data, etc.  

 
Color tab: Control the color of all the graphic data such as nodes, elements, 

masses, loads, support conditions, material properties, sections, 
thicknesses, grids, coordinate systems, display background, etc. 

 
Print Color tab: Control the printing color similarly to Color tab.  

 
Size tab: Adjust the scale of Label Symbol, Zoom In/Out, Pan Rotate, 

Shrink, Perspective, etc. 
 

Draw tab: Specify the requirements for element color display on the screen 
(global element type, material, property, etc.), the representation 
mode of elements (outline, thickness and surface treatment), the 
printing color processing method for printouts, the representation 
method of inactivated elements, the drawing direction for 
diagrams, etc.  

 
 
Use View> Display>Display Option or click  Display Option. 
 
midas Civil provides a Dynamic Display capability, which displays all the nodes 
and elements, as well as loads and boundary conditions on the model screen as 
they are being input, which helps prevent modeling errors. 
 

Display Option dialog box 
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Project Status  
 
 
Project Status provides the current status of data entries. The data containing the 
types of data entries with the counts are clearly arranged in a table format.  
 
Use Query>Project Status. 
 
 

Project Status 
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Query Nodes 
 
 
Query Nodes enables the user to verify node numbers, nodal coordinates and 
nodal attributes. After selecting Query>Query Nodes, assign the node to be 
verified with a mouse click or by typing the node number in the dialog box. The 
desired information will appear in the Message Window at the bottom of the 
screen. 
 

 
 
Query Nodes 

Query Nodes provides 
the following types of 
information: 

 
Node (number, 
coordinates) 
Nodal Local Axis 
Support 
Point Spring Support 
General Spring Support 
Rigid Link 
Nodal Mass 
Nodal Load 
Specified Displacement  
Nodal Temperature 
Dynamic Nodal Load 

When  Fast Query is 
toggled on, the number 
and coordinates of the 
snapped node are 
displayed in a Bubble 
Tip. 
Fast Query can easily 
verify the basic attributes 
of nodes and elements. 
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Query Elements  
 
 
Query Elements enables the user to verify the element’s connecting node 
numbers and all types of element attributes. After selecting Query>Query 
Elements, select the element to be verified with a mouse or by typing the 
element number in the dialog box. The desired information will appear in the 
Message Window at the lower part of the screen. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Query Elements  
 

Query Elements offers 
the following types of 
information: 

 
Element  
(element, connecting 
nodes, material 
properties, section,  
number, length, etc.) 
Beam End Release 
Beam End Offset 
Plate End Release 
Element Beam Load 
Pressure Load 
Prestress 
Pretension 
Temperature Gradient 

When  Fast Query is 
toggled on, the number, 
type, material and 
section properties and 
other relevant attributes 
of the snapped element 
are displayed in a 
Bubble Tip. Fast Query 
can easily verify the 
basic attributes of nodes 
and elements.  
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Node Detail Table 
 
 
Node Detail Table is used to verify all types of information related to nodes in a 
spread sheet format. 
 
Select the relevant nodes with View>Select first. Click Query>Node Detail 
Table and select the desired information by clicking the tabs located at the 
bottom. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Node Detail Table 
 

Table Window provides 
all kinds of selection, 
namely, Filtering, 
Sorting, Editing, Graph, 
data transfer with Excel, 
etc., in addition to data 
input/output and 
modification. Refer to 
On-line Manual for 
detail directions. 
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Element Detail Table 
 
 
Element Detail Table is used to verify all types of information related to 
elements in a spreadsheet format. 
 
Select the relevant elements with View>Select first. Assign Query>Element 
Detail Table and select the desired information by clicking the tabs located at the 
bottom. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
   Element Detail Table  
 

Element Detail Table 
displays only the 
information related to 
the selection. It is easy 
to detect errors such as 
redundant or duplicated 
loads. 
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Mass Summary Table  
 
 
Mass Summary Table is used to verify the masses of the structure in a 
spreadsheet format.  
 
Assign Query> Mass Summary Table. The Nodal Mass that the user entered as 
such, masses converted from loads and Structure Mass obtained from the self-
weight of elements can be verified in Mass Summary Table. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Mass Summary Table 
 
 

Data cannot be 
modified in this mode. 
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Load Summary Table  
 
 
Load Summary Table is used to verify the loads that have been input in each 
direction arranged by load types in a spreadsheet format.  
 
Assign Query>Load Summary Table. Click the tab corresponding to the desired 
information at the bottom.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Load Summary Table
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Group Activation of Construction Stage Table 
 
Group Activation of Construction Stage is used to check in a table whether or 
not the groups assigned in each stage of the construction stages are activated. 
 
Selecting Query>Group Activation of CS and using the function, click the 
Group tab at the bottom of the table. The state of activation in the corresponding 
construction stages can be checked by the symbols o or x.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Group Activation of Construction Stage Table  
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Analysis 
 
 
 
 
 
 
midas Civil provides linear and nonlinear structural analysis capabilities. 
 
A large collection of finite elements has been implemented for applications in 
civil and building structures. The program’s efficient analysis algorithms yield 
exceptional versatility and accurate results appropriate for practical design 
applications. 
 
There are no limits on the numbers of nodes, elements, load cases and load 
combinations for a structural model.  
 
 
 

Finite Elements 
 
For beam elements, midas Civil can analyze the displacements and the 
maximum stresses at the end nodes as well as at intermediate points 
(Results>Beam Detail Analysis). 
 
For plate elements, thin plate (DKT, DKQ) and thick plate (DKMT, DKMQ) 
elements must be used appropriately. Accurate analysis results can be obtained 
from thin plates for structures such as common storage tanks. Thick plates may 
be more appropriate for modeling walls, bridge decks, basemats, etc. 
 
The Tapered Beam Element formulated from the most current algorithms can 
precisely simulate the behavior of a hunched beam with varying section 
dimensions along the length. The Cable Element has also been introduced in 
midas Civil for the design of cable-stayed bridges with a small strain condition, 
and suspended cable structures with geometric nonlinearity including the 
sagging effect. 
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The finite element library of midas Civil contains the following: Refer to 
“Numerical Analysis Model ” of the Analysis Manual for details. 
 
 

Truss 
Transmit only tensile and compressive loads in the element axial direction 

 
Compression-only Truss/Gap 

Transmit only compressive load in the element axial direction considering 
a gap distance 

 
Tension-only Truss/Hook 

Transmit only tensile load in the element axial direction considering a 
hook distance 

 
Cable 

Transmit only tensile load in the element axial direction considering 
varying stiffness due to the variation of the internal tension and the sag 
effect 

 
General Prismatic Beam 

Common beam element considering 6 degrees of freedom per node 
 

Tapered Beam 
Beam element with varying sections along the length considering 6 
degrees of freedom per node  

 
Plane Stress 

Plane stress element considering in-plane behaviors 
 

Plate 
Plate element considering in-plane and out-of-plane bending behaviors 

 
Stiffened Plate 

Anisotropic Plate element considering in-plane and out-of-plane bending 
behaviors 

 
Plane Strain 

Plane strain element considering 2-D behaviors in the GCS X-Z plane 
 

Axisymmetric 
Axisymmetric element considering 2-D behaviors in the GCS X-Z plane 

 
Solid 

Solid element considering 3 degrees of freedom per node 
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Visco-elastic Damper 
Linear spring and (non) linear viscous damper combined in parallel and 
connected to a spring linking two nodes in all 6 degrees of freedom. An 
additional linear viscous damping coefficient for each dof in parallel with 
the system can be defined. 

 
Hysteretic System 

Hysteretic System consists of springs with the Uniaxial Plasticity property 
in all 6 degrees of freedom. An additional linear viscous damping 
coefficient for each degree of freedom in parallel with the system can be 
defined. 

 
Lead Rubber Bearing Isolator 

Similar to the Hysteretic System, it includes 2 inter-related shear 
deformation springs with the Biaxial Plasticity property. Independent linear 
elastic springs represent the remaining 4 degrees of freedom. An additional 
linear viscous damping coefficient for each dof in parallel with the system 
can be defined. 

 
Friction Pendulum System Isolator  

It includes 2 inter-related shear deformation springs with the Biaxial 
Plasticity property whose physical movements take the form of a 
pendulum (pot bearing). The axial deformation spring retains the property 
of a Gap spring with 0 internal gap. Independent linear elastic springs 
represent the remaining 3 degrees of freedom. An additional linear 
viscous damping coefficient for each dof in parallel with the system can 
be defined. 
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Analysis  
 
midas Civil provides three solvers for analysis. Select the analysis method from 
Analysis>Analysis Options. The default is the Skyline Solver.  
 
The Skyline Solver is generally used in most structural analysis programs. It can 
be used in virtually all cases regardless of the types and scales of analysis 
models or the system capacities. It is an optimized algorithm that can analyze 
most structural engineering problems within a short time frame. 
 
The Band Solver is more appropriate for an ABD (Almost Block Diagonal) 
stiffness matrix and can be used in all cases, similar to the Skyline Solver.  
 
The high performance Multi-Frontal Sparse Gaussian Solver (MFSGS) is a latest 
addition to the group of MIDAS solvers. The MFSGS uses an optimum frontal 
division algorithm to minimize the number of calculations for simultaneous linear 
equations. The MFSGS is especially useful for those finite elements that contain a 
large number of degrees of freedom. Structures with many nodes can be solved 
over 3~5 times faster depending on the cases. The MFSGS is a particularly useful 
solver for the detail analysis of a structure consisted of plate and/or solid elements. 
 
The analysis capabilities of midas Civil are as follows: Refer to “Structural 
Analysis” of the On-line Manual for details. 
 

 Static Analysis 
· Linear Static Analysis 
· Thermal Stress Analysis 

 
 Dynamic Analysis 

· Free Vibration Analysis 
· Response Spectrum Analysis (SRSS, CQC, ABS) 
· Time History Analysis 

 
 Geometric Nonlinear Analysis 

· P-Delta Analysis 
· Large Displacement Analysis 

 
 Boundary Nonlinear Dynamic Analysis 

· Gap 
· Hook 
· Visco-elastic Damper 
· Hysteretic System 
· Lead Rubber Bearing Isolator 
· Friction Pendulum System Isolator 
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 Buckling Analysis 
· Critical Buckling Load Factors 
· Buckling Modes 

 
 Moving Load Analysis 

· Influence Line Analysis 
· Influence Surface Analysis 
· Moving Load Tracer 

 
 Heat Transfer Analysis (Conduction, Convection, Radiation) 

· Steady State Analysis 
· Time Transient Analysis 

 
 Heat of Hydration Analysis 

· Thermo-elastic Analysis (Temperature stress) 
· Maturity, Creep, Shrinkage & Pipe Cooling 

 
 Construction Stage Analysis 

· Time-dependent Material Properties 
· Boundary Group 
· Static Load Group 

 
 Pushover Analysis 

· Loading Applications as per Mode Shape and Static Load type 
· Generation of Capacity Spectrums & Demand Spectrums 

 
 Other Analysis Features  

· Calculation of Unknown Loads using optimization technique 
· Analysis of structures reflecting support settlements 
· Analysis of steel girders reflecting the section properties before and  

after composite action 
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Eigenvalue analysis result of the completed model of Youngjong Br. (vert. 1st 
mode: 0.485 Hz)  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Heat of Hydration analysis results of the pier top portion of an Extradosed 
PSC Box reflecting the construction stage/concrete pour sequence showing 
stress distribution 
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Construction stage analysis model created by FCM Bridge Wizard 
 

 
Each construction stage may be displayed using Stage Group of the construction 
stage analysis model of Cable Stayed Bridge.  
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Static Analysis 
 
 

1. Select Load>Static Loads> Static Load Cases to enter the load cases.  
 

2. Input the loads using the various static load input options in the Load 
menu. 

 
3. When geometric nonlinear elements are included in the model, a) 

reassign predefined load combinations as load cases in Load>Static 
Loads>Using Load Combinations and b) select Analysis>Main 
Control Data to enter the number of iterations and a tolerance 
necessary for convergence. 

 
4. When the P-Delta effect is considered in the analysis, select Analysis> 

P-Delta to enter the number of iterations and a tolerance necessary for 
convergence. Enter the load cases and load factors for analysis. 

 
5. Select Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis. A message indicating the progress of analysis or 
the completion of analysis is displayed in the Message Window at the 
lower part of the screen. 

 
6. After completing the analysis, analyze the analysis results using the 

load cases or combinations and various post-processing functions in 
Results. 

 
 
 
 
Heat of Hydration Analysis 
 
 

1. Enter the time dependent material properties in 
Properties>Creep/Shrinkage and Properties>Comp. Strength, and 
relate the general material properties to the time dependent material 
properties in Properties> Material Link. 

 
2. Enter the data required for heat of hydration analysis in the sub-menu of 

Load>Heat of Hydration following the procedure outlined in 
“Modeling Functions for Heat of Hydration Analysis”. 

  

All the messages 
pertaining to the 
analysis process are 
compiled automatically 
in the “fn.out” file.  
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3. Enter the integration factor, initial temperature, stress output position 
and whether or not to consider creep & shrinkage in Analysis> Heat of 
Hydration. 

 
4. Carry out the analysis in the Analysis>Perform Analysis menu or by 

clicking  Perform Analysis. 
 

5. Once the analysis is completed, the results can be verified in contours, 
graphs, animations, etc. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Heat of Hydration analysis model of a bridge pier cap cast in sequence 
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Dialog boxes defining Heat & Time dependent material properties 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

                                        Construction Stage dialog box defining sequential construction joints 
(Define Elements & boundary conditions for each construction stage) 
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1st Stage 
 
 
 
 
 
 
 
 
 

 
2nd Stage 

 
 
 
 
 
 
 
 
 
 
 

3rd Stage 
 
 
 
 
 
 
 
 
 
Analysis results for each construction stage in graphs 
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Eigenvalue Analysis 
 
 

1. Enter the masses of the model using the mass input tools supplied by 
Load>Static Loads>Masses. 

 
2. Select Analysis>Eigenvalue Analysis Control to enter the data necessary 

for eigenvalue analysis such as the number of modes. 
 

3. Select Analysis>Perform Analysis or click  Perform Analysis to 
perform the analysis. 

 
4. After completing the analysis, verify the vibration mode shapes and 

natural frequencies (or natural periods) for each mode using Results> 
Mode Shapes>Vibration Mode Shapes or Results>Result Tables> 
Vibration Mode Shape. 

 
 
 
 
Response Spectrum Analysis 
 
 

1. Follow the steps 1 and 2 of Eigenvalue Analysis. 
 

2. Select Load>Seismic>RS Functions and click . Enter the 
function name and related spectrum function data in the Add/Modify 
Show Response Spectrum Functions dialog box. 

 
3. Use Load>Seismic>RS Load Cases to enter the Load Case Name, 

Modal Combination Type and to specify the condition for the restoration 
of signs. Then, select the function name from the Function Name 
List and enter the remaining data. 

 
4. Use Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis. 
 

5. Use the post-processing functions of Results to analyze or combine the 
analysis results. 

 

Using Model>Masses> 
Loads to Masses, the 
desired loading condition 
of the static load data 
can be converted to 
nodal masses. 
This function is 
extremely useful for a 
seismic analysis where 
dead load is to be 
converted into mass. 

It is convenient to use 
the built-in design 
response spectra to 
specify Spectrum 
Function. The built-in 
design response spectra 
are as follows:  
· UBC 88-94 
· UBC 97 

Civil can restore the 
signs of the analysis 
results that have been 
combined by SRSS or 
CQC method. The results 
with the restored signs 
can then be used for 
foundation design and 
other member design 
sensitive to proper signs. 
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Time History Analysis 
 
 

1. Follow the steps 1 and 2 of Eigenvalue Analysis.  
 

2. Select Load>Seismic>Time History Functions and click 
 or  to enter the data pertaining to 

Time History Function related to Function Names in the dialog box.  
 

3. Select Load> Seismic>Time History Load Cases to enter the Load 
Case Name, the Damping Ratio and the data required for the time 
history analysis process and the output.  

 
4. When dynamic nodal loads are entered as Time History Function, use 

Load>Seismic>Dynamic Nodal Loads to select the Load Case Name 
and Function Name from the Function Name List, and then enter the 
loading direction and arrival time. 

 
When ground motion is used as Time History Function, use Load> 
Seismic>Assign Ground Acceleration to select the Load Case Name 
and Function Name from the Function Name List, and then click  
in Operations. 

 
5. Select Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis. 
 

6. Use the post-processing functions of Results to analyze or combine the 
time history and static analysis results. The absolute maximum values 
within the given time history are provided for all analysis results. Use 
Results>Time History Results to analyze the results at each time step. 
The history graphs and text type results may be produced. 
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Dynamic Boundary Nonlinear Analysis 
 
 

1. Enter the properties of nonlinear link elements in the 
Boundary>General Link>General Link Properties menu. 

 
2. Define the nonlinear link elements in the model using 

Boundary>General Link>General Link. 
 

3. Enter the mass data. 
 

4. Define the dynamic loads in the Load>Seismic>Time History 
Functions dialog box. 

 
5. Enter the time history analysis conditions and various control data 

required to perform time history analysis in Load> Seismic>Time 
History Load Cases. 

 
6. Enter the time load functions in the form of ground acceleration in 

Load> Seismic>Ground Acceleration. 
 

7. Convert pertinent static loads into dynamic loads by multiplying the 
previously defined static loads by time functions in Load>Seismic 
>Time Varying Static Loads. 

 
8. Enter the control data required to perform eigenvalue analysis in 

Analysis>Eigenvalue. 
 

9. Carry out the analysis in the Analysis>Perform Analysis menu or by 
clicking  Perform Analysis. 

 
10. Upon completing the analysis successfully, we can check the 

displacements and max/min member forces for the Time History load 
cases. We can also check the time history analysis results in 
Results>T.H Graph/Text>Time History Graph. 
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Dynamic Boundary Nonlinear Analysis Model of a bridge attached with 
bearing isolators 
 

 
Dialog boxes for entering nonlinear properties of bearing isolators 
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Shear force-Deformation graph of bearing isolator obtained from dynamic 
boundary nonlinear analysis 
 
 
 
Buckling Analysis  
 
 

1. Static analysis results are required to provide the initial geometric 
stiffness matrix for the buckling analysis of a structure. Thus, the load 
cases for the buckling analysis must be specified first to analyze the 
buckling modes. Follow the procedure presented in Static Analysis 
above.  

 
2. Invoke the dialog box of Analysis>Buckling to enter the number of 

modes and the data necessary for convergence. Assign the load cases to 
be considered in the buckling mode analysis. 

 
3. Use Analysis>Perform Analysis or click  Perform Analysis to 

perform the buckling analysis. 
 

4. Use Results> Mode Shapes>Buckling Mode Shapes or Results>Result 
Tables> Buckling Mode Shape to verify the buckling mode shapes and 
the critical buckling load factors for each mode. 
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P-Delta Effect Analysis 
 
 

When considering the P-Delta effect in the static analysis and dynamic 
analysis processes, use Analysis>P-Delta to assign the load cases to be 
considered for the formation of the geometric stiffness matrix. In addition, 
enter the number of iterations and the tolerance for convergence. midas 
Civil only performs P-Delta effect analysis for structures modeled with truss 
and beam elements.  

 
 
 
 
Geometric Nonlinear (Large Displacement) Analysis  
 
 

The Geometric nonlinear analysis function is applicable for static analysis 
and construction stage analysis. Prior to the analysis, assign the order of 
applying the loads to be used for the analysis in Load>Nonlinear Analysis 
Data>Loading Sequence for Nonlinear Analysis, followed by assigning the 
repetitive analysis and convergence conditions required to carry out the 
nonlinear analysis in Analysis>Nonlinear Analysis Control. 

 
Geometric nonlinear analysis is applicable for all the elements except for the 
solid element. 

 
 
 
 
Construction Stage Analysis 
 
 

1. Use the dialog box of the Analysis>Construction Stage menu when a 
construction stage analysis is sought for calculating vertical 
deformations due to the creep and shrinkage of concrete. Assign the 
time dependent material property types and specify the number of 
iteration and convergence condition required for creep calculation. 

 
2. If the analysis model is a post-tensioned concrete structure, specify 

whether or not the tendon prestress losses will be accounted for. 
 

3. Select Analysis>Perform Analysis or click  Perform Analysis to 
perform the construction stage analysis. 
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4. Once the analysis is successfully completed, we can verify displacements, 
member forces, stresses, etc. for each construction stage as well as the 
final construction stage in the Results menu. 

 
 

Simply specifying durations sequentially creates construction stages. 
New stages may be inserted, or the previously defined stages may be deleted. 
 
 

Simple activation and Deactivation of element, boundary and load groups 
compose the construction stages. 
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Real time display of a stage, which shows the corresponding structure and 
loading conditions using Stage Tree 
 
 
Pushover Analysis 
 
 

1. Define initial load and specify the maximum numbers of Iterations and 
convergence tolerance in Pushover>Global Control. 

 
2. Define the Pushover load case and specify Increment steps in 

Pushover>Load Case>Pushover Load Cases. 
 

3. Define the plastic hinge properties, which are to be applied to the model 
in Pushover>Assign Hinge Properties>Define Pushover Hinge 
Properties. 

 
4. Assign the defined hinge properties to each member in 

Pushover>Assign Hinge Properties>Assign Pushover Hinge 
Properties. 

 
5. Select Pushover>Perform Analysis to perform the pushover analysis. 

 
6. Verify Performance points using the Capacity spectrum and Demand 

spectrums obtained from Pushover>Pushover Curve. 
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Structural Analysis Automatically considering Support 
Settlements 
 
 

1. Use Load>Settlement/Etc.>Settlement Group to enter the groups for 
which simultaneous local settlements may occur and the magnitudes of 
the settlements. 

 
2. Use Load>Settlement/Etc.>Settlement Load Cases to assign the load 

cases for each group of local settlements.  
 

3. Select Analysis>Perform Analysis or click  Perform Analysis to 
perform the local settlement analysis.  

 
4. Verify the maximum and minimum values for each local settlement 

case. Analyze these results by combining with other load cases. 
 
 
 
 
Composite Steel Beam Analysis considering Variation of 
Pre- and Post-Composite Section Properties 
 
 

1. Use Load>Static Load>Static Load Cases to define the load cases and 
the loads applied to the pre-composite sections. 

 
2. Use Load>Settlement/Etc.>Pre-Composite Section to assign the load 

cases applied to the pre-composite sections for the analysis. 
 

3. Select Analysis>Perform Analysis or click  Perform Analysis to 
perform the analysis. 

 
4. Use the post-processing functions of Results to combine or analyze the 

analysis results. 
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Interpretation of  
Analysis Results 

 
 
 
 
 
 

Mode Switching 
 
midas Civil organizes the operating environment of the program by 
Preprocessing Mode and Post-processing Mode for user convenience and 
efficiency. 
 
All the data-entering tasks for modeling are possible only in the preprocessing 
mode. On the other hand, interpretation of analysis results such as combining 
loads, reactions, displacements, member forces and stresses is carried out in the 
post-processing mode. 
 
If the analysis is completed successfully without errors,  the preprocessing 
mode is switched automatically to  the post-processing mode. 
 
 
 

Load Combinations  
and Maximum/Minimum Values Extraction  

 
Combining Analysis Results 
 
 
midas Civil can combine all the results obtained from static, moving load, 
response spectrum, time history, heat of hydration, nonlinear and construction 
stage analyses by means of the Results>Combinations function. The combined 
results can be expressed in text or graph formats in each post-processing mode. 
Also, combining the load combination cases can create new load cases. 
 

Notice that the analysis 
results are removed 
when the modeling data 
are modified in the 
preprocessing mode 
after completing the 
analysis. However, the 
design data can be 
modified. 
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The following 2 methods are used to enter load combination data in midas  
Civil: 
 
 

1. The user directly specifies the load combination data. 
 
2. A file, which already contains the required load combinations, is 

imported. 
 
 

Type : Assign load combination methods 
Add : Linear combination of analysis results  
Envelope : Maximum, minimum and maximum absolute values from 

the results of each analysis  
ABS : Linear combination of the sum of the absolute values of 

response spectrum analysis and other analysis results  
SRSS : Linear combination of the SRSS combination of response 

spectrum analysis and other analysis results 
 

 

Auto-generation and modification of Load Combinations  
  

The load combinations 
can be selectively 
activated to suit the 
purpose of analyzing 
the results. 
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Extracting Maximum/Minimum Values 
 
 
By grouping several unit load cases, midas Civil can extract the maximum and 
minimum values of structural analysis results such as displacements, reactions, 
member forces, stresses, etc., using Envelope Type. 
 
The results produced by using Envelope Type as a load combination can be 
produced in graph or text formats in each post-processing mode. 
 
 

 
Arch bridge BMD: Envelope max 
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Analysis Results Verification 
 
The post-processing mode of midas Civil provides analysis results in graph or 
text formats for simple verification. 
 
Results supports the post-processing mode of midas Civil. The sub-menu types 
are as follows: 
 

Combinations 
Generate the load combinations 

 
Reactions   

Reaction Forces/Moments: reaction diagrams for supports  
Search Reaction Forces/Moments: verification of reaction forces at a 

specific support  
 

Deformations  
Deformed Shape: deformed shape of the model  
Displacement Contour: displacement contour diagrams  
Search Displacements: verification of displacements at a specific node 

 
Forces  

Truss Forces: member force contour diagrams for truss elements  
Beam Forces/Moments: member force contour diagrams for beam elements  
Beam Diagrams: member force diagrams for beam elements  
Plate Forces/Moments: element force contour diagrams for plate elements  
Plate Cutting Line Diagram: element force diagrams for plate elements 

along defined sections 
 

Stresses  
Truss Stresses: stress contour diagrams for truss elements  
Beam Stresses: stress contour diagrams for beam elements   
Plane Stress/Plate Stresses: stress contour diagrams for plane stress 

elements and plate elements   
Plane Strain Stresses: stress contour diagrams for plane strain elements   
Axisymmetric Stresses: stress contour diagrams for axisymmetric elements  
Solid Stresses: stress contour diagrams for solid elements 

 
Heat of Hydration Analysis 

Heat of Hydration analysis results including stresses, temperatures, 
displacements, allowable tension stress, crack ratios and time history graphs  
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Beam Detail Analysis 
Detail displacement, shear force/bending moment and maximum section 
stress distribution diagrams for a beam element 

 
Element Detail Results 

Member forces and stresses of elements for individual load cases or load 
combinations 

 
Local Direction Force Sum 

Compute the resultant forces of plate or solid elements by summing up 
their nodal forces in a particular direction 

 
Vibration Mode Shapes 

Natural frequencies and eigenvalue modes 
 

Buckling Mode Shapes 
Critical buckling factors and buckling modes 

 
Time History Results 

Time History Graph and Time History Text for analysis results 
 

Stage/Step History Graph 
Graphs of analysis results for Construction stage, Geometric nonlinear or 
Heat of hydration analysis 

 
Influence Lines 

Influence lines of reactions, displacements and member forces based on a 
moving load analysis 

 
Influence Surfaces 

Influence surfaces based on a moving load analysis 
 

Moving Load Tracer 
Trace the condition of moving loads for particular analysis results 
(reactions, displacements, member forces, etc.). 

 
Batch Conversion from MVLTRC to Static Load 

Convert different moving load conditions into static loads. 
 

Unknown Load Factor 
Supply the design load factors satisfying the specified reactions, 
displacements, member forces of truss and beam elements, etc. 

 
FCM Camber 

Produce camber control graph and table of an FCM construction stage 
analysis. 
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ILM Reaction 
Check the changing reactions of the supports being changed during an 
ILM operation. 

 
Bridge Girder Diagrams 

Produce the graphs of the maximum stresses and forces of bridge girders 
in every stage. 

 
Tendon Time dependent Loss Graph 

Produce the graphs or animations of tendon force changes by construction 
stages 

 
Result Tables 

Supply spreadsheet tables containing the analysis results such as 
reactions, displacements, member forces, stresses, eigenvalue modes, 
story displacements, story shear forces, etc. 

 
Text Output 

Supply a text output file containing the analysis results such as reactions, 
displacements, member forces, etc. arranged by the load combinations and 
output contents chosen by the user. 

 
 
Post-Processing Procedure 
 
 
The general operating procedure related to the post-processing of midas Civil is 
as follows: 
 
 

1. Click Post-processing Mode to switch to the post-processing 
environment. 

 
2. Use Results or the icons in the toolbars to recall the desired post-

processing function. 
 

3. Select the desired load case or combination when the dialog bar appears 
on the left of the screen. Click the  button located to the right of the 
load cases/combination selection list to enter a new load combination. 

 
4. Use the Components field to assign the desired displacement, member 

force or stress component. 
 

5. Use Type of Display to assign the contour, deformed shape, numerical 
values, etc. Click  to the right of the relevant selection field to 
change the details of the display if necessary.  

The toolbars for 
analyzing analysis 
results can be recalled 
into the screen by 
Customize in Tools> 
Customize>Tool bars. 
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Dialog bar of the post-processing and dialog box for the control of screen display 
 

6. For selectively displaying a part of the entire model, use View>Select to 
select the entities, and use View>Activities>Active to activate the 
entities. The selection feature can be used at any time since it is 
independent of the post-processing.  

 
7. Click  to display the post-processing results, reflecting the 

conditions assigned in the above procedure. 
 

8. When accessing another post-processing function, it is more convenient 
to use the Icon menu, the function list, or the post-processing tabs of the 
dialog bar rather than using the Main Menu. 
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Type of Display 
 
 
Multiple selections are possible. It controls the display of the post-processing 
results. 
 

Contour  Display the analysis and design results in the form of 
contour diagrams. 
 

  Assign the type of contour lines, the number of colors 
(Number of Colors), the range of color distribution 
(Customize Range), the type of colors (Color Table), 
the change of colors (Customize Color Table), the 
Gradation, etc. 

 

Contour Details dialog box 
 

Deform  Display the deformed shape. 
 

  Adjust the deformation scale (Scale Factor) of the 
deformed shape, or determine the display type of the 
deformed shape. midas Civil provides two types of 
deformed shapes. “Nodal Deform” reflects only the nodal 
displacements and “Real Deform” computes additionally 
the intermittent of beam elements between the end nodes. 

 

 
Deformation Details dialog box  

Notice that substantial 
time is required to print 
a contour processed 
with Gradation via 
Windows Meta File. 
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Values  Display the numerical values of displacements, member 
forces and stresses at the assigned location. 
 

  Assign the number of decimal points and specify the 
option of expressing the values in the exponential form. 
In addition, only the maximum/minimum values may be 
displayed. Use the Font tab of  Display Option to 
adjust the color and size of the numerical values. 

 

 
Value Output Details dialog box 

 
 
 

Legend 
 

 Assign the position and color of the legend that reflects 
all the reference items on the post-processing screen. 
 

 

 
Legend Details dialog box 

 
  

The color of legend can 
be adjusted through 
Display Option.  
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Animate  Simulate the deformation process of the model 
dynamically. 
 

  Specify whether or not the color of the contour diagram 
is to be changed according to the dynamic deformation 
process (Animate Contour). Also specify the iteration 
cycle of the dynamic deformation process as a half cycle 
or a full cycle. 
 
For reference, select the half cycle when simulating the 
deformed shape of the structure and select the full cycle 
when simulating the vibration modes or buckling modes. 
In AVI Options, assign the number of colors per pixel 
(Bits per Pixel) to set the dynamic base screen and the 
compression option of the screen data (Compressor). 
Specify the number of cutting frames (Frames per Half 
Cycle) and the number of frames per second (Frames per 
Second) to display. These items affect the quality, 
animation processing time per cycle, and also the quality 
of the dynamic screen image processing. When a 
construction stage analysis is performed, the animation 
by construction stages or by steps within a construction 
stage may be assigned. 

 

 
        Animation Details dialog box 
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Undeformed  Display the deformed shape overlapped with the 
undeformed model. Use the Draw tab of  Display 
Option to control the display of the undeformed shape. 

 

 
Display Option dialog box for Undeformed Shape 

 
 

Mirrored  Carry out the analysis using a 1/2 or 1/4 model and 
expand the results to create the results of the full model 
by plane symmetry. 
 

  Define the reference plane(s) about which the symmetry 
is created. 

 

 
Symmetric Model Mirror Detail dialog box 
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Cutting Diagram  Display the stresses in plate elements at specified 
cutting lines or planes. 
 

  Define the cutting lines or planes and select the 
direction of stresses for display. Assign the form of 
display type for the stresses (numerical values, graphs, 
min/max, etc.). 

 
 

Plate cutting Diagram dialog box 
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Cutting Plane  Display the stresses in solid elements at specified 
cutting planes. 
 

  Define the cutting planes, the expression method for 
solid elements and the moving or rotating direction for 
animation. 

 

Cutting Plane Detail dialog box 
 
 

IsoSurface  Display the IsoSurfaces of solid elements, which 
represent the surfaces of equal stresses for given stress 
values. 
 

  Specify the stress values for which the IsoSurfaces are 
to be displayed and assign the method of representing 
solid elements. 

 
IsoSurface Detail dialog box 
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Batch Output 
Generation 

 From the selected output categories, produce all graphic 
output at once by sequentially changing the load cases 
and combinations. 
 

  Select the screen output types and assign them as base 
files. 
 

  Assign base files, load cases/combinations, analysis 
relations, etc. to generate Batch Output. 

 
 

Batch Output Generation dialog box 
 
 
 
 
Post-Processing Function Types 
 
 
Examples of results display and the types of post-processing functions in midas 
Civil are noted below. Use Type of Display to produce various types of Graphic 
Output. 
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Display of Reactions 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Reaction Forces/Moments: Vertical Reactions 
 
Display of Deformed Shape   
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Search Displacements 
 

Click the mouse cursor 
over the desired node 
to display the relevant 
displacements in 
Message Window. 

Select “Values” in Type 
of Display in the dialog 
bar to display the 
numerical values of the 
reactions. 
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Select Legend.  
The color palette, 
relevant table of 
numerical values, model 
coordinate axes, file 
name, working time, etc., 
can be displayed on the 
left or right of the Model 
Window. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Deformed Shape + Undeformed Shape 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Displacement Contour 

Click the  button to 
the right of Deform in 
Type of Display in the 
dialog bar to adjust the 
scale of the deformed 
shape. 

Select Undeformed to 
view the deformed 
shape overlapped with 
the undeformed model.  

Select  Perspective 
and  Hidden, then a 
very realistic contour 
will be displayed. 

Click  next to 
Contour in Type of 
Display of the dialog bar 
to adjust the division of 
contour, the types of 
colors and the gradient 
treatment. 
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Display of Member Forces  
 

Maximum Moment Diagrams  
 
 
 
 
 
 
   
 
 
 
 
 
 
 
 
 
 
Beam Forces/Moments: Axial Forces 

  

Using Window>New 
Window, different types 
of windows can be 
displayed simultaneously. 

”5 Points” in Display 
Options uses the 
calculated SFD/BMD at 
the nodes and 1/4 
points. With “Exact” the 
shear forces and 
bending moments are 
computed over the 
entire lengths of the 
beam elements and 
SFD and BMD are 
displayed exactly. 
“Select “Fyz” or “Myz” in 
Components to display 
the SFD/BMD about the 
strong & weak axes 
simultaneously. 

Check () in “Values” in 
Type of Display and 
assign “Max” in Output 
Section Location to 
display the maximum 
member forces for 
beam elements. 
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Display of Stresses  
 

 
Beam Stresses: Combined Stresses  
 

 
Plane-Stress/Plate Stresses: von-Mises Stress Contour 

Select Hidden Option 
(Model) in the Draw tab 
of  Display Option 
and assign Plane 
Thickness in the 
Thickness field. Then, 
click  Hidden, to 
display the stress 
distribution of plate 
elements reflecting the 
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Plane-Stress/Plate Stresses: Principal Stress Vectors 
 

 
 Plane-Stress/Plate Stresses: Cutting Diagram 

 

With “Local” in the 
Stress Options field and 
“Vector” in the 
Components field, the 
principal stress contour 
is displayed as vectors. 

Select Window> New 
Window to display 
different post-processing 
results simultaneously 
in separate windows.  

With Cutting Diagram, 
plate stresses can be 
displayed at the specified 
cutting lines in graphs. 
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Solid Stresses - Principal Stress Contour  
 

 
                                                           Solid Stresses – Cutting Planes 
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Display of Detail Analysis Results for individual Beam Elements 
 

 
Beam Detail Analysis 
 

 
Beam Detail Analysis: Normal Stress 
 
 

Beam Detail Analysis 
supplies, for a specific 
beam element, the detail 
displacement diagram, 
SFD/BMD, the section 
stress related to a 
particular section, the 
maximum stress 
distribution diagram 
over the entire length of 
the beam element, etc. 

If a particular position 
on a beam element is 
specified, the bending 
stress, shear stress, 
effective stress, etc. 
occurring at that position 
can be evaluated. 
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Beam Detail Analysis: von-Mises Stress 
 
 
Display of Analysis Results for individual Elements 
 

  
Element Detail Results 

With Fast Query, analysis 
results for an element 
can be displayed in the 
post - processing mode. 

Upon selecting a 
particular point on a 
cross section, bending, 
shear and effective 
stresses, etc. can be 
checked in detail.  
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Display of Local Direction Force Sum 
 

 
Local Direction Force Sum 
 
Display of Vibration Mode Shapes  
 

 
Vibration Mode Shapes 

Select the View tab in 
 Display and use 

Description to include 
comments on the screen.  
Click the  button 
to the right of Description 
to adjust the size, type 
and color of the fonts. 
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Display of Buckling Mode Shapes 

 
Buckling Mode Shapes 
 
Display of Influence Line/Surface 

 
Influence Line 

Using Multi-Modes, you 
can analyze several mode 
shapes simultaneously. 
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Influence Surface 
 
Display of Moving Load Tracer 

Moving Load Tracer 
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Animation 
 
 
midas Civil provides the capability of animating static and dynamic analysis 
results. The animation reflecting dynamic effects of the analysis results can be 
extremely useful in analyzing the structural behaviors and creating presentation 
materials. Follow the directions below. 
 
 

1. Recall the functions (Beam Stresses, Vibration Mode Shapes, 
Influence lines, etc.), which yield deformed shapes, vibration modes, 
buckling modes, etc. and select the desired load case or mode. 

 
2. In Components, select the component of relevant analysis results. 

 
3. Select “Animate” in Type of Display, and choose additional selection 

items as necessary. 
 

4. Click . 
 

5. Select  Record in the animation control bar at the bottom of the 
working window. The Animation reflecting the items selected in Type 
of Display is displayed repeatedly on the working window. Use the  
button to the right of Animate to adjust the speed of animation. 

 
6. Select  Save in the animation control bar and enter the desired 

filename to save the played animation. If the extension of the file is not 
assigned explicitly, the “AVI” extension is imposed. Double-click to 
replay the saved animation after searching the relevant file in the folder. 

 
7. Select  Close to terminate the animation function. 

 
 
 
Please note that animation is not supplied in  Render View. 

The Icons controlling 
the animation during the 
animated simulation are 
as follows:  
 

 Play 
 Pause 
 Stop 
 Skip Back 
 Rewind 
 Fast Forward 
 Skip Forward 
 Save 
 Record 
 Close 
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Verification by Result Tables 
 
 
In Results>Result Tables, midas Civil provides Table Window in the 
spreadsheet form similar to that of Excel, which enables us to evaluate the 
analysis and design results at a glance. midas Civil provides the following 
verification capabilities for result tables: 
 

 Spreadsheets related to all the analysis and design results 
(displacements, member forces, stresses, reactions, vibration modes, 
buckling modes, heat of hydration results, tendon coordinates and 
tensions, etc.) 

 
 A powerful Filtering function linking all types of selection functions 

 
 All types of Sorting functions (Multiple ascending/descending sorting 

rearranged in the order of priorities by material attributes) 
 

 Adjustment of text style (positions, formats of numerical values, 
assignment of effective decimal points, etc.) 

 
 Copy/Paste functions through the clipboard (assignment of all types of 

copy range) 
 

 Search text and numbers 
 

 Transfer data with other database S/W such as Excel  
 

 Elegant report output template forms 
 

Context Menu in Table Window 
 

Context Menu prompts when the mouse curser is right-clicked on the table 
window. If Graph, Filtering and Sorting supplied by Context Menu of Table 
Window are interactively used, the analysis results can be efficiently analyzed 
for different structural characteristics. The types and purposes of Context 
Menu in the analysis results table are as follows: 

Refer to Getting 
started>Tables>Table 
Tool Directions of  
On-line manual for 
detail information. 



 
 
 
 

Interpretation of Analysis Results 
 

179 

Sorting Dialog  
 
Arrange the table data in columns. We can accomplish sorting the data in an 
ascending/descending order and rearranging the data columns in the order of 
priority. For example, sorting the member forces of beam elements by strong 
axis bending moments, weak axis bending moments and axial forces in a 
descending order displays the following:  

Display of Table Sorting Dialog  
 
Style Dialog 
 
Adjust the column width, alignment, format of real numbers, decimal points, 
etc., in the table for display. 

                                                  Style Dialog 
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Show Graph 
 
25 types of graphs are provided for the table data output. 

Display of Graph: Web Chart 
 

                                        Active Records 
 
Produce the output data selectively by the attributes of elements (element types, 
types of material properties, section types, group, etc.), or produce the member 
forces or stresses of beam elements selectively by load cases/combinations, 
construction stages and positions (i-node, 1/4, 1/2, 3/4 & j-node). 
 
Where eigenvalue or buckling analysis has been performed, the output can be 
selectively produced by vibration or buckling modes. 

Records Activation dialog box 
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View by Load Cases 
 
Produce the member forces selectively by load cases/combinations. 

Result View Items dialog box 
 
 
 
 

Checking Construction Stage Analysis Results 
 
midas Civil provides Bridge Girder Diagrams, Stag/Step History Graph, 
Tendon Time Dependent Loss Graph, etc. to check and analyze the construction 
stage analysis results. The graphs can be saved as a text file type. 
 
 
Bridge Girder Diagrams 
 
 
The combined stresses at the top, bottom, left and right of the girder can be 
checked for individual construction stages. If the auto-generated Min/Max is 
selected from the list of stages, we can check the maximum and minimum 
stresses in the form of an envelope for all the stages. In the Final Stage, we can 
combine the results of the construction stage analysis and the results of other 
analyses for live load, temperature load, wind load, etc. 
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1. Select Results>Bridge Girder Diagrams. 
 

2. Using the Stage combo-box  in the model view, 
select the stage for which analysis results will be produced. 

 
3. Select the steps and load case or combination. 

 
4. Select a force component or stress components that will be combined. 

 
5. Select the structure (element) group for which the results will be 

produced. The structure groups pertaining to the PSC Box girders in 
Bridge Wizards are automatically generated. 

 
6. Enter the allowable stresses, which will appear together with the 

applied stresses on the graphs. 
 
 

Bridge Girder Stress Diagrams 
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Stage/Step History Graph 
 
 
Stage/Step History Graphs enable us to check nodal displacement, member 
force and stress history curves. The checking procedure is as follows: 
 
 

1. Select Results>Stage/Step Graph. 
 

2. Define a specific location for which displacements, forces or stresses 
will be generated for each construction stage/step.  

 
 
 
 
 
 

 
 
 
 
 
 
 
 

Dialog boxes for defining history functions 
 

3. Select either Multi Function or Multi Load Case to produce history 
graphs for multi-functions with a single load case or a single function 
with multi-load cases respectively. 

 
4. Select the load cases and combinations of relevance for producing 

graphs. 
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Stage/Step History Graph-Tower Setback displacements 

 
Stage/Step History Graph-Cable Tensions 
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Stage/Step History Graph-Stresses at Top & Bottom of PSC Box Girder 
 
 
 
Tendon Time-dependent Loss Graph 
 
 
Check immediate and long-term prestress losses in Results>Tendon Loss 
Graph. Click  so that we may also check the results through 
animations. 
 

Tendon Loss Graph 
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Tendon Coordinates Table 
 
 
Check the coordinates of the tendon insert points in Global Coordinate System 
expressed in a table format in Results>Result Tables>Tendon>Tendon Coordinates. 
 

Tendon Coordinates Table 
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Tendon Elongation Table 
 
 
The tendon elongation and the shortening of the girder are separately produced in 
Results>Result Tables>Tendon>Tendon Elongation. The summation represents 
the true lengthening of the tendon during jacking. The girder shortening signifies 
that the tendon is additionally lengthened to maintain the intended prestressing. 
 

Tendon Elongation Table 
 
 
FCM Camber 
 
midas Civil automatically generates camber control graphs that are indispensable 
for the purpose of erecting an FCM bridge. The following procedure is observed: 
 
 

1. Compose structure groups. Each structure group consists of the 
elements contained in the FCM bridge, Key Seg. Elements and support 
nodes. FCM Bridge Wizard automatically generates individual 
structure groups. 

 
2. Assign Bridge Girder Element Group, Support Node Group & Key-

Segment Elem. Group in Results>Camber/Reaction>FCM 
Camber>FCM Camber Control. 
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3. Produce the camber graph or table in Results> Camber/Reaction>FCM 

Camber>FCM Camber Graph View or Results> Camber/Reaction> 
FCM Camber>FCM Camber Table. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
FCM Camber Graph 
 
 
 
 
 
 
 
 
 
 
FCM Camber Table 
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Checking Heat of Hydration Analysis Results 
 
 
The change in temperature and stress distribution due to heat of hydration can be 
verified by means of contours, time history graphs, animations, tables, etc. 
 
 
Checking Temperature Distribution 
 
 

1. Select Results>HY Results >Temperature. 
 

2. Select the stage and step for which the temperature distribution is of 
interest.  

 
 

 
Temperature Distribution 
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Checking Stress Distribution 
 
 

1. Select Results>HY Results>Stress. 
 

2. Select the stage and step for which the stress distribution is of interest. 
 

3. Select the Stress Options and a stress component. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Stress Distribution 
 
 
 
Checking Time History Graph 
 
 

1. Select Results> HY Results>Graph. 
 

2. Select the nodes and stress components by clicking  & 
 as required for multiple selection. 

 
3. In Graph Type, select the result types among resulting Stress, 

Allowable Stress, Crack Ratio and temperature. 
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   Graph showing Resulting and Allowable Stresses 

 
 
 
 
 
 
 
 
 
 
 
 
 

  Temperature Gradient 
 
 
 
 
 
 
 
 
 
 
 
 
 
  Crack Ratio Graph 
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Production of Output 
 
 
 
 
 
 

Text Output 
 
The Text Output provides the structural analysis and design results in a text file 
format specified by the user. 
 
The principal features related to the text output of midas Civil are as follows: 
 

 Produce output for (Load Sets) individual groups of load combinations 
(it is possible to assign different load combinations for different output 
contents). 

 
 Produce selective output of member forces and stresses pertaining to 

specific material properties, section properties, element numbers, etc. 
 

 Produce the output of maximum and minimum values for each section 
property. 

 
 Produce nodal displacements and reaction forces. 

 
 Produce the output of Envelope and Summary for each element type. 

 
 Produce the output in ECS or GCS of each element.  
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Directions and Procedure of Usage 
 
 
The Text Output features operate on a method that accumulates the required 
information on a step-by-step basis for the final outcome. The procedure for 
using the Text Output features is as follows: 
 
Example: A load set for the evaluation of reactions, another load set for element 
output, and so on. Up to 3 load sets at a time may be specified. 
 
 

1. Assign Load Set. 
 

Select Results>Text Output to display the load combination selection 
dialog box for text output. 

 

Load set selection dialog box  
 

A Load Set is a collection of load cases/combinations for the desired 
output items for different results such as member forces, nodal 
displacements, reaction forces, etc. The user selects as many Load Sets 
as necessary in the load combinations selection dialog box. 
Define the method of producing output for steps in Step Option where 
construction stage analysis or geometric nonlinear analysis has been 
carried out. Click , then the Load Set entry dialog box 
shown in the next figure will be displayed. 
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Load Set entry dialog box 
 

Enter the Load Set name. A load set is registered when the desired load 
cases and/or load combinations are selected (checked) and  is 
clicked. Click  to modify the contents of a Load Set 
and click  to remove a registered Load Set. 

 
Once all the necessary load sets are defined, click  and access 
the Element Output Selection dialog box. 

 
 

2. Select Elements for Output. 
 

In the dialog box, assign the elements for output and select the output 
format. In Output Load Set for Element Output, select the load set for 
which element output will be produced among the registered load sets. 
Select the element types for which output will be produced by checking 
appropriate boxes. At this time, only the elements for which the output 
can be produced are activated in the dialog box. 

 
By clicking the button to the right of the element type, detail 
specifications related to the element output may be selected.  
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Element Output Selection dialog box 
 

Detail Output Selection dialog box 
 

Two parts constitute the Element Selection Detail dialog box. The left 
section filters the selected items, and the right section assigns the output 
format and other items. 
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Only the output for the elements conforming to the selected attributes 
among the filter items such as ID, Section, Material, etc. will be finally 
produced.  

 
Filter  : list of elements selected through the filter 
 
PreSel: list of elements already selected on the screen prior to starting 
the Text Output feature 

 
The Text Output features operate on all the elements listed in the Filter 
and PreSel fields.  

 
 

3. Select Output for Nodal Displacements and Reaction Forces. 
 

After the selection for Element Output is completed, click the  
button to switch to the dialog box for output specifications for 
displacements and reaction forces. The usage of this dialog box is 
identical to that of Element Output Selection.  

 

Output Selection dialog box for displacements and reactions 
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Dialog box for items of results output  
 
 

4. Specify the sequence of output 
 

Finally, specify the sequence of output and the output file name. 
 

It is possible to arrange the output sequence by Default or by Type. 
Select and drag the items individually with the mouse to modify the 
sequence. 

 
If Insert form feed at each output end is checked, a page form feed 
character (“ ”) is inserted at the end of each output item. Type the name 
and path of the output file in the File Name field and click the  
button to create the file. Text Editor is executed automatically and the file 
is displayed on the screen. 
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Print Output 
 
midas Civil provides a collection of format choices for print outputs for user 
convenience. midas Civil prints output in a vector or in an image format.  
 
When the model window in preprocessing or post-processing mode is printed, 
the output is generated in a vector format. The output results provide uniform 
quality irrespective of output sizes. 
 
If the screen containing a rendering view is printed, the output is printed in an 
image format. Due to the characteristics of image output, the quality of the print 
output is determined by the resolution and the number of colors used in the 
window. The size of the output also affects the quality.  
 
 
 
Output Layout Setting  
 
midas Civil provides the  Print Preview feature that enables us to adjust the 
size and position of the output before printing. 
 
Select File>Print Preview or click  Print Preview. Then, the Print Preview 
window is displayed. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Print Preview window 
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The dialog bar at the top of the screen is used to adjust the size and position of 
the output before printing. 
 
Clicking the buttons of each item with the mouse can set up a rough Layout, 
while specifying numbers in the Margin fields within the dialog bar can adjust it 
to a more precise layout. 
 
 
 

Dialog bar for Print Preview 
 
 
The following explains the dialog bar: 
 

Zoom In, Zoom Out Magnify or reduce the view, which has no effect 
on the true output 
 

Combo Box Select Paper Size 
 

Landscape/Portrait Horizontal or vertical printout 
 

Draw Rect. Border line insertion option 
 

HORZ Alignment (justified) to Center, Left & Right 
 

VERT Alignment (justified) to Center, Top & Bot. 
 

Keep Ratio Option to maintain horizontal/vertical ratio when 
changing the printout size 
 

Fit to Paper Fit the contents to the selected paper size 
Selecting Fit to Paper disables Margins/Sizes 
 

Print Resume printing 
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Output Color Setting 
 
midas Civil provides both color and black-and-white printing options for user 
convenience. By setting the Black/White Printing option, the object is printed in 
black and white based on the set up in midas Civil in lieu of printing the current 
colors of the working window.  
 
The Color Selection Option is independent of the printer types, and it may be 
freely set according to the user’s intent. 
 
The method of setting output color is as follows: 
 
Select View>Display>Display Option or  Display Option, then the dialog box 
shown in the figure below will be displayed. The Draw tab displays the dialog 
box that defines the color selection method. Select Print Color Option and set 
the print option in Option Value as shown in the figure below. 
 
Among the Color Print Options, Color Printing (View) produces the contents in 
the window colors, and the colors may be selected in Color tab from the Display 
Option dialog box. Color Printing (Setting) is adjusted in Print Color tab from 
the Display Option dialog box, and the colors in the model window and the 
output may be set independently. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

      Display Option dialog box 
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Text Editor 
 
 
 
 
 
 

Principal Features of Text Editor 
 
MIDAS Text Editor works together with the MIDAS Family Program as a 
document editor that conveniently edits relevant input/output text files. 
 
In Windows environment, the Text Editor may be used as a common text editor 
that provides the basic editing features such as compose, save and print text 
documents (may be used as a substitute for Windows memo pad). 
 
To run MIDAS Text Editor, execute  tedit.exe in the program folder of midas 
Civil, or select Tools>Text Editor from the Main Menu of midas Civil. 
 
The basic functions of Text Editor are as follows: 
 

 Create and edit document files 
 

 Search function, and header and footer inserts 
 

 Insert page split ( ) 
 

 Print layout setting 
 

 Preview print output 
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Document Output Using Text Editor 
 
When a new document has been composed or a document has been loaded in the 
editor by the Text Output function of midas Civil, the document may be edited 
and printed. 
 
 
Font Type and Size Setting 
 
 
Selecting View>Configure menu or  Configure Language displays the dialog 
box shown below. 
 
The desired font and size may be specified by clicking the  button on 
the right of the dialog box. Text Editor supports a limited number of font types 
with fixed pitch. 
 

Dialog box for font and color settings of Text Editor 
 
 
Page Split 
 
 
When a new page is desired at a specific line on the page, place the cursor at the 
desired position and press  Page Split. If the page split character  is 
inserted at the position of the mouse cursor, the page is automatically divided at 
the position of the page split character for printing. The character  does not 
appear on the printed sheets. 
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Header and Footer Insertion 
 
 
Selecting File>Header & Footer Setup menu or clicking  Heading Footing 
displays the dialog box shown below. 

 
Dialog box for header and footer insertion 

 
Check Print Header and fill in the entry fields to print the header. 
 
Check Print Footer to print the footer with the page number and date. 
 
The Page Number Position option selects the position at which the page number 
will be printed. The position is either in the middle or on the right at the bottom 
of the page. 
 
The Page Number Setting option defines the numbering style. 
####: Print the page number beginning with the Base Page Number. 
####/####: Print the current page number and the total number of pages. 
 

The Base Page Number 
is literally the first page 
(page 1) of the document 
from which the page 
numbering starts 
sequentially. 
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Page Setup 
 
 
Selecting the File>Page Setup menu displays the Page Setup dialog box. This 
dialog box defines the size of printed forms, the orientation and the margins. 
 
 

Page Setup dialog box 
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Print Preview 
 
 
When all the print settings are complete, it is advisable to verify the layout of the 
print settings. Select the File>Print Preview menu or click . Once the print 
settings are verified, start printing by clicking the  button.  
 

Print Preview window 
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Graphic Editor 
 
 
 
 
 
 

Principal Features of Graphic Editor 
 
MIDAS Graphic Editor works together with the MIDAS Family Program. It is 
a vector-based graphic editor program that edits and prints various graphic files. 
 
Various titles and comments may be added to the graphic documents with the 
BMP or EMF (Enhanced Metafile) extensions that midas Civil created. Such 
editing capabilities provide high quality documents for reports or presentation 
materials. 
 
In order to execute MIDAS Graphic Editor, execute  gedit.exe in the 
program folder of midas Civil or select Tools>Graphic Editor from the Main 
Menu of midas Civil. 
 
The principal features of Graphic Editor are as follows: 
 
 

 Drawing various images 
 

 Various editing functions  
 

 Importing external files (BMP, EMF) 
 

 Saving files in BMP & EMF formats or in its inherent type 
 

 Print Layout and Print preview functions 
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Usage 
 
Refer to the Graphic Editor section of the On-line Manual for further details 
regarding the image and editing functions of the Graphic Editor. 
 
 
Open an Image File 
 
 
This opens graphic files (BMP, EMF) created by midas Civil. 
 

 Open 
Click  to display the dialog box. After selecting the file format 
(BMP, EMF), move the file to the desired folder. Select a file name and 
click the  button. 

Open Graphic File view 
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 Insert Image 
If the cursor is in a stand-by state for image insertion, move the cursor 
to the desired position and insert the image by left-clicking the mouse. 

 
 Adjust Size and Position 

Adjust the position of the image by holding and dragging the center of 
the image with the mouse. Adjust the size of the image by dragging a 
corner. 

 
 
Create Image Setting and Add Title 
 

 Transparent Color Setup 
This is a tool that makes the desired color transparent. It is very useful 
when printing an image with a black background.  

 
Select an opened image by clicking the image once and right-click the 
mouse. Then select Component Properties. The dialog box shown in 
the figure below is displayed. Check Transparent under Bitmap 
Properties in General and select the black color, then the background 
becomes transparent. 

     Component Properties dialog box 
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Example of black background changed to transparent color 
 
 

 Image Framework 
The image framework may be defined by clicking  Rectangle. After 
selecting each rectangle, right-click the mouse to open the Context 
Menu. Select Properties in the Context Menu, then the thickness and 
color of the lines or the color of the face may be adjusted by the 
Component Properties dialog box. 

 
 Adjust the Overlapping Order of Images 

In Graphic Editor, the image drawn first is behind those drawn later. 
The overlapping order adjustment feature rearranges the overlapping 
order. Selecting Order>Send to Back in the Context Menu or Bring 
Forward can adjust the overlapping order. 
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Framework generated by Rectangle Image edited with Component Properties 
(2 rectangles) 

                                    Example of a later-drawn rectangle brought backward by the overlapping 
                                    order adjustment function 
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 Input of Text  
The graphic editor allows the user to add titles or explanatory texts. 
Clicking  Text brings the cursor into a stand-by state for text input. 
At this time, move the cursor to the desired position and left-click the 
mouse. A text input element appears with “Text” written inside. 

 
The desired text may be entered after double-clicking “Text”. Once the 
desired text has been typed in, click elsewhere on the window away 
from the text field to prompt the end of input. Now, right-click the 
mouse on the Text element, select Properties in the Context Menu, and 
edit the text properties to the desired format. The component properties 
such as the type, size and color of font, the format of the framework, 
etc., may be assigned. Even the text may be rotated such that the text is 
read vertically. 

 
 
Addition of title on an image 
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 Insert Explanatory Lines 
By using the Line and Polyline commands and the text input function, 
explanatory lines to help clarify the image are inserted. 

 
The Selection menu at the bottom of the screen determines the drawing 
method of the extremity and line shapes of Line or Polyline. For 
drawing a new, straight line, the line begins with the selected shape at 
the Start Point and ends with the selected shape at the End Point. If 
Orthogonal is checked, the shortest perpendicular lines linking the start 
and end points are drawn. By applying such a method, explanatory lines 
may be inserted in the drawing. First, place the start point in Circle and 
the end point in Arrow, and input Polyline. If an additional text is 
inserted to the right, the explanatory line is now completed. 

 
 

 
Example of explanatory lines 
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Print Preview and Page Setup 
 

 Print Preview 
When the drawing is complete, the layout of the drawing for printing 
may be verified in advance by Print Preview. The printing is executed 
identically to the print preview displayed on the screen. 

 
 Page Setup 

Adjust the size, direction and margins of the printed forms. 
 
 
 

Print Preview 
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APPENDIX A. Toolbars and Icon Menus 
 
 
File, Help, Redo/Undo  Toolbar 

   
 
 

 New Open a new file. 
 

 Open Open a saved file. 
 

 Save Save the current working file. 
 

Project Information Register the general project information 
(project name, user name, etc.). 
 

 Print Print the currently active window. 
 

 Print Preview View the window for printing prior to actual 
printing. 
 

 Register Protection 
Key 

Register Protection key ID for web 
authentication or hardware lock. 
 

 On-line Manual Invoke online help, show start page, and 
display program information (version, build 
date, etc.). 
 

 Undo Cancel the latest input items entered during the 
modeling process and restore the model to the 
previous state. 
 

 Redo Restore the tasks cancelled by the Undo 
function. 
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Zoom & Pan Toolbar 

 
 
 

 Zoom Fit Fit the currently active model to the size of the 
Model Window. 
 

 Zoom Window Magnify the rectangular area outlined by the 
mouse. 
 

 Zoom In Magnify the model window proportionally. 
 

 Zoom Out Reduce the model window proportionally. 
 

 Auto Fitting Activate the Zoom Fit function automatically to 
accommodate varying model sizes. 
 

 Pan Left Move the model to the left by a certain distance. 
 

 Pan Right Move the model to the right by a certain distance. 
 

 Pan Up Move the model upward by a certain distance. 
 

 Pan Down Move the model downward by a certain distance. 
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View Point Toolbar 
 

 
 

 Redraw  Redraw the screen by applying the current View 
Point and Display Option. 
 

 Initial View Revert to the initial stage of opening file in the 
case of preprocessing mode. Revert to the model 
view stage after deleting the analysis results in the 
case of post-processing mode. 
 

 Iso View Display the model in a 3-D isometric view. 
 

 Top View Display the model in the X-Y plane with the view 
point from the (+) Z-axis direction. 
 

 Right View Display the model in the Y-Z plane with the view 
point from the (+) X-axis direction. 
 

 Front View Display the model in the X-Z plane with the view 
point from the (–) Y-axis direction. 
 

 Angle View Display the model relative to GCS with a specific 
view point. 
 

 Rotate Left Rotate the model to the left. 
 

 Rotate Right Rotate the model to the right. 
 

 Rotate Up Rotate the model upward. 
 

 Rotate Down Rotate the model downward. 
 

 View Previous Restore the View Point immediately prior to the 
latest change. 

 Zoom Dynamic Magnify/Reduce the model in real time as desired 
by dragging the mouse. 
 

 Pan Dynamic Move (up, down, left and right) the model in real 
time as desired by dragging the mouse. 
 

 Rotate Dynamic Rotate the model in real time as desired by 
dragging the mouse. 

Redraw is used to 
remove the Dynamic 
Label, which displays 
automatically the Label 
for the latest input or to 
remove the residual 
image on the screen. 
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Selection Toolbar 
 

 
 

 Group Toggle group tab of Tree Menu. 
 

 Toggle Work Tree 
and Previous Dialog 

Toggle Works tab of Tree Menu and Previous 
Dialog box. 
 

 Select Single Select/unselect one node or one element at a time 
with the mouse. 
 

 Select Window Select the nodes and elements within a 
rectangular area defined with the mouse. 
 

 Select Polygon Select the nodes and elements within a polygonal 
area defined with the mouse. 
 

 Select All Select all the nodes and elements displayed in the 
current window. 
 

 Select Previous Reselect the last-selected nodes and elements. 
 

 Select Recent 
Entities 

Select the nodes and elements most recently 
created. 
 

 Unselect Window Unselect the presently selected nodes and 
elements within a rectangular area defined with 
the mouse. 
 

 Unselect Polygon Unselect the presently selected nodes and 
elements within a polygonal area defined with the 
mouse. 
 

 Unselect All Unselect all the nodes and elements displayed in 
the current window. 
 

 Select Nodes by 
Identifying 

Select nodes by attributes. 
 

 Select Elements by 
Identifying 

Select elements by attributes. 
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Activation Toolbar 
 

 
 
 

 Active Activate and display only the selected nodes and 
elements. 
 

 Inactive Activate and display only the unselected nodes and 
elements. 
 

 Inverse Active Activate the inactive nodes and elements. 
 

 Active All Activate and display all the nodes and elements 
currently modeled. 
 

 Active Identity Activate the nodes and elements related to the 
assigned UCS x-y plane, Named Plane, Story or 
Group. 
 

 Active Previous Revert to the previous state of activation. 
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View Control Toolbar 
 
 
 
 
 

 Shrink Display the elements smaller than the true sizes 
(Shrink the elements from nodes). 
 

 Perspective Display a perspective. 
 

 Hidden Display the elements to appear as real shapes by 
removing the hidden lines, reflecting the sectional 
shapes and the thickness of the elements. 
 

 Display A feature that enables the user to verify the input 
state related to all types of attributes such as 
loadings, support conditions, node or element 
numbers, material properties and section names, 
etc. 
 

 Display Option A feature that enables the user to control the 
representation format (color, font size, etc.) related 
to all the graphics and texts in the working 
window. 
 

 Node Number Display the node numbers. 
 

 Element Number Display the element numbers. 
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Change Mode Toolbar 

 
 

 Analysis Perform structural analysis. 
 

 Preprocessing 
Mode 

Switch to the preprocessing mode. 
 

 Post-processing 
Mode 

Switch to the post-processing mode. 
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APPENDIX B. List of Shortcut Keys 
 

Main Menu Parent Menu Children Menu Shortcut Key 

File 

New Project   +  

Open Project   +  

Save   +  

Print   +  

Undo   +  

Redo   +  

Cut   +  

Copy   +  

Paste   +  

Delete   
Find   +  

View 

Redraw   
Initial View   +  

Zoom 

Fit  +  

Window  +  +  

In  +  

Out  +  

Pan 

Left  +  

Right  +  

Up  +  

Down  +  

View Point 

Iso  +  +  

Top  +  +  

Bottom  +  +  

Left  +  +  

Right  +  +  

Front  +  +  

Rear  +  +  
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Main Menu Parent Menu Children Menu Shortcut Key 

View 

View Point 

Rotate Left  +  +  

Rotate Right  +  +  

Rotate Up  +  +  

Rotate Down  +  +  

Previous View Status   +  

Shrink Elements   +  

Perspective View   +  

Remove Hidden Lines   +  

Render View   

Select Identity 

Element Type  +  +  

Material  +  +  

Section  +  +  

Thickness  +  +  

Named Plane  +  +  

Structure Group  +  +  

Select Single   +  +  

Select All   +  +  

Select Previous   +  

Select Recent Entities   +  

Activities 

Active  
Inactive  +  

Active All  +  

Active Identity  +  

Display   +  

Structure Structure Wizard 

Arch  +  +  

Frame  +  +  

Truss  +  +  

Node/Element Nodes 

Create Nodes  +  +  

Delete Nodes  +  +  

Translate Nodes  +  +  

Rotate Nodes  +  +  
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Main Menu Parent Menu Children Menu Shortcut Key 

Node/Element 

Nodes 

Project Nodes  +  +  

Mirror Nodes  +  +  

Divide Nodes  +  +  

Merge Nodes  +  +  

Compact Numbers  +  +  

Nodes Table  +  +  

Elements 

Create Elements  +  

Delete Elements  +  

Translate Elements  +  

Rotate Elements  +  

Extrude Elements  +  

Mirror Elements  +  

Divide Elements  +  

Intersect Elements  +  

Change Element 
Parameters  +  

Compact Numbers  +  

Elements Table  +  +  

Properties Properties Tables 

Material Table  +  +  

Section Table  +  +  

Thickness Table  +  +  

Boundaries Boundaries Tables 

Supports Table  +  +  

Beam End Release 
Table  +  +  

Rigid Link Table  +  +  

Load Loads Tables Nodal Masses Table  +  +  

Structure 

Define Structure 
Group   +  

Check Structure Data Check and Remove 
Duplicate Elements  

Load 

Static Load Cases   

Load Tables 
Nodal Loads Table  +  +  

Beam Loads Table  +  +  
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Main Menu Parent Menu Children Menu Shortcut Keys 

Load Load Tables Floor Loads Table  +  +  

Analysis Perform Analysis   
Results Combinations   +  

Mode 
Preprocessing Mode   

Post-processing Mode   +  

Query 

Project Status   +  

Query Nodes   
Query Elements   +  

Tools 

MCT Command Shell   +  

Text Editor   +  

Graphic Editor   +  

Window 
New Window   +  

Full Screen   +  

Help Index   
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   +   +  

 Active All Select All Select Identity Element Type 

 Previous View Status Bottom Select Identity Material 

 Copy  Select Identity Section 

 Active Identity Beam End Release 
Table Select Identity Thickness 

 Display Rear Select Identity Named Plane 

 Find Front  

   Select Identity Structure 
Group 

 Remove Hidden Lines   

  Iso  

 Perspective View   

 Shrink Elements   

  Left Material Table 

  Beam Loads Table Elements Table 

 New Project Nodal Loads Table Nodes Table 

 Open Project Floor Loads Table  

 Print  Supports Table 

 Select Previous   

 Select Recent Entities Right Rigid Link Table 

 Save Select Single Section Table 

 Project Status Top Thickness Table 

 Full Screen  Nodal Masses Table 

 Paste   

 New Window Structure Wizard-Arch  

 Cut Structure Wizard-Frame  

 Redo Structure Wizard-Truss  

 Undo   
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    +  

  Create Elements Create Nodes 

  Delete Elements Delete Nodes 

  Translate Elements Translate Nodes 

  Rotate Elements Rotate Nodes 

  Extrude Elements Project Nodes 

  Mirror Elements Mirror Nodes 

  Divide Elements Divide Nodes 

  Intersect Elements Merge Nodes 

  Change Element Parameters Compact Numbers 

 Zoom Fit Compact Element Numbers  
 
 Function  + Function 

 Help Structure Group 

 Active Inactive 

 Redraw Initial View 

 Query Nodes Query Elements 

 Perform Analysis Text Editor 

 Render View Graphic Editor 

 Preprocessing Mode Post-processing Mode 

   

 Static Load Cases Combinations 

   

   

 Check and Remove Duplicate Elements MCT Command Shell 
 
 Shortcut Key  Shortcut Key 

Zoom Fit  +  Pan Down  +  

Zoom In  +  Delete  
Zoom Out  +  Rotate Right  +  +  

Pan Left  +  Rotate Left  +  +  

Pan Right  +  Rotate Up  +  +  

Pan Up  +  Rotate Down  +  +  
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