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MIDAS Family Programs are the group of software packages for structural analysis and design 
developed by MIDAS IT Co., Ltd. 
 
 
MIDAS Family Programs and all associated documentation are copyrighted and protected by the computer 
program protection law. 
 
  
For any enquiry concerning the program or related materials, please contact the following: 
 

 

MIDASoft Inc. 
38701 Seven Mile Road, Suite 260 

    Livonia, MI  48152, USA 
MIDASoft 

Modeling, Integrated Design & Analysis Software 
Phone: 1-800-584-5541    
E-mail: MIDASoft@MidasUser.com 
http://www.MidasUser.com 

 
 
Trademarks and Registered Trademarks referred to in this User’s Guide are as follows: 
 
ADINA is a registered trademark of ADINA R&D, Inc.  
AutoCAD is a registered trademark of Autodesk, Inc.  
ETABS, SAFE, and SAP2000 are registered trademarks of Computers and Structures, Inc.  
Excel is a trademark of Microsoft Corporation.  
IBM is a registered trademark of International Business Machines Corporation.  
Intel 386, 486, and Pentium are trademarks of Intel Corporation.  
MIDAS is a trademark of MIDAS Information Technology Co., Ltd.   
NASTRAN is a registered trademark of the National Aeronautics and Space Administration (NASA).  
NISA II is a trademark of Engineering Mechanics Research Corporation.  
ScreenCam is a trademark of Lotus Development Corporation.  
Sentinel is a trademark of Rainbow Technologies, Inc.  
STAAD Pro is a trademark of Research Engineers, Inc.  
Windows is a trademark of Microsoft Corporation.  
Internet Explorer is a trademark of Microsoft Corporation. 
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PROGRAM VERIFICATION AND PRECAUTIONS BEFORE GETTING STARTED 

 
MIDAS Family Programs produce accurate analysis results based on up-to-date theories and numerical 
techniques published in recognized journals. The program has been verified by thousands of examples 
and comparative analyses with other S/W during the development. 
 
Since the initial development in 1989, MIDAS Family Programs have been accurately and effectively 
applied to over 4000 domestic and overseas projects. 
 
A strict verification process of the Computational Structural Engineering Institute of Korea has 
scrutinized MIDAS Family Programs. 
 
Due to the complexity of structural analysis and design programs which are based on extensive theories 
and design knowledge, the sponsors, developers and participating verification agencies do not assume any 
rights or responsibilities concerning benefits or losses that may result from using MIDAS Family 
Programs. The users must understand the bases of the program and the User’s Guide before using the 
program. The users must also independently verify the results produced by the program.  
 
 
 
DISCLAIMER 

 
The developers and sponsors assume no responsibilities for the accuracy or validity of any results 
obtained from MIDAS Family Programs (MIDAS/Gen, MIDAS/SDS, MIDAS/Set, MIDAS/FEmodeler, 
MIDAS/Civil, MIDAS/FX+ and MIDAS/GTS, also referred to as "MIDAS Package" hereinafter). 
 
The developers and sponsors shall not be liable for loss of profit, loss of business, or any other losses, 
which may be caused directly or indirectly by using the MIDAS package due to any defect or deficiency 
therein. 
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Preface 
 
Welcome to the MIDAS/Gen programs.  
MIDAS/Gen is a program for structural analysis and optimal design in the civil engineering and 
architecture domains. The program has been developed so that structural analysis and design can be 
accurately completed within the shortest possible time. The name MIDAS/Gen stands for General 
structure design. 
 
 
 
About MIDAS/Gen and MIDAS Family Programs 

 
MIDAS/Gen is a part of MIDAS Family Programs that have been developed since 1989. 
MIDAS Family Programs are groups of Package Software that systematically integrates the entire 
design process generally encountered in the design of structures. MIDAS Family Programs consist of 
the following entities: 
 

MIDAS/Gen General structure design system  
Structural analysis and optimal design system for general structural engineering 
applications, especially in building design 
 

MIDAS/SDS Slab & basemat Design System 
Structural analysis and optimal design system for slabs and basemats 
 

MIDAS/Set Structural Engineer's Tools 
Collection of individual programs to expedite the design of structural units 
 

MIDAS/FEmodeler finite element MESH generator 
Program for automatic generation of finite element meshes 
 

MIDAS/Civil CIVIL structure design system 
Structural analysis and optimal design system for exclusive applications in civil 
engineering structures, especially in bridge design. 
 

MIDAS/FX+ General Pre & Post-processor for Finite Element Analysis 
General purpose, FEA (Finite Element Analysis) pre & post-processing in CAE 
(Computer Aided Engineering) 
 

MIDAS/GTS Geotechnical and Tunnel analysis System 
Integrated solution for tunnel and geotechnical specific structures 
 

 
 
Among MIDAS Family programs, “MIDAS/Gen”, “MIDAS/Civil”, “MIDAS/SDS”, “MIDAS/Set”,  
“MIDAS/FEmodeler” “MIDAS/FX+” and “MIDAS/GTS”,  are currently in use and have been applied to 
over 5,000 projects. 
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Advantages and Features of MIDAS/Gen 

 
MIDAS/Gen has been developed in Visual C++, an object-oriented programming language, in the 
Windows environment. The program is remarkably fast and can be easily mastered for practical 
applications. By using the elaborately designed GUI (Graphic User Interface) and the up-to-date Graphic 
Display functions, a structural model can be verified at each step of formation and the results can be 
directly set into document formats. 
 
During the development process, MIDAS/Gen has been verified through numerous examples. Each of 
the functions has been verified by comparing the results with theoretical values and output from other 
similar programs. The program has been applied to over 5,000 projects and the reliability and 
effectiveness have been established. 
 
Representative examples are in the Verification Manual. The latest theories form the bases for the finite 
element algorithm that determines the accuracy of analysis results. Excellent results are achieved compared 
to other similar programs.  
 
 
 
Closing Remarks 

 
MIDAS/Gen has been conceived as a result of the cooperation and efforts by a number of engineers and 
professors. We expect that MIDAS/Gen users will be pleasantly surprised with satisfying results. The users 
are encouraged to contact MIDAS IT to suggest any improvements that they feel can be implemented in 
subsequent versions. 
 
In closing, we extend our gratitude to everyone who participated in the development of MIDAS/Gen.  
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About the User’s Guide 

 
The User’s Guide for MIDAS/Gen consists of the following 3 volumes and the On-line Manual: 
 

Volume 1 Getting Started & Tutorials 
Summary of the program contents and items to become familiarized 
before getting started with the tutorial examples 
 

Volume 2 Analysis 
Explanation of the analysis backgrounds 
 

Volume 3 Verification Examples 
Illustration of verification examples 
 

On-line Manual Detailed directions and explanations for each built-in function 
 
 
 
Understanding the User’s Guide is essential in effectively learning the characteristics and functions of 
MIDAS/Gen. The following is a recommended reading sequence before getting started with the program. 
 
First, read the commentaries on the structural analysis and design functions of MIDAS/Gen in Volume 2. 
Volume 2 describes the fundamentals necessary to perform finite element analysis using MIDAS/Gen. 
Some technical journals have reported that the probability of incurring errors exceeds 90% when 
programs are used with poor knowledge of analysis theories and of the programs. 
 
Install MIDAS/Gen following the procedure described in the “Installation” section of Volume 1. Read 
other parts of Volume 1, which outline the fundamental concepts necessary to run MIDAS/Gen. Also 
contained in Volume 1 are the following: the directions for various functions to run MIDAS/Gen 
efficiently, functions for modeling such as “Preferences setting”, “Input Data”, “Manipulation of Model 
Window”, “Selection Functions and Activation/Deactivation Functions”, and functions required for real 
analysis operations such as “Modeling”, “Analysis”, “Interpretation of Analysis Results”, etc. 
 
Detailed directions and explanations for each function are described in the On-line Manual that can be 
accessed from the Help Menu of MIDAS/Gen. 
 
The “Tutorials” supply the modeling, analysis and results interpretation processes of simple structural 
examples. Subsequently, practice MIDAS/Gen following the procedures described in the “Tutorials” of 
Volume 1. The Tutorials are organized so that when all the step-by-step stages from modeling to the analysis 
and design of practical examples are followed, the user understands and acquires the capabilities of the 
program. If, at any time, some contents remain misunderstood, the user may refer to the relevant sections 
contained in the On-line Manual. 
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Volume 3 presents principal analysis functions where the results have been verified by comparisons with 
theoretical values and results from other programs. Because the verification examples are simple 
problems commonly introduced in the academic courses, these examples can be practically used by the 
novice in structural analysis as materials to understand the concepts related to the fundamentals of 
structural analysis. Representative examples have been selected and included in the Verification Manual. 
Contemporary theories have been applied to the finite element algorithm that determines the accuracy of 
analysis results. Compared to the results from other similar programs, MIDAS/Gen produces excellent 
results.  
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About MIDAS/Gen 
 
 
 
 
 
 

Summary 
 
MIDAS/Gen stands for “General structure design system.”, i.e., a Windows 
based integrated system for structural analysis and optimal design. 
 
 
 
 

2002 FIFA World Cup Stadium (Jeonju) 
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MIDAS/Gen, developed in the object-oriented programming language Visual 
C++, fully exploits the advantages and the characteristics of the 32bit Windows 
environment for the technical computations.  
 
The user-oriented input/output functions are based on sophisticated and intuitive 
User Interface and up-to-date Computer Graphics techniques. They offer 
excellent facilities and productivity for the modeling and analysis of complex, 
large-scale structures. 
 
The technical aspects of structural analysis functions necessary in a practical 
design process are substantially strengthened. Nonlinear elements such as Cable, 
Hook, Gap, Visco-elastic Damper, Hysteretic System, Lead Rubber Bearing 
Isolator and Friction Pendulum System Isolator are now included in the Finite 
Element Library, which will surely improve the accuracy and the quality of 
results. Construction stages, time dependent material properties and 
geometric/boundary nonlinear analyses are some of the new inclusions. 
 
 
 

Surface View and Wire-frame View (Posteel) 
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Analysis model of a spiral staircase 
 
 
MIDAS IT’s in-house researchers have developed an efficient CAD modeling 
technique, which is a totally new concept. Powerful automatic modeling 
functions such as Auto Mesh Generation (available as a separate module) and 
Structure Wizard are introduced. Also, a new Multi-Frontal Sparse Gaussian 
Solver has been added lately, which has accelerated the analysis speed 
dramatically. 
 
Latest design standards are adopted in the design module. To list a few, they are 
ACI, AISC (ASD & LRFD), BS, Eurocodes, etc. 
 
The Optimal Design function considers various design constraints and leads to 
weight optimization in the design of steel frame structures. It offers practical, 
convenient and accurate results.  
 
Refer to “Appendix A. Principal Features of MIDAS/Gen” for more information. 
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Results of strength verification according to AISC Design Standards  
 
 
The domains of applications for MIDAS/Gen are as follows: 
 

 Civil engineering structures 
Bridges, underground structures, water tanks, dams, etc. 

 
 Architectural structures 

Office buildings, residential buildings, commercial buildings, complex 
multi-use buildings, plants, maritime/offshore structures, etc. 

 
 Special structures 

Stadiums, hangars, power plants, etc.  
 

 Other structures 
Ships, airplanes, power line towers, cranes, pressurized vessels, etc. 

 

After designing a plant 
structure, the detailed 
calculation for a 
particular member has 
been carried out. 
Automatic optimal 
design, the combined 
stress ratio and weight 
distribution by section 
properties of the 
structure are graphically 
displayed. 
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Analysis model of KAL O/C hangar, Kimpo International Airport 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Analysis model of Transportation Complex, Inchon Int. Airport
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Analysis model of Daejeon 2002 World Cup Stadium 
 
 

Installation 
 
System Requirements 
 
MIDAS/Gen operates on IBM compatible Personal Computer (PC) in Windows 
environment. 
 
In addition, MIDAS/Gen requires the following minimum configuration: 
 

 Pentium or better performing PC processor   
 Minimum of 64MB RAM  
 500 MB of free space on HDD (MIDAS/Gen requires a minimum of 1 

GB hard disk space for Construction Stage analysis)  
 Microsoft Windows 95 or higher version or Windows NT Operating 

System  
 Windows-supported Graphics card, Monitor with a minimum of 

1024×768 resolution and a minimum of 16bit High Color display  
 Windows compatible Printer or Plotter 
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Installation Sequence 
 
 
Installing MIDAS/Gen 
 
Follow the steps below to install MIDAS/Gen. 
 
 

1. Insert MIDAS/Gen CD into the CD-ROM drive.  
 
2. MIDAS Gen Installation 

When the automatic installation does not proceed, select the Run 
command in the Start menu of Windows. Once the CD-ROM drive 
is assigned, enter the following command: 

 
D:\setup 
(Note: this is the case where CD-ROM drive is assigned to the 
directory D) 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Installation dialog box of MIDAS/Gen 

 
3. Once the installation program is initiated, the dialog box shown in the 

figure above is displayed and the installation of MIDAS/Gen begins. The 
installation will proceed step-by-step to the subsequent phases following 
the displayed information. To proceed to the next step, click . 
To return to the previous step, click . 
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4. MIDAS/Gen will be installed only in the system where Internet Explorer 

version 5.0 or higher has been installed. Install Internet Explore if not 
already installed and install MIDAS/Gen. 

 

 
MIDAS/Gen information dialog box 

 
5. When the license agreement dialog box is displayed, read the agreement 

carefully. If the terms and conditions are agreeable click , and 
the installation will continue. 

 
6. Enter the user’s registration information and click . 

 
7. The directory selection dialog box will appear. Select the folder in which 

MIDAS/Gen will be installed. MIDAS/Gen can be installed in the 
default folder by clicking . To change the folder, click  
and choose the folder in which to install MIDAS/Gen. 

 
8. Once the program folder selection dialog box is displayed, select a folder 

name for the registration of MIDAS/Gen icons and other related 
programs. Click the  button, and copying the files will begin. 

 
9. Once the copying of the files is complete, the “installation completed” 

message dialog box will appear. Click  and the installation 
process now will be completed. If at this time “Run MIDAS/Gen Now” 
is checked and  is clicked, then the installation will be 
completed and MIDAS/Gen will be executed immediately.  
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Install Sentinel/pro Driver  
 
 
The Sentinel Driver is used to drive the Lock key of Sentinel hardware. To run 
MIDAS/Gen and the Lock key the driver has to be installed. The Sentinel Driver 
is installed automatically during the installation process of MIDAS/Gen. For  
upgrading or replacing a damaged Lock driver, follow the procedure outlined 
below. 
 
To install the Sentinel Driver manually follow these steps. 
 
 

1. Press the left side Shift key and insert the MIDAS/Gen CD in your 
CD-ROM drive.  

 
2. Select the Run command in the Start menu. Once the CD-ROM drive is 

assigned, enter the following command: 
 

D:\protection drivers\setup 
(Note: this is the case where CD-ROM drive is assigned to the 
directory D) 

 
 
 
 
To uninstall the Sentinel Driver follow these steps.  
 
 

1. Press the left side Shift key and insert the MIDAS/Gen CD in the CD-
ROM drive.  

 
2. Select the Run command in the Start menu. Once the CD-ROM drive is 

assigned, enter the following command: 
 

D:\protection drivers\setup /u 
(Note: this is the case where CD-ROM drive is assigned to the 
directory D) 

 
 
 



 
 
 
 
GETTING STARTED 
 

10 

Registering the Protection Key  
 
 
To operate MIDAS/Gen properly, register the serial number after connecting the 
protection key to the parallel port.  
 
 

1. Connect the Protection Key to the Parallel Port. 
 

2. Execute MIDAS/Gen. 
 

3. Select Register Protection Key on the Help menu. 
 

4. Enter the Protection Key ID provided in the Program CD Case in the 
Protection Key field. 

 

5. Click . 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Register Protection Key
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Before Getting Started 
 
 
 
 
 
 

How to Use the On-line Manual 
 
When using MIDAS/Gen, pressing F1 key or clicking the Help menu can always 
allow us to access the On-line Manual. 
 
Every category of help is connected to related keywords by hyperlink, and all the 
detailed explanations and information in connection with the keyword may be 
obtained. 
 
A summary of the help contents and an index of the main keywords are arranged 
systematically in the On-line Manual of MIDAS/Gen. Read it as a reference in 
the order presented in the summary. Alternatively, the information regarding the 
desired item may be directly obtained using the Search function of the 
keywords. 
 

On-line Manual of MIDAS/Gen 

 Symbol in On-line 
manual signifies that 
the Mouse editor is 
supported for the 
corresponding data 
entry field. The Mouse 
editor replaces the 
keyboard function for 
defining materials, 
distances, etc. on the 
screen. 
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If the Midas on the Web feature of MIDAS/Gen is used, the website of 
MIDASoft (http://www.MidasUser.com, MIDASoft@MidasUser.com) can be 
directly connected, and e-mails can be sent.  
 
 
 

Recognition of Input/Output Files 
 
The types of files, their purposes and the generation process are as follows:  
 
 
Data Files 
 
 

fn.mgb Binary The basic data file of MIDAS/Gen 

During the initial generation, use File>New Project.  
When opening an existing file, use File>Open Project. 
 

fn.mgt Text The basic data file of MIDAS/Gen 

If necessary, it can be modified using Text Editor. 
The user may transform the data generated by 
MIDAS/Gen into a format suitable for other S/W. 
The data file can also be used for MGT Command 
Shell.  
File>Export>Gen MGT File creates a file and 
File>Import>Gen MGT File recalls the file in the 
format used by MIDAS/Gen model data. 
 

fn.wpf Text Wind loading data file that MIDAS/Gen 
automatically calculated 
 
Click  in Load>Wind 
Loads>Add/Modify Wind Load Code>Wind Load 
Profile to create this file. 
 

fn.spf Text Equivalent static seismic loading data file that 
MIDAS/Gen automatically calculated 
 
Click  in Load>Static 
Seismic Loads>Add/Modify Seismic Load Design 
Code>Seismic to create this file. 

 

Refer to Tools>MGT 
Command Shell in On-line 
Manual. 
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Analysis Output Files 
 
 

fn.ga1 Binary Data file obtained from a static/dynamic analysis 
process  
File generated automatically by Analysis>Perform 
Analysis  

fn.ga2 Binary Analysis results generated for each time step from a 
time history analysis and a heat of hydration analysis  
File generated automatically by Analysis>Perform 
Analysis  

fn.ga4 Binary File for all the analysis data generated in the process 
of a geometric nonlinear analysis  
File generated automatically by Analysis>Perform 
Analysis  

fn.ga5 Binary File for all the analysis data generated in the process 
of a pushover analysis  
File generated automatically by Design>Perform 
Pushover Analysis  

fn.ga6 Binary File for all the analysis data generated in the process 
of  construction stage analysis  
File generated automatically by Analysis>Perform 
Analysis  

fn.anl Text File containing structural analysis results (reactions, 
displacements, element forces, stresses, etc.) which 
has been arranged by the user’s preference  
This file is useful for verifying analysis results and 
preparing calculation sheets.  
File generated automatically by Results>Combinations 
or Envelope  

fn.out Text All kinds of messages or related data produced 
during a structural analysis process  
File generated automatically by Analysis>Perform 
Analysis. 
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Design Output Files 
 
 

fn.gd1 Binary Design of steel frame elements and all the related 
data  
File generated automatically by Design>Steel Code 
Check  

fn.gd2 Binary Design of RC (reinforced concrete) elements and all 
the related data  
File generated automatically by Design>Concrete 
Code Design (or Concrete Code Check)  

fn.gd3 Binary Design of footings and all the related data  
File generated automatically by Design>Footing 
Design  

fn.gd4 Binary Design of SRC elements and all the related data  
File generated automatically by Design>SRC Code 
Check  

fn.acs Text Data file that contains a summary of structural steel 
member design results and the detail calculations  
Click  or  in the design results 
dialog box after a design.  

fn.rcs Text Data file that contains a summary of reinforced 
concrete member design results and the detail 
calculations  
Click  or  in the design results 
dialog box after a design.  

fn.src Text Data file that contains a summary of structural 
steel/reinforced concrete composite member design 
results and the detail calculations  
Click  or  in the design results 
dialog box after a design. 
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Graphic Files 
 
 

fn.color   Binary Color data file of MIDAS/Gen  
Click  in Color and Print Color tabs from 
the View>Display Option. 
 

fn.emf Binary Graphic data file of the model window in the EMF 
(Enhanced Meta File) format  
File generated automatically by Files>Windows 
Meta File.  

fn.bmp Binary Graphic data file of the model window in the BMP 
(Bitmap) format   
File generated automatically by Files>Windows 
Bitmap File.  

fn.mgf Binary Graphic data file produced by Graphic Editor of 
MIDAS/Gen   
File generated automatically by the Save function of 
Tools>Graphic Editor. 

 
 
 
 
Data Transfer Files  
 
 

Fn.mgt Text MIDAS/Gen text file  
Fn.dxf Text AutoCAD DXF file compatible with data for 

MIDAS/Gen  
Fn.s90 Text Data file of SAP90 compatible with data for 

MIDAS/Gen  
Fn.s2k Text Data file of SAP2000 compatible with data for 

MIDAS/Gen  
fn.std Text Data file of STAAD compatible with data for 

MIDAS/Gen  
fn.gti Text Data file of GT STRUDL compatible with data for 

MIDAS/Gen 
 

Refer to 
“File>Import/Export/Dat
a Conversion” of On-
line Manual. 
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Other Files 
 
 

fn.bak Binary Back-up data file of MIDAS/Gen   
Select Make Backup File in Tools>Preferences to 
create the file automatically while saving the model 
data in progress.  

fn.bom Text Weight data file of every element included in the 
modeling and bill of material   
File generated automatically by Tools>Bill of 
Material.  

fn.sgs Text Seismic data file produced by the seismic 
acceleration and response spectrum generation 
module of MIDAS/Gen   
It uses Tools>Seismic Data Generator.  

fn.spd Text Response spectrum data file required for a response 
spectrum analysis  
File produced by Load>Response Spectrum Analysis 
Data>Response Spectrum Functions.  

fn.thd Text Time Forcing Function data file required for a time 
history analysis   
File produced by Load>Time History Analysis 
Data> Time Forcing Functions.  

fn.bog Binary File containing the data entered in the Batch Output 
Generation dialog box   
Among the checking features of analysis results of 
the Results menu, the  button of the Batch 
Output Generation dialog box generates the file, 
which can be accessed by the  button. 
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Organization of Windows and Menu System 
 
The Menu System of MIDAS/Gen permits an easy access to all the functions 
related to the entire process of input, output and analysis and minimizes the 
mouse movement. 
 
The Works tab of Tree Menu systemizes the entire design process, which allows 
us to review the status of input at a glance while the Drag & Drop type of 
modeling capability allows us to readily modify the data during the modeling 
process. 
 
The organization of the working windows of MIDAS/Gen and the Menu system 
are as follows: 
 

 
 
Organization of the working windows and the Menu system of MIDAS/Gen 
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Main Menu 
 
 
The commands and shortcut keys for all the functions necessary to run 
MIDAS/Gen are built-in.  
 
 

File  File, print, data transfer and related functions 
 

Edit  Undo/Redo functions and functions related to editing in 
spreadsheet table window formats 
 

View  Visual presentation method and manipulation functions, 
selection functions, Activation/Deactivation functions, etc. 
 

Model  Entering model data and automatic generation of grids, 
nodes, elements, section properties, boundary conditions, 
masses, etc. 
 

Load  Enter all types of static loads, dynamic loads, thermal loads, 
automatic generation functions, etc. 
 

Analysis  Enter all types of control data necessary for analysis process 
and analysis execution functions 
 

Results  Enter load combinations, plotting analysis results (reactions, 
displacements, member forces, stresses, vibration modes, 
buckling modes, etc.), verification and analysis functions, 
etc. 
 

Design  Automatic design of structural steel, SRC, RC and footings, 
code checking, etc. 
 

Mode  Switch functions between preprocessing and post-processing 
modes 
 

Query  Status verification functions for nodes, elements and related 
data 
 

Tools  Assignment of unit system and preferences setting, MGT 
Command Shell, computation of bill of material, extraction 
of seismic data, Sectional Property Calculator, etc. 
 

Window  Control functions for every window within the main window 
and arrangement functions 
 

Help  Help functions and access to MIDAS IT homepage and e-mail. 
 

 

When running 
MIDAS/Gen for the first 
time, the use of Main 
Menu is recommended 
to understand the built-
in functions and the 
working environment. 
Once the user becomes 
familiar with 
MIDAS/Gen, the use of 
Icon Menu or Context 
Menu will be more 
effective. 
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Tree Menu 
 
 
The entire procedure for modeling from data entry to analysis, design and 
preparation of calculations are systemically organized. An expert as well as a 
novice can efficiently work without making errors by accessing the related 
dialog boxes, which provide the procedural guidance. 
 
Also, Works Tree allows the user to glance over the input status of the current 
model data, which can be revised by the Drag & Drop capability. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Drag & Drop capability of Works Tree tab 
 
 
 
Context Menu 
 
 
In order to minimize the physical motions of the mouse, simply right click the 
mouse. MIDAS/Gen automatically selects a menu system, which offers related 
functions or frequently used functions reflecting the working circumstances of the 
user. 
 

Assign 

Drag 
Drop 

Selection 



 
 
 
 
GETTING STARTED 
 

20 

Model Window 
 
 
The working window deals with the modeling, interpretation of analysis results 
and design by means of GUI (Graphic User Interface) of MIDAS/Gen. 
 
The Model Window may present several windows simultaneously on the screen. 
Because every window operates independently, different user coordinate systems 
can be assigned to the individual windows to create a model. In addition, each 
window shares the same database and as such, the work performed in a window 
updates the other windows simultaneously. 
 
The Model Window can represent common model shapes as well as shapes 
generated by up-to-date features such as hidden lines, removal of hidden surfaces, 
shading, lighting, dispersion of color tone, etc. The model, analysis and design 
results may be displayed in rendering views. The input status of the model or each 
type of analysis and design results can be visually verified by “walking through or 
flying over” the interiors of structures using the Walk Through Effect. 
 
 
 
Table Window 
 
 
Table Windows display all types of data entry, analysis and design results in the 
Spread Sheet format. Various kinds of data modification, additional input, 
compilation, arrangement for different characteristics and searching capabilities 
are provided in Table Windows. They allow transfers with common database 
S/W or Excel. 
 
 
 

Data exchange with Microsoft Excel
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History Window 
 
 
History Window displays the contents of data entry such that the user may verify 
previous activities or the status of analysis and design process. 
 
 
 
Message Window 
 
 
Message Window displays all types of information necessary for modeling, 
warnings and error messages. 
 
 
 
Status Bar 
 
 
Status Bar presents matters related to all kinds of coordinate systems, unit systems 
conversion, select filtering, fast query, element snap control, etc., which enhance 
the work efficiency. 
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Toolbar and Icon Menu  
 
 
Icon Menu helps the user promptly invoke functions frequently used in 
MIDAS/Gen. Each icon is regrouped with the icons of similar purposes in 
various Toolbars. Each Toolbar may be easily dragged with the mouse to the 
desired position on the screen. They may be edited to appear selectively on the 
screen or modified by using Tools>Customize. For more information on any 
icon in the Toolbar, place the mouse cursor on the icon in question and tool tip 
will provide a short description.  
 
Refer to “APPENDIX B. TOOLBAR AND ICON MENU” for more information 
regarding the Toolbars and the corresponding Icons. 
 
 

Default positions of the Toolbars and status tabs in the window 

Applying Tools> 
Customize, it will be 
more convenient to 
display Node, Element 
and Property Toolbars 
on the screen during 
the preprocessing 
stage. 
Similarly, display Result 
Toolbar on the screen 
during the post-
processing stage. 

File Graphic & Snap UCS/GCS View Control 

Selection Activation 

Label
Option

Change Mode Zoom & Pan

View Point

Dynamic View

Coordinates Select Filter Elements Snap 
Location Control

Unit Change Fast Query

Stage 
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   Dialog box of Tools>Customize 
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Preferences Setting 
 
 
 
 
 
 

Assignment of Unit System and Conversion 
 
In practice, there are diverse working conditions and forms of data entry. 
MIDAS/Gen is designed to operate concurrently under a specific system of units 
or a combination of several types of unit  systems. For instance, “m” unit for the 
geometry data and “mm” unit for section data may be used in the same model. 
The “SI” unit system used in the data entry process can be converted into the 
“Imperial” unit system for the analysis and design results.  
 
The thermal unit system requires a consistent unit system for the data. The units 
for moment, stress or modulus of elasticity which combine length units and force 
units are automatically adjusted by the program according to the types of length 
and force units selected by the user.  
 
The user may use Tools>Unit System or the unit system conversion function of 
Status Bar located at the bottom of the screen to assign or convert the system of 
units.  
 
                                
 
 
 
 
 
 
 
 
 
 
 

 
         Dialog box of Unit System Setting
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Preferences Setting 
 
Generally, each project is unique. The size and the material characteristics of a 
structure differ from one another, and it is convenient to define the modeling 
environment in advance when starting a new project. 
 
As the scale of the structure becomes apparent during the initial stage of a new 
project, it is possible to assign the grid spacing using Grid in advance. This will 
avoid additional and cumbersome adjustments of the screen dimensions. 
 
Tools>Preferences of MIDAS/Gen allows the setting of the basic data required 
to run the program in advance. 
 
When the Preferences function is selected, the dialog box shown below is 
displayed. Select the entities desired from Tree Menu on the left side and enter 
the required data. 
 
Environment  

General  Provide the user’s name, company logo & set the 
automatic file saving defaults  

View  Set the default window and its size  
Data Tolerance  Assign the bounds of nodal combination and the 

upper limit of numerical values to be recognized as 
zero (0)  

Property  Assign the basic database for materials and sections  
Design  Assign applicable design standards for different 

material types properties  
Load  Save the database for the floor loads 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
Dialog box for Preferences 
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Output Formats  
Formats  Assign the effective number of decimal points for the 

model data and analysis results 
 

Refer to On-line Manual for detail information regarding each of the above-
mentioned Preferences. The View function is necessary to set the working 
window at the initial stage of the work as described below. 
 
Initial Model Boundary Size  

Assign the size of the working window. For example, if the length unit is set 
to “m” and “10” is entered, the vertical length of the new window will be set 
to 10m. 

 
Initial Point Grid  

Assign the spacing of point grids to display in the window.  
Grid Space x  Spacing of point grids in x-direction in user 

coordinate system  
Grid Space y  Spacing of point grids in y-direction in user 

coordinate system  
Grid On  Option to display the point grids in the window 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 

 

 

Default window of MIDAS/Gen 

Refer to “Preferences 
Setting for Modeling” in 
Getting Started & 
Tutorials. 

Coordinate system 

Mouse Hair

Coordinates Unit System 

View Point 
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Initial View Point  
Assign the window coordinate system to correspond to either an isometric 
view (Iso View) or the global X-Y plane coordinate system. 

 
 
 
 
 

Initial window after setting the preferences 
 
 
Notice that the initial window appears as shown in the figure above after 
specifying the following: The length unit is set to “m” in Tools>Unit System. 
The size of the default window is 10m in View of Tools> Preferences. The grid 
spacings in the x & y directions of the coordinate system are set to 1m and 2m 
respectively. 
 
Snap 
 
Snap is used to assign the snap state. Multiple Snap functions may be assigned 
at a time. When nodes or elements are being entered with the mouse, Snap 
automatically sets the mouse-click point to the closest grid, node or element. 
 
The types of the Snap functions supported by MIDAS/Gen are as follows: 
 

 Point Grid Snap 
Search the point grid contiguous to the mouse cursor. 
Set the point grid by  Set Point Grid. 

Refer to “Snap” in 
“Nodes and Elements 
Generation” of the 
“Modeling” section. 
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 Line Grid Snap 
Search the intersection of line grids contiguous to the mouse cursor. 
Set the line grid by  Set Line Grid. 

 
 Node Snap 
Search the node contiguous to the mouse cursor. 

 
 Element Snap 
Search the mid point of the element contiguous to the mouse cursor. 
In the case of a line element , the position of the snap may be adjusted by 
using the Snap point assignment function to the right of the status bar located 
at the bottom of the window. For example, the user may locate the snap at  
the third points of an element ( ). This is an extremely 
convenient feature when a line element is already set up and another line 
element has to be connected to a particular point on that existing element. 

 
 Snap All 
Select all the above-mentioned snap functions. 

 
 Snap Free   
Release all the snap functions.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 

Examples of Snap applications 

Line Element means 
elements of Line Type 
constituted by two 
nodes such as truss or 
beam elements. 

To release Snap types 
separately, click the 
relevant Icon so that it 
switches to Toggle Off 
state. 

Mouse Cursor 

Snap Point 

Snap Point 

Mouse Cursor 

Mouse Cursor 

Mouse Cursor 

Snap Point 

Snap Point 
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Modeling Preferences Setting 
 
 
Coordinate Systems 
 
 
The coordinate systems used in MIDAS/Gen are as follows: 
 

 Global Coordinate system (GCS) 
 Element Coordinate System (ECS) 
 Node local Coordinate System (NCS) 

 
The GCS uses the X, Y and Z-axes of the Conventional Cartesian Coordinate 
System with the right-hand rule. The axes are denoted by the capital letters (X, 
Y, Z). Nodal data and the majority of data entry related to nodes, nodal 
displacements and nodal reactions are in GCS. 
 
The GCS is used for the geometric data for the structure. The Reference Point is 
automatically set to the coordinates X=0, Y=0 and Z=0. 
 
In MIDAS/Gen, because the vertical direction of the screen is set parallel to the 
Z-direction of the global coordinate system, it is more convenient to coincide the 
vertical direction of the structure (the direction opposite to the direction of 
gravity) with the GCS Z-direction. 
 
The ECS uses the x, y and z-axes of the Conventional Cartesian Coordinate 
System with the right-hand rule. The axes are denoted by the lowercase letters. (x, y, z) 
 
Element internal forces, stresses and the majority of data entry related to 
elements are in ECS. 
 
The NCS is used to assign Inclined Support Condition at a particular node. NCS 
uses the x, y and z-axes of the Conventional Cartesian Coordinate System with 
the right-hand rule. The axes are denoted by the notations x, y and z. 
 
Once the Node Local Axes define the node coordinates, the following boundary 
conditions and forced displacements are entered according to the defined node 
coordinates: 
 

 Supports 
 Point Spring Supports 
 General Spring Supports 
 Surface Spring Supports 
 Specified Displacements of Supports 

Refer to “Structural 
Analysis>Numerical 
Analysis Model> 
Coordinate Systems 
and Nodes” of On-line 
Manual. 

Refer to “Structural 
Analysis>Numerical 
Analysis Model>Types of 
Elements and Important 
Considerations” of On-
line Manual. 
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User Defined Coordinates and Grids 
 
 
The User Coordinate System (UCS) is the coordinate system additionally 
defined by the user to ease the modeling task. The UCS is defined relative to the 
GCS and can be useful when the geometry is complex.  
 
Generally, the majority of structures in practice are constituted in 3-D with 
various unit-planar structures. The structure is decomposed into a number of 
planes. For each plane, apart from the GCS, a coordinate system convenient for 
the modeling task is assigned. Once the individual segments are modeled, these 
planes are reassembled with respect to the GCS, and the overall 3-D shape now 
becomes effectively complete. The UCS is used mainly for such purpose and 
assigns a local coordinate system for each unit-planar structure. 
 
User-defined Coordinate System may be saved with pre-defined titles (Named 
UCS), which can be recalled interchangeably with GCS. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
UCS and the grid layout 
 

Refer to “Open File and 
Setting of Preferences> 
Working Plane and 
Grids” in Tutorial 1 to 
understand this 
procedure. 

An example of UCS 
and Grid Line 
assignment for entering 
beam elements located 
at different angles 

User Coordinate System

Line Grid 

Global Coordinate System 
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When entering coordinates or elements, assign the grids to coincide with the 
UCS x-y plane. Such technique is extremely convenient for modeling. 
 
 
MIDAS/Gen supports the following two types of grid system: 
 

 Point Grid 
 Line Grid 

 
The point grid represented by a series of points on the UCS x-y plane is parallel 
with the x & y-axes, and each point is set equally apart. Generally, during the 
initial stage of modeling, set the point grid by Tools>Preferences. Depending on 
the work conditions, use View>Grids>Define Point Grid to reassign the grid. 
 
The line grid, as a grid represented by lines at right angles on the UCS x-y plane, 
is positioned parallel with both x and y directions. The spacing may be unequal. 
 
Set the line grid by  Set Line Grid. 
 
Each grid system can be positioned at the same time, and it is convenient to use 
Snap to automatically locate the mouse cursor to a contiguous grid.  
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Entering Data 
 
 
 
 
 
 

General 
 
All the data are entered with the Dialog Box, Table Window, MGT Command 
Shell and Model Window in MIDAS/Gen. Using the Dialog Box, the data can 
be entered by both mouse and keyboard. The keyboard is mainly used for the 
Table Window and MGT Command Shell, and the mouse is mainly used for the 
Model Window.  
 
 
In the Dialog Box, the following buttons are used to reflect or cancel the data 
entry in the model. 
 

 Reflect the data entry in the model and, at the same time, close 
the corresponding operation and the dialog box.  
 

 Reflect the current data entry in the model and continuously 
accept any additional data entry and modification maintaining 
the dialog box active.  
 

 Cancel the current data entry and close the dialog box. 
 

 Close the dialog box. 

 
When shifting the focus from one data entry to another in a Dialog Box, use the 
Tab key on the keyboard to move successively from one data field to the next, or 
directly specify data by placing the mouse cursor over the desired data field. 
 
If the Shift+Tab key is used, the input sequence will be reversed. 
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Dialog box in the form of Dialog Bar 
 
The Table Window is a Spread Sheet type window where all the data entry and 
design results can be viewed at a glance. It allows the user to make any 
additional data entry or modification. 
 
MGT Command Shell is a unique modeling feature, which allows the user to 
enter data by text type commands. 
 
For more details concerning the applications, refer to the On-line Manual. 

Elements table window 

Table Window of 
MIDAS/Gen offers data 
input/output and 
modification 
capabilities. In addition, 
it provides all types of 
selection functions, 
Filtering, Sorting and 
Graph functions, data 
exchange with Excel, 
etc.  

Dialog box
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Data Input Commands 
 
For convenience, MIDAS/Gen provides the following data entry options: 
 
 

 Where several numerical data are entered consecutively in a data field, 
these data can be distinguished by a “,” (Comma) or a “  ” (Blank). 

 
 <Example> ‘333, 102, 101’ or ‘333 102 101’ 

 
 Position data, element sections and properties and other relevant data 

can be entered by simple assignments in the Model Window.  
 

 Length or directional increments can be specified using the mouse by 
choosing the relevant origin and ending points in the Model Window 
rather than typing these data directly on the keyboard. 

 
 Where the same length is repeated, the entry can be simplified by 

“number of repetition @ length” instead of repeating the same number.  
 

 <Example> 20, 25, 22.3, 22.3, 22.3, 22.3, 22.3, 88  20, 25, 5@22.3, 88 
 
The keyboard may be used to enter selected data directly. The related node 
numbering or element numbering may be an arithmetic progression in series or 
the progression may be incremental. Then, the data entry can be simplified by 
“start number to (t) final number” or “start number to (t) final number by 
increment”.  
 

< Example> 21, 22, … , 54, 55, 56  “21 to 56”, “21 t 56” 
 

< Example> 35, 40, 45, 50, 55, 60  “35 to 60 by 5”, “35 t 60 by 5” 
 

 Numbers and mathematical expressions can be used in combination. 
The majority of the operators and parentheses applied in engineering 
computation can be used. 

 
<Example> π × 202  PHI * 20^2 

 

<Example> ⎟
⎠
⎞⎜

⎝
⎛ ++×+ 30sin30cos230sin335 22  

“35 + 3 * (sin(30) + 2 * SQRT(cos(30)^2+sin(30)^2))” 
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Notation Content Remarks 

( Open parenthesis – 

) Close parenthesis – 

^ Power of n 
( ^2 square, ^3 cube) Ex.: 23 = 2 ^ 3 

+ Addition – 

– Subtraction – 

* Multiplication – 

/ Division – 

PI π 3.141592653589793 

SQRT  Ex.: 2  = SQRT(2) 
SIN Sine Unit: Degree 

COS Cosine Unit: Degree 

TAN Tangent Unit: Degree 

ASIN Arc Sine Ex.: sin-1(0.3)=ASIN(0.3) 

ACOS Arc Cosine Ex.: cos-1 (0.3)=ACOS(0.3) 

ATAN Arc Tangent Ex.: tan-1 (0.3)=ATAN(0.3) 

EXP Exponential function Ex.: e0.3 =EXP(0.3) 

SINH Hyperbolic Sine Ex.: sinh(1)=SINH(1) 

COSH Hyperbolic Cosine Ex.: cosh(1)=COSH(1) 

COTAN Cosine/Sine Ex.: cotan(1)=COTAN(1) 

LN Natural Logarithm – 

LOG Common Logarithm – 

Built-in operators in MIDAS/Gen 
 
 
※ Highlights of usage  

1. Operators accept the mixed use of capital and lowercase letters. 
 

2. As the operators are similar to that of an engineering calculator, the 
hierarchy of operations follows the rules of common mathematical 
operations. 
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Manipulation of 
Model Window 

 
 
 
 
 
 
MIDAS/Gen offers various Model Window Handling capabilities for 
sophisticated and realistic visual representation of the model generation, analysis 
and design results. 
 
Model Window Handling functions can be invoked from the View menu or by 
simply clicking the icons in Toolbar. 
 
 

Model Shape Representation 
 
The Model Shape Representation functions of MIDAS/Gen such as Wire Frame, 
Hidden, Shrink, Perspective and Render View present the model in diverse shapes 
and views. These functions help the user grasp the input state of the model and 
manipulate the model as much as desired.  
 
The Model Shape Representation functions of MIDAS/Gen are as follows: 
 

 Shrink  
Display the modeled elements in proportionally reduced sizes. 

 
 Perspective  
Display a perspective 3-dimensional view of the model. 

 
 Hidden  
Display the model shape reflecting the sectional shapes of elements and their 
thicknesses as it would truly appear. 

 
 

 Shrink is typically 
used to check the 
connectivity of nodes 
and elements 
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3-D Plant Structure: Shrink, Perspective and Hidden Views 
 
 

 Render View  
Display the model shape reflecting the sectional shapes of elements and their 
thicknesses with a shadowing effect as it would truly appear. 

 
 Rendering Option 
Modulate the effects of lighting and shadowing of Render View. 

 
 Display 
Display in the working window the nodal and element numbering, material 
and sectional designation, the loading input state, etc.  

 
 Display Option  
Control all the graphics displayed in the working window including all types 
of display modes such as the color palette of characters, the displayed size, 
etc. 

 
 

Refer to Model>Verify 
input results>  Display 
Option section. 

The Size and Draw tabs 
in  Display Option 
controls the Factor and 
Scale adjustment, and 
the reflection of the 
thickness related to 
Model Shape 
Representation. 

This model is viewed 
with Shrink, Perspective 
and Hidden using the 
Model Shape Represen- 

  -tation Toolbar. 

The Rendering function 
is provided in the 
window, and the 
Render View is used to 
apply the functions 
such as Blending. 

Model Shape Representation
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Zoom in/out and Motion Control (View Manipulation Functions) 
 
All the View Manipulation functions of MIDAS/Gen with the  Render View 
function assist the user to accurately grasp the three-dimensional views of the 
model input state and the analysis and design results through diverse view angles 
and points.  
 
 
View Point 
 
The View Manipulation functions of MIDAS/Gen are as follows: 
 

 Iso View 
Represent the model in a three-dimensional space. 

 
 Top View 
Represent the model as viewed from the +Z direction. 
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 Left View 
Represent the model as viewed from the –X direction. 

 
 Right View 
Represent the model as viewed from the +X direction. 

 
 Front View 
Represent the model as viewed from the –Y direction. 

 
 Angle View 
Represent the model as viewed from a specified viewpoint. 

 
 
Rotate 
 

 Rotate Left 
Rotate the model to the left (clockwise about Z-axis). 

 
 Rotate Right 
Rotate the model to the right (counterclockwise about Z-axis). 

 
 Rotate Up 
Rotate the model upward from the horizontal plane. 

 
 Rotate Down 
Rotate the model downward from the horizontal plane. 

 
 
Zoom 
 

 Zoom Fit 
Fit the model to the screen size by scale up/down. 

 
 Zoom Window 
Assign the desired size of the window by dragging a corner of the window 
with the mouse. 

 
 Zoom In 
Magnify the current window gradually. 

 
 Zoom Out 
Reduce the current window gradually. 
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Pan 
 

 Pan Left 
Move the model window to the left. 

 
 Pan Right 
Move the model window to the right. 

 
 Pan Up 
Move the model window upward. 

 
 Pan Down 
Move the model window downward. 

 
 
 

Dynamic View Manipulation 
 
The Dynamic View of MIDAS/Gen provides Zoom, Pan and Rotate functions. 
It displays realistic views of the structure in real time from the desired viewpoint 
by keeping the mouse left-shifted and dragging the mouse. 
 
By linking Dynamic Zoom/Rotate and Render View, we can look inside and 
walk through the structure (Walk Through Effect) or fly over the structure. 
 
 
 
 
 
 
 
 
 
 
 
Zoom Dynamic Illustration 
 

Keeping the mouse left-
shifted and dragging 
the mouse downward or 
to the left reduces the 
window. 

The proportioning of 
screen manipulation for 
Zoom, Pan and Rotate 
is controlled in the Size 
tab in  Display Option. 

Keeping the mouse left-
shifted and dragging 
the mouse upward or to 
the right magnifies the 
window. 

Zoom out 

Zoom out

Zoom in 

Zoom in 
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Pan Dynamic View 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Example of Rotate Dynamic Application 

Using  Rotate 
Dynamic, drag the 
mouse cursor 
downward or upward. 
The View Point will 
move downward or 
upward following the 
drag direction. 

Using  Rotate 
Dynamic, drag the 
mouse cursor to the left 
or right. The View Point 
will move to the left or 
right following the drag 
direction. 

By keeping the mouse 
left-shifted and moving 
the mouse cursor, the 
model window will 
follow the course of the 
mouse. 

Mouse Drag Direction 

Model Rotation Direction

Model Rotation Direction Model Rotation Direction 
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Selection and 
Activation / Deactivation 

 
 
 
 
 
 

Selection 
 
The Selection functions are extremely important and indispensable for the overall 
task of generating a model. It allows duplication of nodes and/or elements, with or 
without the same attributes such as loading or boundary conditions, activation of 
special parts, verification of input and output data, etc.  
 
The Selection functions supported by MIDAS/Gen are as follows: 
 

 Select Single 
 

 Select Plane 

 Select Window 
 

 Select Volume 

 Select Polygon 
 

 Select All 

 Select Intersect 
 

 Group 

 Select Identity-Nodes 
 

 

 Select Identity-Elements 
 

 

 Select Previous 
 

 

 Select Recent Entities 
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Graphical Selection 
 
 

 Select Single 
 

Select the desired entities by clicking the mouse once each time. To unselect 
the selected entities click them once again. The Select Window feature can be 
effected by dragging the mouse left-shifted from a fixed point. 

 
 Select Window      Unselect Window  

 
Click the diagonal corners of a window containing the entities with the mouse 
cursor and select or unselect the desired nodes or elements. 

 
When assigning the window, select only the nodes and elements completely 
contained within the window by dragging the mouse cursor from left to right. 

 
When assigning the window, select all the elements that are contained inside 
the window as well as the elements intersecting the boundaries of the window 
by dragging the mouse cursor from right to left.  

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Select plate elements successively one by one with Select Single  
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Select Window 

Drag the mouse cursor 
from left to right. The 
elements that are not 
completely contained in 
the window boundaries 
will not be selected. ( ) 

Drag the mouse cursor 
from right to left. Even 
those elements crossing 
the window boundaries 
will be selected. ( ) 
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 Select Polygon      Unselect Polygon 
 

Select or unselect the desired nodes and/or elements by successively clicking 
the corners of the polygon containing the relevant entities with the mouse 
cursor. 

 
When clicking the final corner, left-click the mouse twice. The polygon linking 
the final corner and the starting point is created, and all the nodes and elements 
contained inside the polygon are selected.  

 
 
 
 
 
 
 
 
 
 

 
Select Polygon  

 
 

 Select Intersect      Unselect Intersect 
 

Select or unselect elements by crossing a series of lines that intersect the 
desired elements with the mouse cursor in the Model Window. When clicking 
the final point of the last line, left-click the mouse twice. This terminates the 
selection process. 

 
 
 
 
 
 
 
 
 
 
 
 

Select Intersect  

To enter a loading 
acting on an inclined 
roof, select only the 
beam elements on the 
slope. 

To modify the boundary 
conditions at the 
supports, select only 
the supports by forming 
a polygon. 

In the process of 
element meshing, plate 
elements can be readily 
selected by Intersect. 

Select the final corner 
and left-click the mouse 
twice with the [Ctrl] key 
pressed; even those 
elements crossing the 
polygon line will be 
selected. 

To modify the element 
types, select the vertical 
and diagonal members 
of the truss roof. 

Polygon

Polygon

Intersect Line

Intersect Line 
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 Select Plane      Unselect Plane 
 

By assigning a particular plane, select or unselect all the nodes and/or 
elements contained in the plane. 

 
Observe the following methods to select a plane: 

 
3 Points 

Specify 3 points located in the desired plane. 
 

XY Plane 
For a plane parallel to the X-Y plane, specify a Z coordinate of the desired 
plane. 

 
XZ Plane 

For a plane parallel to the X-Z plane, specify a Y coordinate of the desired 
plane. 

 
YZ Plane 

For a plane parallel to the Y-Z plane, specify an X coordinate of the 
desired plane. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

  Select Plane by 3 Points 

Planes non-parallel to 
GCS or UCS can be 
easily assigned by 
means of 3 Points. The 
figure shows an inclined 
roof lying in a plane 
assigned by 3 Points 
placed on the grids. 

Selected Plane

1st

3rd 

2nd 
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 Select Volume      Unselect Volume 
 

To assign a particular hexagonal volume, select and/or unselect all the nodes 
and elements contained in the volume. 

 
Observe the following methods to select a hexagonal volume: 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
  

   Select Volume 

Click  and 
select the volume by 
modifying only the 
necessary coordinates. 
The part of the structure 
contained within the 
minimum and maximum 
coordinates will appear. 

Selected Volume 

1st Point of the 
Diagonal Corners 

2nd Point of the 
Diagonal Corners

Selected Volume

(Max X, Max Y, Max Z) 

(Min X, Min Y, Min Z) 
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2 Points 
Select two points of the diagonal corners of the desired hexagonal volume. 

 
XYZ Limit 

Enter the coordinates of the range of the desired hexagonal volume for 
each axis. 

 
 

 Select All      Unselect All 
 

Select or unselect all the nodes and/or elements. 
 
 
 
Specified Selection 
 
 

  Select Identity  
 

Select the desired entities by physical or geometrical identities, i.e., select 
nodes or elements with identical attributes, types or groups.  

 
Entities can be selected by each identity separately or multi-identities 
simultaneously. 

 
The types of identities that can be selected are as follows: 

 
Element Type Selection by type of element 

 
Material Selection by type of material attribute 

 
Section Selection by type of section 

 
Thickness Selection by type of thickness 

 
Named Plane Selection by name of plane 

 
Story Selection by ID of story 

 
Supports Selection of nodes by support condition 

 
Beam End Release Selection of beams by beam end release condition 

 
Wall ID Selection by wall combination numbering 

 
Structure Group Selection by element group 

 
Boundary Group Selection by boundary group 

 
Load Group Selection by load group  

Specified Selection 
 

 Select Identity-Nodes 
 Select Identity-Elements 
 Group Selection 
 Select Previous 
 Select Recent Entities 
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Select Identity - Section 
 
 
Select the desired types in the Identity list shown in the figure above. Select or 
modify the selected entities subsequently and selectively as required. Alternatively, 
one of the elements having the identity in the Model Window can be selected with 
the mouse cursor. 
 

 Select Previous 
 

Reselect the entities selected in the previous step.  
 

 Select Recent Entities  
 

Select the nodes or elements most recently generated during the modeling 
exercise. 

 
 

A section type (the top 
and bottom chords of 
the roof trusses) is 
selected with  Select 
Identity-Elements to 
modify the Element 
Type. 
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Group 
 
 

 Group  
 
MIDAS/Gen allows us to define Structure group by grouping nodes and 
elements and Boundary Group and Load Group for boundary conditions and 
loadings attributed to the nodes and elements. The three groups are subsequently 
used in combination for defining construction stages. 
 
First, assign a structure group name and designate relevant nodes and elements 
by various Select functions. Using Drag & Drop under the Group tab of Tree 
Menu, we can assign the relevant nodes and elements appropriate group names. 
In particular, it is extremely useful for modeling complex structures by selecting 
and activating certain groups without a repetitive process of selection. 
                                            
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
                              Group Dialog Bar 
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The common procedure for applying Structure Group is as follows: 
 
 
Register the desired nodes and elements as a Group 
 
 

1. Select Model>Group>Define Structure Group (or click  Group, 
select Structure Group from the Group tab of Tree Menu and select 

 after right-clicking the mouse. 
 

Define Structure Group 
 

2. Enter a group name in the Name field with Suffix numbers and click the 
 button to create a number of structure groups simultaneously. 

 
3. Using the selection functions, select the relevant nodes and elements to 

be assigned to the structure groups. 
 

4. Define structure groups using Drag & Drop of Tree Menu. 
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Define Boundary Groups and Load Groups similarly.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Group Selection (Element Selection using Tree Menu) 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Change of section properties by a simple operation of Drag & Drop of Works 
Tree tab 

Using Model>Group> 
Change Boundary 
Group/Change Load 
Group the existing 
boundary conditions 
and loading groups can 
be copied, moved and 
deleted to create other 
groups. 

Double-click the 
selected group in Tree 
Menu to select the 
corresponding nodes 
and elements. 

Right-clicking in the 
selected group of Tree 
Menu permits us to 
carry on many different 
tasks. 

Drag & Drop
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Filtering Selection 
 
 
Filtering Selection chooses line elements selectively based on the elements’ 
directional orientation while applying the Graphical Selection or Specified 
Selection features. When the desired entities are selected by Graphical Selection, 
only the line elements satisfying the Filtering Condition are selected upon 
defining the direction of axis or plane from the filter selection field illustrated in 

 below. 
 
To apply Specified Selection, define the desired entities and click the Filtering 
button ( ) illustrated in  below to select only the elements satisfying the 
Filtering condition among the selected line elements.  
 
 
 

Specified Selection 
 

 Select Identity-Nodes 
 Select Identity-Elements 
 Select Previous 
 Select Recent Entities 
 Group Selection 

Define x-axis in the 
Filter selection field and 
define the pertinent 
limits by Select 
Window. Only the 
elements parallel to the 
x-axis will be selected 
within the window. 

 Filtering button 

 Filter selection 

Filtering Selection



 
 
 
 

Selection and Activation / Deactivation 
 

55 

Model Activation/Deactivation 
 

 Active /  Inactive is used to partially activate or inactivate specific parts of 
a structure. 
 
Active represents a state in which the modeling tasks are permitted. Modeling 
tasks such as selection, addition and modification are not allowed for the 
inactivated parts. Unless this function is deliberately invoked the total model is 
always in an activated state. 
 
Inactivated Object under the Draw tab in View>Display Option allows the 
inactivated parts to either appear or disappear on the screen. 
 
This function can be effectively used for modeling complex, large-scale 
structures or post-processing tasks.  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Active/Inactive 

To create efficiently a 
frame that supports a 
bin, simplify the Model 
Window by inactivating 
the complex bin 
structure. 

To examine the 
bending moments of a 
frame located in the 
middle of a plant 
structure, activate only 
the relevant frame. 
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For instance, by only activating the desired story of a building or a part of a 
bridge on the screen, the modeling task becomes much more manageable. This 
function remarkably simplifies tasks such as adding or modifying nodes or 
elements, interpreting analysis results by selective activation of specific element 
types, section or attribute types, etc. Analyzing the maximum or minimum 
member forces will require much less effort. 
 
The Active/Inactive function is used in connection with Selection. After 
selecting the desired parts, activate or inactivate the relevant selections by using 
the functions outlined below. 
 
 

 Active  
Activate only the selected part while the remaining parts are inactivated. 

 
 Inactive  
Inactivate only the selected part while the remaining parts are activated. 

 
 Inverse Active  
Reverse the current active and inactive parts to inactive and active parts 
respectively. 

 
 Active All  
Transform all the nodes and elements in an inactivated state into an activated 
state. 

 
 Active Identity 
Activate the assigned entities on the current UCS x-y plane that contains the 
origin, a particular story, the named plane or the Group, etc.  

 
 Active Previous 
Return to the previous active or inactive state. 
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Modeling 
 
 
 
 
 
 

Nodes and Elements Generation 
 
MIDAS/Gen enables us to readily create nodes and elements as if we were 
drawing drawings using the majority of functions used in CAD programs. 
 
 
The following two methods are mainly used for generating elements in 
MIDAS/Gen: 
 

 Enter the nodes first and then enter the elements using these nodes.  
 Enter the nodes and elements simultaneously using the predetermined 

grids. 
 
 
The second method is generally recommended for expediency. Grids are 
generated first. The presence of the grids significantly reduces the risk of making 
mistakes during the modeling. This is highly efficient as nodes and elements are 
created at the same time. 
 
The first method is used when the geometric arrangement of elements is so 
irregular that the application of grids is not expected to offer any advantage. This 
method is used to perform a partial, detail analysis of planar elements.  
 
The grids are laid out in the x-y plane of the UCS. The procedure to layout the 
Point Grids is simple enough since the grid spacing is regular in each direction 
of the axes, but unsuitable for modeling an irregularly spaced structure. In such a 
case, the use of Line Grids is more effective. 
 
During the modeling task, because various functions are alternately used to 
create nodes and elements, it is convenient to use Model Entity Tab at the top of 
the Dialog Bar located on the left of the screen. The desired function in the 
function list can be selected or the Toolbars on the right of the working window 
can be used rather than using the Main Menu.  
 

Refer to the “Structure 
Modeling Using Nodes 
and Elements” part in 
the Tutorial 1 of the 
present manual for 
better understanding of 
this procedure. 

You may move the 
toolbars to any position 
by dragging the mouse. 
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The distance, coordinate, directional vector or node number can be directly typed 
on the keyboard in the Dialog Bar. Alternatively, the relevant distance or position 
can be conveniently assigned in the Model Window with the mouse cursor. When 
the mouse cursor is used to enter the above entities, click the relevant data field 
once and the background color of the data field will change to pale green. Then, 
enter the relevant data in the Model Window (Mouse Editor function). 
 
When duplicating or moving nodes and elements the relevant attributes may be 
selectively included. The relevant attributes for nodes are nodal loading, support 
conditions, etc. The relevant attributes for elements are element loading, element 
boundary conditions, etc. (Copy Node Attributes, Copy Element Attributes). 
 
When duplication is required with modification of material or section properties, 
the modification can be accomplished by specifying increments from the number 
being copied. 
 
 
 

Refer to the coordinates 
appearing in the Status 
Bar at the bottom of the 
screen while 
undertaking 
nodes/elements 
generation with the 
mouse. Function list

Model Entity Tab 

UCS Coordinates GCS Coordinates 

 Element Generation Tool Bar 

Fast Query 
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         Translate Elements 
                 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Translate Elements Dialog Bar 

Copy: Assign to copy 
Move: Assign to move 

Use when duplicating or 
moving elements while 
the material and section 
properties are altered. 
(Applicable also where 
column sections 
change while a building 
is modeled by copying 
each story.) 

Specify whether or not 
to include the relevant 
attributes when 
duplicating nodes or 
elements. 

When duplicating 
distance, use the 
mouse cursor 
instead of typing a 
numerical value in 
the data field. 
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Nodes Generation 
 
 
Use Model>Nodes or Node Toolbar to generate nodes. For detailed information 
concerning the directions, refer to On-line Manual. 
 

 Create Nodes  
Create new nodes and additional nodes by duplicating the new nodes at given 
spacings simultaneously. 

 
 Delete Nodes 
Remove nodes. 

 
 Translate Nodes  
Duplicate or move the existing nodes with equal or unequal spacings. 

 
 Rotate Nodes  
Duplicate or move the existing nodes by rotating about a given axis. 

 
 Project Nodes  
Duplicate or move the existing nodes by projecting on a particular line or 
surface (plane, conic surface, spherical surface, elliptic surface, etc.). 

 
 Mirror Nodes 
Duplicate or move the existing nodes symmetrically with respect to a 
particular plane.  

 
 Divide Nodes 
Create additional nodes by dividing a straight line between two nodes into 
equal or unequal spacings. 

 
 Merge Nodes 
Merge contiguous nodes into one node. 

 
 Scale Nodes 
Reduce or magnify the spacings between two existing nodes by a specified 
ratio. 

 
 Compact Node Numbers 
Adjust the missing node numbers that have been removed, and arrange the 
node numbers in a consecutive order. 

 
 Renumber Node ID 
Renumber the existing node numbers either partially or in its entirety. 

 
 Start Number 
Assign the start number for new nodes to be created. 

 Undo cancels an 
unlimited number of 
previous tasks. 

 Redo recovers the 
previous tasks canceled 
by Undo. 

Project Nodes projects 
specific nodes onto a 
selected line or plane to 
copy or move the 
nodes. This becomes 
useful when modeling 
complicated parts of a 
structure. 
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Elements Generation  
 
 
Use Model>Elements or Element Toolbar to generate elements. The menu for 
material and section properties need not be accessed separately. By clicking the 

 button to the right of the material and section properties list in the dialog bar 
for the elements, the related attributes can be added or modified. If necessary, 
new material and section numbers can be assigned to the elements while being 
duplicated. 
 

 Create Elements 
Create new elements. 

 
 Create Line Elements on Curve 
Create line elements along the traces of a circle, a circular arc, an elliptical 
circle, a parabola, etc. 

 
 Delete Elements 
Remove elements. 

 
 Translate Elements 
Duplicate or move existing elements with equal or unequal spacings. 

 
 Rotate Elements 
Duplicate or move existing elements by rotating about a given axis. 

 
 Extrude Elements 
Create one-dimension higher geometric elements (line elements, plate 
elements and solid elements) by expanding existing nodes, line elements and 
plate elements as follows: 
• Create a line element along the path created by the motion of a node.  
• Create a plate element along the path created by the motion of a line 

element.  
• Create a solid element along the path created by the motion of a plate 

element. 
 

 Mirror Elements 
Duplicate or move existing elements symmetrically with respect to a 
particular plane.  

 
 Divide Elements 
Divide existing elements into equal or unequal sub-elements. 

 
 Merge Elements 
Merge elements of identical attributes (materials, section properties, element 
types, etc.) into one element. 

 Undo cancels an 
unlimited number of 
previous tasks. 

 Redo recovers the 
previous tasks canceled 
by Undo. 
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 Intersect Elements 
Divide automatically existing line elements intersecting one another relative 
to the intersection points. 

 
 Change Element Parameters 
Change the attributes of elements. 

 
 Compact Element Numbers 
Adjust the missing element numbers that have been removed, and arrange the 
element numbers in a consecutive order. 

 
 Renumber Element ID 
Renumber existing elements either partially or entirely. 

 
 Start Number 
Assign the start number for new elements to be created. 

 
 
 
Modeling Automation 
 
 
Depending on the characteristics of a structure in question, the following automated 
generation features may simplify the data entry, thereby increasing productivity: 
 
 

Structure Wizard  

Using this feature, unit-regular structures such as a frame, an arch, a truss, 
a plate and a shell may be modeled by this automated modeling tool 
independently and may be combined later with the total model. 

 
 

Building Generation 
In a building structure, Building Generation allows efficient modeling of 
the geometry reflecting story heights and section or material variation of 
beams, columns, walls and bracings simultaneously. 

 

Refer to “Modeling> 
Model>Structure 
wizard” of On-line 
Manual. 

Refer to “Modeling> 
Model>Building> 
Building Generation” 
of On-line Manual. 
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Model of a Bin 

Extrude the temporary 
beam elements, which 
represent a section of a 
bin to form a complete 
bin reinforced with 
stiffeners. 

The Shrink function 
reduces the element 
sizes and thus enables us 
to readily verify the inter-
connection of the 
elements. 
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Modeling sequence of a multi-story office building  

2nd floor modeling of an 
office building by Frame 
Wizard and UCS.  

Frame structure with 
columns generated by 
the use of Extrude 
followed by creating 
braces.  

Building structure 
generated with varying 
floor-to-floor heights 
and increments of 
section numbers. 

Remove the 
unnecessary elements 
in the upper floor 
setback. 



 
 
 
 

Modeling 
 

65 

                                          
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Modeling sequence of a T-shaped pier 

Generate plate 
elements in the upper 
portion of the coping 
and select the 
projecting plane below.  

Extrude the upper plate 
elements onto the lower 
projecting plane to 
create solid elements.  

Divide the solid 
elements vertically to 
generate finer sub 
elements. 

Complete this T-shaped 
pier model by adding 
the footings and 
columns. 
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Material and Section Properties Generation 
 
 
MIDAS/Gen provides various material and section database, and we are also free 
to define User-defined material and section properties. Sectional Property 
Calculator calculates section properties for an irregularly shaped section. 
 
Material Property Data 
 
 
MIDAS/Gen supports the following material properties: 
 
Steel 

ASTM (American Society for Testing Materials) 
A total of 40 built-in types of steel database (A36, A53, A242-40, etc.) 

CSA (Canadian Standards Association) 
A total of 48 built-in types of steel database (230G(H), 350G(H), etc.) 

BS (British Standards) 
A total of 23 built-in types of steel database (43A, 50A, etc.) 

DIN (Deutsches Institut für Normung e.V.) 
A total of 11 built-in types of steel database (St 37-2, St 52-3, etc.) 

EN (European Code) 
A total of 12 built-in types of steel database (S235, S275, etc.) 

JIS (Japanese Industrial Standards)  
A total of 13 built-in types of steel database (SS400, SM490, etc.) 

GB (Guojia Biao Zhun, China)  
A total of 5 built-in types of steel database (Grade3, 16Mn, etc.) 

JGJ (Jian Zhn Gong ye Jian Zhn Biao Zhun, China) 
A total of 5 built-in types of steel database (Q235, Q295, etc.) 

JTJ (Jiao Tongbu Jian She Bia Zhun, China) 
A total of 2 built-in types of steel database (A3, 16Mn) 

KS (Korean Industrial Standards) 
A total of 45 built-in types of steel database (SS400, SM490, etc.) 

KS-Civil (Korean Civil Standards) 
A total of 27 built-in types of steel database (SS400, SM490, etc.) 

 
Concrete 

ASTM (American Society for Testing Materials) 
A total of 7 built-in types of concrete property database (Grade C2500, 
Grade C3000, etc.) 

CSA (Canadian Standards Association) 
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A total of 6 built-in types of concrete property database (C25, C30, etc.) 
BS (British Standards) 

A total of 10 built-in types of concrete property database (C35, C40, etc.) 
EN (European Code) 

A total of 9 built-in types of concrete property database (C30/37, etc.) 
JIS (Japanese Industrial Standards)  

A total of 16 built-in types of concrete property database (FC27, FC30, 
etc.) 

GB (Guojia Biao Zhun, China)  
A total of 14 built-in types of steel database (C15, C20, etc.) 

GB-Civil (Guojia Biao Zhun, China)  
A total of 7 built-in types of steel database (15, 20, etc.) 

KS (Korean Industrial Standards) 
A total of 19 built-in types of concrete property database (C270, etc.) 

KS-Civil (Korean Civil Standards) 
A total of 19 built-in types of concrete property database (C270, etc.) 

 
Reinforcing Steel 

ASTM (American Society for Testing Materials) 
A total of 4 built-in types of reinforcing steel database (Grade 60, etc.) 

CSA (Canadian Standards Association) 
A total of 6 built-in types of reinforcing steel database (300R, etc.) 

BS (British Standards) 
A total of 2 built-in types of reinforcing steel database (SD460, etc.) 

EN (European Code) 
A total of 6 built-in types of reinforcing steel database (SD400, SD460, 
etc.) 

JIS (Japanese Industrial Standards)  
A total of 6 built-in types of reinforcing steel database (SD345, etc.) 

GB (Guojia Biao Zhun, China)  
A total of 4 built-in types of reinforcing steel database (HPB235, etc.) 

GB-Civil (Guojia Biao Zhun, China)  
A total of 4 built-in types of reinforcing steel database (Grade 1, etc.) 

KS (Korean Industrial Standards, Civil/Building Structures) 
A total of 5 built-in types of reinforcing steel database (SD40, etc.) 

KS-Civil (Korean Civil Standards) 
A total of 5 built-in types of reinforcing steel database (SD40, etc.) 

 
SRC 

Combinations of the above-mentioned steel and concrete materials 
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User Defined 

The user may define the properties directly as well as defining the properties 
of Isotropic Material and Orthotropic Material. 

 
To enter material properties, use Model>Properties>Material or  Material. 
 
At the convenience of the user, enter material properties by the following methods: 

Dialog box for material properties 
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The following is a method of assigning material properties by selecting from the 
predefined materials list specified at the elements generation stage after defining 
the general material properties:  
 
 

1. Click  Material for material data input. 
 

2. Select the desired material properties from the list of material properties 
of the Dialog Bar used for the generation of elements. 

 
3. Use the automatic incremental numbering function for material properties 

in the Dialog Bar used for the duplication of elements. This is convenient 
where properties of the duplicated elements are different from that of the 
elements being duplicated. 

 
 
 
The following is a method of assigning arbitrary material numbers to the 
elements being generated irrespective of the true material data. The assigned 
materials are subsequently revised. 
 
 

1. Click  Material for material data input. 
 

2. Create elements without assigning material data concurrently. 
 

3. Use View>Select or the related Icons to select the elements whose 
material properties are to be assigned or modified. 

 
4. Use Model>Elements>Change Element Parameters or  Change 

Element Parameters to assign new material numbers. Alternatively 
assign material properties by Drag & Drop after selecting relevant 
material properties from Works Tree. 

 
 
Only a few material properties are used for modeling real structures. The first 
method is generally more practical. Use  Change Element Parameters to 
modify material data subsequently. 
 
For effective management of modeling, assign material numbers based on the 
element types (beam, column, wall, brace, etc.) even if the material types are 
identical. 
 
Similar material data used in other model files (fn.MGB) may be imported 

 for entering material properties.  

When additional 
material properties data 
are to be entered during 
the elements 
generation process, use 
the  button to the 
right of the material 
properties list of the 
Create Elements Dialog 
Bar. 

It makes no difference if 
steps 1 and 2 are 
reversed. If elements 
are created without 
specifying the material 
data, the material 
number “1” is assigned 
automatically. 
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Time Dependent Material Property Data 
 
 
Construction stage analysis is required for a high-rise building structure reflecting 
short-term and long-term deformations such as elastic column shortening, concrete 
creep and shrinkage. In such a case and the case of a heat of hydration analysis, 
time dependent material properties are required.  
 
The following outlines the method of defining the time dependent material 
properties: 
 
 

1. Define material property data for creep and shrinkage in Model> 
Properties>Time Dependent Material (Creep/Shrinkage). 
 
 
 
 
 
 
 
 
 
Selection of Code for defining Material Properties 

 
If User Defined is selected, the user is required to directly specify 
relevant creep and shrinkage functions in Model>Properties>Time 
Dependent Material (Creep/Shrinkage) Function. 

 
2. Define a function of modulus of elasticity of concrete in Model> 

Properties>Time Dependent Material (Comp. Strength). 
 
 
 
 
 
 
 
 

 
 
 
Variation of Modulus of Elasticity of Concrete 
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3. Relate the time dependent material properties to the general material 
properties previously defined in Model>Properties>Time Dependent 
Material Link. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Time Dependent Material Link Dialog Bar 
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Section Data 
 
MIDAS/Gen supports the following section property data: 
 
DB Selection among international standard section databases 
 AISC 2K (US) American Institute of Steel Construction, 2000 

Imperial Unit 
 AISC 2K (SI) American Institute of Steel Construction, 2000 

Metric Unit 
 AISC American Institute of Steel Construction, 
 CISC 02 (US) Canadian Institute of Steel Construction, 

Imperial Unit 
 CISC 02 (SI) Canadian Institute of Steel Construction,  

Metric Unit 
 BS British Standards 
 DIN Deutsches Institut für Normung e.V. 
User Key dimensions of standardized sections  
Value Section properties defined by the user  
SRC SRC sections  
Combined Combined sections made up of two section types  
Tapered Tapered sections  

 
The section data in MIDAS/Gen is entered using Model>Properties>Section or  

 Section. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Dialog box of Section data  
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Depending on the user’s preference, section data in MIDAS/Gen can be entered 
by the following methods: 
 
Selecting sections from the list of section data defined in advance and assigning 
them to the elements being created: 
 
 

1. Click  Section to enter the section data. 
 

2. Select the desired sections from the list of sections of the Dialog Bar 
used for the generation of elements. 

 
3. Use the automatic incremental numbering function for sections in the 

Dialog Bar used for duplicating elements where the sections of the 
duplicated elements and the original elements are different. 

 
 
 
Revising the temporary section data assigned to the elements whose section 
numbers are arbitrarily assigned to create the elements: 
 
 

1. Click  Section to enter the section data. 
 

2. Create elements without assigning section data concurrently. 
 

3. Use View>Selection or the related Icons to select the elements whose 
section data will be modified or assigned. 

 
4. Use Model>Elements>Change Element Parameters or  Change 

Element Parameters to assign new section numbers.  
 
 
 
The first method may be advantageous for a relatively simple structure with only 
a few section types. The second method may be more practical for general 
structures with many section types.  
 
Similar section data may be imported  from the MGB files (fn.mgb) used in 
other models. The user may expedite the sectional data entering process by 
establishing a DB in an MGB file containing built-up sections and other 
frequently used sections. This may also come in handy as the DB can be applied 
to the automatic design of steel structures.  

When section data are 
additionally required 
while creating 
elements, it will be 
more convenient to use 
the  button to the 
right of the section list 
in the Create Element 
Dialog Toolbar. 

There is no difference if 
the steps 1 and 2 are 
reversed. If elements 
are created without 
specifying the section 
data, the section 
number “1” is assigned 
automatically. 
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MIDAS/Gen computes the following section properties automatically: 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
DB/User Section 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Combined Section 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Value Section 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Tapered Section 

 

It is not necessary to 
enter sectional 
dimensions for 
elements with varying 
cross sections. 
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SRC material properties 
 & sectional data 
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Applicable Section Shapes  
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Model>Properties>Tapered Section Group automatically calculates the section 
properties of tapered (non-prismatic) elements in a zone of section variation. 
 
Prior to analysis, input tapered elements by assigning them to a  Tapered 
Section Group to calculate the section properties of the individual tapered 
elements, and then ungroup to retain the individual section properties. The 
ungrouping reduces analysis time, especially in a construction stage analysis 
where repetitive sub-analyses are internally performed. 

 
                            Tapered Section Group 
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Thickness Data 
 
 
The thickness data for plate elements in MIDAS/Gen are considered in the 
following two ways: 
 

 Applying the same thickness to compute the stiffness for both in-plane 
and out-of-plane directions.  

 Applying different thicknesses to compute the stiffness for in-plane and 
out-of-plane directions. 

 
For plane stress elements, only the in-plane behavior is taken into account, and 
as such only the in-plane thickness data are applied regardless of the data 
entered. The Out-of-plane stiffness is irrelevant. 
 
MIDAS/Gen has the capability of entering stiffened or reinforced (ribbed) 
plates, which may often be used in thin plates. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
Entering thickness data (Value)      Entering thickness data (Stiffened) 
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Sectional Property Calculator (SPC) 
 
 
MIDAS/Gen provides SPC, which calculates stiffness data for any shape or 
form. The section shape can be drafted, or a DXF file can be imported. Invoke 
Tool>Sectional Property Calculator from Main Menu, and the section 
properties calculated are imported in Section when modeling a structure. 
 
 

 Import a section shape through AutoCAD DXF.  
 Simple entry of a section shape by various modeling tools.  
 Optimized mesh is automatically created for calculating the section.   
 The properties of a hybrid section consisted of a number of different  

materials can be calculated. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

A number of sections are arranged in the order of sizes, and the section 
properties are individually calculated for each section 
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Sectional Property Calculator calculates the section properties of the section 
shapes read in from AutoCAD DXF files 
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Boundary Conditions Input 
 
MIDAS/Gen provides unique boundary conditions such as General Spring 
Supports to account for lateral stiffness of piles, Compression-only boundary 
elements to reflect foundations and Tension-only boundary elements.   
 
 
Boundary Conditions 
 

 Supports 
 

 Point Spring Supports 

 Define General Spring Type 
 

 General Spring Supports 

 Surface Spring Support 
 

 Elastic Link 

 Nonlinear Link Properties  Nonlinear Link 
 

 Beam End Release 
 

 Beam End Offset 

 Plate End Release 
 

 Rigid Link 

 Diaphragm Disconnect 
 

 Panel Zone Effect 
 

 Node Local Axis 
 

 Story Diaphragm Group for 
Construction stage 
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Display of equivalent soil springs auto-generated for a tunnel lining  
 
 
 
Surface Spring Supports is applied in the case where a structure is in contact 
with soils such as a foundation mat or a tunnel. The effective contact area of 
each node of plate and solid elements and the modulus of sub-grade reaction are 
used to automatically calculate and input the equivalent spring stiffness. 
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Display of Boundary Conditions in the zone of lane expansion of a curved bridge  
 
 
 
 
Elastic Link can be applied to represent an elastic bearing on a bridge pier, which 
eliminates the need for incorporating a fictitious beam element in the modeling. 
All that is required is just the stiffness in the relevant direction, which then 
produces the reaction. 
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Rigid Link representing offset between the main girder and bridge pier 
 
 
 
Plate End Release and Beam End Release represent the inability of resistance in 
certain degrees of freedom at the element ends. Node Local Axis is used to 
represent skewed boundary conditions relative to the Global Coordinate System, 
such as a bridge supported on skewed supports. 
 
 
Nonlinear Link can model base isolators and dampers in structures representing 
the behaviors of nonlinear damping history. Nonlinear Link Element is 
composed of 6 linear or nonlinear springs linking two nodes, which represent 
one axial spring, two shear springs, one torsional spring and two bending 
springs. 
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Loads Generation 
 
 
The types of loading implemented in the analysis tasks in MIDAS/Gen are as 
follows:  
 
 

 Static Loads 
 

 Dynamic Loads 
 
The static loads are used to perform static analyses for unit loading conditions. 
The dynamic loads are used to perform response spectrum analyses or time 
history analyses. 
 
 
 
Static Loads 
 
 
The following two steps specify static loads in MIDAS/Gen: 
 
 

1. Use Load>Static Load Cases to enter the static unit loading conditions. 
 

2. Enter the loading data using various static loading functions provided in 
Load.  

 
 
A static analysis is performed for each static unit loading case. Use the 
Results>Combinations function to combine analysis results during the post-
processing mode. 
 
It is also possible to carry out the structural analysis after converting the loading 
combination conditions entered in Load>Create Load Cases Using Load 
Combinations into individual loading cases.  

When modifying or 
adding unit loading 
conditions in the 
process of entering 
loads, click the  
button located to the 
right of the Load Case 
Name field of the 
corresponding load 
dialog bar for quick 
changes. 

This is an extremely 
useful tool for entering 
loading cases when 
nonlinear elements are 
used in the analysis 
model. 

Load Group is applied 
to the Construction 
Stage Analysis in which 
groups of loads are 
activated and 
inactivated at different 
stages of construction. 
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Entering static unit loading conditions  
 
 
MIDAS/Gen supports the following types of static loading: 
 

 Self Weight 
Element self weight  

 
 Nodal Loads 
Nodal concentrated loads  

 
 Specified Displacements of Supports 
Forced displacements of supports 

 
 Element Beam Loads 
Concentrated or distributed loads acting on beam elements 

 
 Line Beam Loads 
Beam loads on a number of consecutive beam elements aligned in a straight 
line 

 
 Typical Beam Loads 
Common types of beam loads resulting from floor loading  

 
 Define Floor Load Type 

 
 Assign Floor Loads 
Floor loads on the top of beam or wall elements 

The type field is used to 
automatically create the 
loading combinations 
according to various 
design codes in different 
countries. It supports a 
list of 24 types of loads. 
For detail information, 
refer to On-line Manual. 

Specify the name of a 
static unit loading 
condition in the name 
field. This name is an 
identification used for 
loading combinations 
and specifying loading 
conditions required for 
the geometric stiffness 
matrix formation in a 
buckling analysis or a 
P-Delta effect analysis. 
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 Define Plane Load Type 
Define the type of loads on a plane, which will be applied to the nodes of 
plate/solid elements and any desired location irrespective of element type. 

 
 Assign Plane Loads 
Apply the defined planeloads to the plane in which the plate/solid elements 
are located. 

 
 Prestress Beam Loads 
Pre-stress loads in beam elements 

 
 Pretension Loads 
Pretension loads in truss elements, cable elements and tension/compression-
only elements 

 
 Tendon Prestress Loads 
Define tendon prestress loads 

 
 Pressure Loads 
Pressure loads acting on the thicknesses or surfaces of plate and solid 
elements 

 
 Hydrostatic Pressure Loads 
Pressure loads resulting from the potential energy of fluid 

 
 System Temperature 
The final temperature of the entire structure necessary for thermal stress 
analysis 

 
 Nodal Temperatures 
Nodal temperatures for thermal stress analysis 

 
 Element Temperatures 
Temperatures on elements for thermal stress analysis 

 
 Temperature Gradient 
Temperature gradient between the top and bottom of beam elements or plate 
elements 

 
 Beam Section Temperatures 
Define a temperature difference on a section of a beam element. 

 
 Time Loads for Construction Stage 
Assigning specific elements with construction time duration to elapse at a 
specific construction stage 

Surface pressure loads 
can be applied to even 
Plane Stress elements 
for Geometric Nonlinear 
Analysis. 
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 Creep Coefficient for Construction Stage 
Assigning creep coefficients to specific elements at a specific construction 
stage 

 
Initial Forces Control Data 
Saving initially entered axial forces as the results of a separate loading 
condition 

 
 Initial Force for Geometric Stiffness 
Imposing initial axial forces to specific elements for calculating geometric 
stiffness 

 
 Wind Loads 
Wind loads automatically computed in accordance with IBC (2000), UBC 
(1997), ANSI (1982), NBC (1995), Eurocode-1 (1992), BS6399 (1997), JIS, 
KS codes 

 
 Static Seismic Loads 
Equivalent static seismic loads automatically computed in accordance with 
IBC (2000), UBC (1991, 1997), ATC3-06, NBC (1995), Eurocode-8 (1996),, 
JIS, KS codes 

 
Ambient Temperature Functions 
For Heat of Hydration Analysis 

 
Convection Coefficient Functions 
For Heat of Hydration Analysis at the boundary surface of a structure 

 
Element Convection Boundary 
Boundary condition for heat transfer by convection on the surface of a 
structure 

 
Prescribed Temperature 
Constant temperature condition independent of time 

 
Heat Source Functions 
For Heat of Hydration Analysis 

 
Assign Heat Source 
Heat source function assigned to each element 

 
Pipe Cooling 
Pipe cooling data for the reduction of temperature 

 
Define Construction Stage for Hydration 
For Heat of Hydration Analysis 

 
Loading Sequence for Nonlinear Analysis 
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Assign loading application order for nonlinear analysis. 
 

 Define Construction Stage 
Define analysis models for each construction stage. 

 
 Select Construction Stage for Display 
Activate the selected stage on the screen. 
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Floor Load 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Automatic generation of Wind Load 

Use Floor Load to enter 
dead and live loads 
simultaneously on an 
inclined roof. 

The applications of 
Floor Load can be 
extended to all the 
planes present in a 
model. Snow and wind 
loads also can be 
generated through the 
use of Floor Load. 

Wind and equivalent 
static seismic loads 
exerting on a building 
can be easily generated 
via automatic load 
calculation. 

The gust factor (Gf) 
required to calculate the 
wind loads for a flexible 
structure can be 
calculated. 
The natural periods of 
vibration (T) required to 
calculate the seismic 
loads can be calculated. 
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Hydrostatic Pressure Load automatically calculates lateral loads acting on plate 
or solid elements due to soil or fluid. The applied loads are automatically 
converted even when the elements are divided or merged. 
 
Temperature loads (changes) can be applied to the total structure as well as to 
individual nodes. Temperature gradients along the ECS axes of line elements 
may be also specified. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Pressure Load: Exterior basement wall supporting soil pressure 

Soil or hydraulic 
pressures acting on 
basement walls or 
retaining walls can be 
easily generated by 
means of Hydrostatic 
Pressure Loads. 
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Dynamic Loads 
 
 
The data entry process for the response spectrum analysis consists of the 
following: 
 
 

1. Define the response spectrum data in Load>Response Spectrum 
Analysis Data > Response Spectrum Functions.  

 
The response spectrum data can be defined using the following four 
methods:  

 
• The user directly enters the spectral data for each period. 
• The design response spectrum database is selected from the built-in 

database (UBC, GB 50011-2001, etc.). 
• The seismic response spectrum is extracted from the records of 

seismic accelerations using Seismic Data Generation. 
• A file containing response spectrum data is imported. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Response Spectrum Function 
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2. Enter the response spectrum load case in Load>Response Spectrum 
Analysis Data>Response Spectrum Load Cases. At this point, select 
the response spectrum defined in Step 1, and assign the direction of 
application, Scale Factor and the mode combination method. 

 
 
 
Refer to Analysis Manual for the concept and features of Response Spectrum 
Analysis. 
 
 
 
The sequence of data entry for time history analysis is as follows: 
 
 

1. Define Time History Function in Load>Time History Analysis Data> 
Time Forcing Functions.  

 
The Time Forcing Functions can be defined by the following four 
methods:  

 
• The user directly enters the loading data for each time step. 
• A selection is made from the built-in earthquake records database 

(32 types, such as El Centro earthquake, 1940, 270°). 
• A file containing the Time History Load is imported. 
• The Time Forcing Function is defined by entering Sinusoidal 

Function coefficients. 
 

2. Enter the title of the time history analysis condition and the data for 
analysis control in Load>Time History Analysis Data>Time History 
Load Cases. 

 
3. When an earthquake analysis is planned, assign the time history analysis 

condition and the Time History Load representing the ground motion to be 
considered in Load>Time History Analysis Data>Ground Acceleration. 
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When performing a typical time history analysis, assign the time history analysis 
condition and the Time History Load to be considered using Load>Time History 
Analysis Data>Dynamic Nodal Loads. 
 
Refer to Analysis Manual and On-line manual for the concept and input process 
of Time History Analysis. 
 
 
 
 
 
 
 
 
 

Time History Function: Sinusoidal  

Time History Function: Heel Drop Load 
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Construction Stage Modeling Feature 
 
MIDAS/Gen provides three types of stages; Base Stage, Construction Stage and 
Post-construction Stage. The characteristics of each stage type are as follows: 
 
 

 Base Stage 
General analysis is carried out at the Base Stage if the Construction 
Stage is undefined. If the Construction Stage is defined, structural 
modeling is prepared, and Structure Groups, Boundary Groups and 
Load Groups are defined and composed at the Base Stage without the 
execution of analysis. 

 
 Construction Stage 

Analyses for construction stages actually take place. The boundary and 
load conditions of the activated Boundary Groups and Load Groups of 
each corresponding stage are established. 

 
 Post-construction Stage 

Being the last stage of the construction stages, special analyses are 
carried out at the Post-construction Stage for conventional, response 
spectrum analysis, etc. in addition to the analysis for the construction 
stage loads. 

 
Construction Stages are composed of Structure Groups, Boundary Groups and 
Load Groups by Activation and Deactivation of relevant entities. Accordingly, 
each stage consists of activated geometry, boundary and load conditions 
pertaining to that particular construction stage.  
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Construction Stage Modeling for a General Structure 
 
 
The general modeling procedure for the construction stage analysis of a structure 
is as follows: 
 
 

1. Prepare a structural model except for the boundary and load conditions. 
 

2. Define Structure Groups in Model>Group>Define Structure Group, 
and assign to each Structure Group relevant elements that will be 
constructed or removed together. 

 
3. Define Boundary Groups in Model>Group>Define Boundary Group. 

 
4. Define Load Groups in Model>Group>Define Load Group. 

 
5. Compose Construction Stages by clicking the  button in 

Load>Construction Stage Analysis Data>Define Construction Stage. 
You may click the  button to define a number of 
Construction Stages of identical duration and click the  
button to compose each construction stage. 

 
 
 
 
 
 
 
 
 
Define Construction Stage dialog box 

 
6. Specify Duration and whether or not to save the results in the Compose 

Construction Stage dialog box. Define Additional Steps if time variant 
loadings are applied within the same structure Group. 
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Compose Construction Stage dialog box 
 

7. From the Group List of the Element tab, select the applicable element 
groups to be included in or excluded from each construction stage 
through activation or deactivation. Age represents the initial maturity of 
each element group. Element Force Redistribution represents the 
redistribution of the forces of each element group being deleted or 
inactivated into the remaining elements. 

 
8. From the Group List of the Boundary tab, select the applicable 

boundary groups to be included in or excluded from each construction 
stage through activation or deactivation. 

 
9. From the Group List of the Load tab, select the applicable load groups 

to be included in or excluded from each construction stage through 
activation or deactivation. Active Day and Inactive Day represent the 
dates of applying and removing each load group. 

 
10. Once the construction stages are composed, we may switch around the 

construction stages in Stage Toolbar and input the boundary and load 
conditions of the Boundary Groups and Load Groups corresponding to 
each construction stage.  

 
 
 
 
 
 

We can minimize input 
errors by inputting the 
load and boundary 
conditions in each 
corresponding 
construction stage. 
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Time Dependent Material Properties 
 
 
The modeling procedure for reflecting the time dependent material properties of 
concrete is as follows: 
 
 
 

1. Define the Creep and Shrinkage properties of concrete, which vary with 
maturity in Model>Properties>Time Dependent Material (Creep/ 
Shrinkage). MIDAS/Gen contains the ACI and CEB-FIP codes for 
defining creep and shrinkage properties of concrete and allows us to 
directly enter any test data. 

 
2. Define the time variant compressive strength gain properties of concrete 

in Model>Properties>Time Dependent Material (Comp. Strength). 
MIDAS/Gen contains the ACI and CEB-FIP codes for defining 
compressive strength gain properties of concrete and allows us to directly 
enter any test data. 

 
3. Relate the time dependent material properties to the general material 

properties in Model>Properties>Time Dependent Material Link. 
When the two types of material properties are linked, the time 
dependent material properties will be used for construction stage 
analyses according to the maturity, and the general material properties 
will be applied to general analyses. 

 
4. Notational Size of Member (h=2×Ac/u) required for calculating the 

time dependent material properties of concrete is entered in 
Model>Properties>Change Element Dependent Material Property for 
each member. 

 
5. Use Load>Creep Coefficient for Construction Stage if creep coefficients 

other than the values automatically calculated by MIDAS/Gen are 
desired. Input creep coefficients for each element at each construction 
stage in the form of loads. When the corresponding load groups are 
activated, the construction stage is created using the specified creep 
coefficient. 
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In the case of a structure where two or more structural components are separately 
erected in the same construction stage and yet the maturities are different as they 
are connected, MIDAS/Gen provides Load>Time Load for Construction Stage 
to account for the different timing effect. Time Load for Construction Stage 
thus enables us to impose time passage to specific elements, which is input as a 
type of load. 
 
 
 
Prestress Input 
 
 
MIDAS/Gen permits construction stage analyses reflecting the pre-stress effects 
of tendons exerted on a structure. It also considers the immediate pre-stress 
losses such as tendon/sheath friction, anchorage slip and elastic shortening as 
well as long term losses such as creep/shrinkage of concrete and tendon 
relaxation in construction stage analyses. The procedure for entering pre-stress is 
noted below. 
 
 

1. Specify the material properties of tendons in Model>Properties> 
Material. MIDAS/Gen does not consider the tendons as independent 
elements, and as such only the modulus of elasticity of the tendons need 
be entered. 

 
2. Enter the cross sectional area, pre-stress loss coefficients, duct diameter 

and strength of tendons in Load>Prestress Loads >Tendon Property. 
 

3. Define the tendon profile in Load>Prestress Loads>Tendon Profile.  
A tendon profile is defined as a curvature relative to an imaginary local 
x-axis, and the insertion point for the origin of the x-axis and the 
direction of the x-axis are assigned. The local x-axis may be in the form 
of a straight line or curved line. A profile already defined can be 
repeatedly copied, and the origin and direction of the x-axis can be 
revised to define a number of different tendons.  

 
A web tendon profile can be created on a vertical plane and projected 
onto a sloped plane by specifying the angle of inclination to model the 
tendon placed in an angled web. Tendons can be also placed in sloped 
elements by simply specifying the slope (gradation) angles.  

 
4. Define pre-stress loads in Load>Prestress Loads>Tendon Prestress 

Loads. The pre-stress loads can be in the form of either force or stress. 
The timing of grouting tendons can be also specified to effect the 
transformed section properties. 
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Tendon Profile & Pre-stress Load Input 
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Modeling Functions for Heat of Hydration Analysis 
 
MIDAS/Gen provides Heat of Hydration Analysis capabilities reflecting 
concrete pour sequence and pipe cooling effects. The modeling procedure for 
Heat of Hydration Analysis is as follows: 
 
 

1. Specify the integration factor, initial temperature, stress output location, 
and whether or not to consider creep & shrinkage in Analysis> 
Hydration Heat Analysis Control. 

 
2. Specify the ambient temperature function in Load>Hydration Heat 

Analysis Data>Ambient Temperature Functions. 
 

3. Specify the convection coefficient function in Load>Hydration Heat 
Analysis Data>Convection Coefficient Functions. 

 
4. Assign the specified ambient temperature and convection boundary 

condition to the concrete surface in contact with atmosphere in 
Load>Hydration Heat Analysis Data>Element Convection Boundary. 

 
 
 
 
 
 
 
 
 
 
 
 
Ambient Temperature Function & Convection Coefficient Function 
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5. Assign a constant temperature to parts that do not experience 
temperature variation with time in Load>Hydration Heat Analysis 
Data>Prescribed Temperature. 

 
6. Define the heat source function, which reflects the state of heat 

generation representing the process of concrete hydration in Load> 
Hydration Heat Analysis Data>Heat Source Functions. 

 
7. Assign the defined heat sources to the corresponding concrete in 

Load>Hydration Heat Analysis Data>Assign Heat Source. 
 

Heat Source Functions 
 

8. Specify the pipe cooling related data, if used, in Load>Hydration Heat 
Analysis Data> Pipe Cooling. 

 
9. Define the element groups and boundary groups pertaining to each 

construction stage, and specify the time for heat of hydration analysis in 
Load>Hydration Heat Analysis Data>Construction Stage for 
Hydration. 
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Construction Stage for Hydration 
 
 
 

Other Modeling Functions 
 
A typical structural analysis modeling entails generating nodes and elements, 
and assigning material properties and boundary conditions. Apart from the 
typical method of preparing an analysis model, MIDAS/Gen provides the user 
with various features to efficiently and accurately carry out the structural 
analysis and design. Some of which are data conversion of other programs, 
merging several model data and text type data entry. 
 
Non-conventional features of MIDAS/Gen related to modeling are as follows: 
 

 Import/Export   
 Data Conversion   
 Merge Data File Function  
 MGT Command Shell  
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Import/Export  
 
 
Use Import/Export when importing model data saved in another format 
incompatible with MIDAS/Gen or generating a file in another format 
incompatible with fn.mgb. 
 
Use File>Import or File>Export to invoke Import/Export. 
 

 MIDAS/Gen MGT File 
Export a file containing the model data in a text format by creating an 
MGT (MIDAS/Gen Text) or import an MGT file. 

 
 AutoCAD DXF File 

Export a fn.mgb to a DXF file or import the geometric shape of a model 
(nodes, elements, etc.) from a DXF file to use it as the model data for 
MIDAS/Gen. 

 
 SAP2000 File 

Import a model data file of SAP2000 to use it as a model data file for 
MIDAS/Gen after converting it into an MGT format. MIDAS/Gen 
functions not supported by SAP2000 are removed from the model data. 

 
 STAAD, MSC.Nastran File 

Import a model data file of STAAD or MSC.Nastran to use it as a 
model data file for MIDAS/Gen after converting it into an MGT format. 
MIDAS/Gen functions not supported by STAAD/ MSC.Nastran are 
removed from the model data. 

 
 

Refer to File> 
Import/Export>STAAD, 
MSC.Nastran File of 
On-line Manual. 

Refer to 
File>Import/Export> 
SAP2000 File of On-
line Manual. 
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Data Conversion  
 
 
Exchange model data and analysis results between MIDAS/Gen and 
MIDAS/SDS, which is a floor/mat analysis and design program. Select 
File>Data Conversion. This feature simplifies the data entry for the analyses of 
structures such as plants, office, residential buildings or any other types that 
require analyses of floor plates (slabs & foundations). 
 

 MIDAS/Gen  MIDAS/SDS (Model+Reaction Data) 
Generate automatically a plate analysis model and corresponding 
loading data (fn.MST) based on the reactions obtained from the 
structural analysis of a MIDAS/Gen model, when analyzing foundation 
mat using MIDAS/SDS. 

 
 MIDAS/SDS  MIDAS/Gen (Load Data) 

Import reactions obtained from the structural analysis of a MIDAS/SDS 
model by converting into the load data (fn.SA1) for MIDAS/Gen. 

 
When converting analysis results by the above functions, the geometric shapes 
of the models must be identical for both MIDAS/Gen and MIDAS/SDS. 
 
 
 
Merge Data File Function 
 
 
In order to expedite the modeling task of a complex structure where the 
geometric configuration is irregular, complicated and large, divide the structure 
into several sub-models and prepare the geometric shape of each sub-model 
separately. Then, combine them into a single model and perform the structural 
analysis. Use File>Merge Data File. 
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Merge Data File 
 
 
MGT Command Shell 
 
Enable the modeling of a structure by the MGT format command, which is a text 
format model data file for MIDAS/Gen. 
 
Use Table Window or improve the efficiency of modeling by using the MGT 
command of MGT Command Shell when the task involves a simple repetition 
under the GUI environment or the task consists of modifying an existing model 
continuously. 

MGT Command Shell 
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Input Results Verification 
 
MIDAS/Gen supports a variety of verification and reference functions, which 
readily verify the current status of all the model data. These functions are: 
 
 

 Display and Display Option 

 Project Status 

 Fast Query 

 Query Nodes 

 Query Elements 

 Node Detail Table 

 Element Detail Table 

 Design Parameter Detail Table 

 Story Weight Table 

 Story Load Table 

 Story Mass Table 

 Mass Summary Table 

 Load Summary Table 

 Group Activation of Construction Stage 
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Display and Display Option  
 
 
Display provides graphical representation of all types of data entries such as 
node/element numbers, material properties, section names, loadings, support 
conditions, end release conditions, rigid body connection conditions, design 
parameters, etc. These representation capabilities enable the user to verify the 
status of data entries by graphics in the working window. For instance, Check & 
Remove Duplicate Elements and Display Free Edge (Face) are used to detect 
and correct errors. 
 
Use View>Display or click  Display in the Toolbar. 
 

                            
 Display dialog box 
 
 
Display Option controls the representation mode of all the graphic and 
alphanumerical data presented in the Model Window. It has 5 dialog boxes:  
 

Font tab: Assign the type, size and color of all the alphanumerical type of 
data such as node numbers, element numbers, analysis results 
related to nodes and elements, numerical load data, etc.  



 
 
 
 

Modeling 
 

109 

Color tab: Control the color of all the graphic data such as nodes, elements, 
masses, loads, support conditions, material properties, sections, 
thicknesses, grids, coordinate systems, display background, etc. 

 
Print Color tab: Control the printing color similarly to Color tab.  

 
Size tab: Adjust the scale of Label Symbol, Zoom In/Out, Pan Rotate, 

Shrink, Perspective, etc. 
 

Draw tab: Specify the requirements for element color display on the screen 
(global element type, material, property, etc.), the representation 
mode of elements (outline, thickness and surface treatment), the 
printing color processing method for printouts, the representation 
method of inactivated elements, the drawing direction for 
diagrams, etc.  

 
 
Use View>Display Option or click  Display Option. 
 
MIDAS/Gen provides a Dynamic Display capability, which displays all the 
nodes and elements, as well as loads and boundary conditions on the model 
screen as they are being input, which helps prevent modeling errors. 
 
 

                 Display Option dialog box 
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Project Status  
 
 
Project Status provides the current status of data entries. The data containing the 
types of data entries with the counts are clearly arranged in a table format.  
 
Use Query>Project Status. 

    Project Status 
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Query Nodes  
 
 
Query Nodes enables the user to verify node numbers, nodal coordinates and 
nodal attributes. After selecting Query>Query Nodes, assign the node to be 
verified with a mouse click or by typing the node number in the dialog box. The 
desired information will appear in the Message Window at the bottom of the 
screen. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Query Nodes 

Query Nodes provides 
the following types of 
information: 
 
Node (number, 
coordinates) 
Nodal Local Axis 
Support 
Point Spring Support 
General Spring Support 
Rigid Link 
Nodal Mass 
Nodal Load 
Specified Displacement  
Nodal Temperature 
Dynamic Nodal Load 

When  Fast Query is 
toggled on, the number 
and coordinates of the 
snapped node are 
displayed in a Bubble Tip. 
Fast Query can easily 
verify the basic 
attributes of nodes and 
elements. 

Fast Query
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Query Elements  
 
 
Query Elements enables the user to verify the element’s connecting node 
numbers and all types of element attributes. After selecting Query>Query 
Elements, select the element to be verified with a mouse or by typing the 
element number in the dialog box. The desired information will appear in the 
Message Window at the lower part of the screen. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Query Elements 
 

Query Elements offers 
the following types of 
information: 
 
Element (element, 
connecting nodes, 
material properties, 
section, number, length, 
etc.) 
Beam End Release 
Beam End Offset 
Plate End Release 
Element Beam Load 
Pressure Load 
Prestress 
Pretension 
Temperature Gradient 

When Fast Query is 
toggled on, the number, 
type, material and 
section properties and 
other relevant attributes 
of the snapped element 
are displayed in a 
Bubble Tip. Fast Query 
can easily verify the 
basic attributes of 
nodes and elements.  

Fast Query
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Node Detail Table 
 
 
Node Detail Table is used to verify all types of information related to nodes in a 
spreadsheet format. 
 
Select the relevant nodes with View>Select first. Click Query>Node Detail 
Table and select the desired information by clicking the tabs located at the 
bottom. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Node Detail Table 
 

Table Window provides 
all kinds of selection, 
namely, Filtering, 
Sorting, Editing, Graph, 
data transfer with Excel, 
etc., in addition to data 
input/output and 
modification. Refer to 
On-line Manual for 
detail directions. 
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Element Detail Table 
 
 
Element Detail Table is used to verify all types of information related to 
elements in a spreadsheet format.  
 
Select the relevant elements with View>Select first. Assign Query>Element 
Detail Table and select the desired information by clicking the tabs located at the 
bottom. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Element Detail Table  
 

Element Detail Table 
displays only the 
information related to 
the selection. It is easy 
to detect errors such as 
redundant or duplicated 
loads. 

Information Table
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Design Parameter Detail Table  
 
 
Design Parameter Detail Table is used to verify all types of information related 
to member design in a spreadsheet format.  
 
Select the relevant elements with View>Select first. Assign Query>Design 
Parameter Detail Table and select the desired information by clicking the tab 
located at the bottom. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Design Parameter Detail Table 
 

Information Table
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Story Weight Table  
 
 
Story Weight Table is used to verify the weight of the structure in a spreadsheet 
format. 
 
Select Query>Story Weight Table to verify the weights of elements classified by 
types of elements and by stories. 
 
 
 
 
 

Story Weight Table 
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Story Load Table  
 
 
Story Load Table is used to verify the loads applied to the model in a 
spreadsheet format. 
 
Assign Query>Story Weight Table first. Select the unit load cases to be included 
in Story Load in Active Dialog. Click the tab corresponding to the desired 
loading direction at the bottom. The total loads for the desired load cases by 
types of loads and by stories can be verified in Story Load Table. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Story Load Table 
 

Information Table 
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Story Mass Table  
 
 
Story Mass Table is used to verify the masses of the structure in a spreadsheet 
format.  
 
Assign Query>Story Mass Table. The Translational Mass and Rotational Mass 
at the mass center, for each story can be verified in Story Mass Table. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Story Mass Table 
 
 

Information Table 
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Mass Summary Table  
 
 
Mass Summary Table is used to verify the masses of the structure in a 
spreadsheet format.  
 
Assign Query> Mass Summary Table. The Nodal Mass that the user entered as 
such, masses converted from loads and Structure Mass obtained from the self-
weight of elements can be verified in Mass Summary Table. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Mass Summary Table 
 

Data cannot be 
modified in this mode. 

Information Table 
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Load Summary Table 
 
 
Load Summary Table is used to verify the loads that have been input in each 
direction arranged by load types in a spreadsheet format. 
 
Assign Query>Load Summary Table. Click the tab corresponding to the desired 
information at the bottom. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Load Summary Table 

Information Table 
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Group Activation of Construction Stage Table 
 
 
Group Activation of Construction Stage is used to check in a table whether or 
not the groups assigned in each stage of the construction stages are activated. 
 
Selecting Query>Group Activation of Construction Stage and using the 
function, click the Group tab at the bottom of the table. The state of activation in 
the corresponding construction stages can be checked by the symbols o or x. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Group Activation of Construction Stage Table 
 
 
 
 
 
 

Information Table
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Analysis 
 
 
 
 
 
 
MIDAS/Gen provides linear and nonlinear structural analysis capabilities. 
 
A large collection of finite elements has been implemented for applications in 
civil and building structures. The program’s efficient analysis algorithms yield 
exceptional versatility and accurate results appropriate for practical design 
applications. 
 
There are no limits on the numbers of nodes, elements, load cases and load 
combinations for a structural model. 
 
 
 

Finite Elements 
 
For beam elements, MIDAS/Gen can analyze the displacements and the 
maximum stresses at the end nodes as well as at intermediate points 
(Results>Beam Detail Analysis). 
 
For plate elements, thin plate (DKT, DKQ) and thick plate (DKMT, DKMQ) 
elements must be used appropriately. Accurate analysis results can be obtained 
from thin plates for structures such as common storage tanks. Thick plates may 
be more appropriate for modeling walls, slabs, bridge decks, basemats, etc. 
 
The Tapered Beam Element formulated from the most current algorithms can 
precisely simulate the behavior of a hunched beam with varying section 
dimensions along the length. The Cable Element has also been introduced in 
MIDAS/Gen for the design of cable-stayed bridges with a small strain condition, 
and suspended cable structures with geometric nonlinearity including the 
sagging effect.  
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The finite element library of MIDAS/Gen contains the following: Refer to 
“Numerical Analysis Model ” of the Analysis Manual for details. 
 

Truss 
Transmit only tensile and compressive loads in the element axial direction 

 
Compression-only Truss 

Transmit only compressive load in the element axial direction considering 
a gap distance  

 
Tension-only Truss 

Transmit only tensile load in the element axial direction considering a 
hook distance  

 
Cable 

Transmit only tensile load in the element axial direction considering 
varying stiffness due to the variation of the internal tension and the sag 
effects  

 
General Prismatic Beam 

Common beam element considering 6 degrees of freedom per node 
 

Tapered Beam 
Beam element with varying sections along the length considering 6 
degrees of freedom per node  

 
Wall 

Wall element considering in-plane and out-of-plane bending behaviors 
 

Plane Stress 
Plane stress element considering in-plane behaviors 

 
Plate 

Plate element considering in-plane and out-of-plane bending behaviors 
 

Stiffened Plate 
Anisotropic Plate element considering in-plane and out-of-plane bending 
behaviors 

 
Plane Strain 

Plane strain element considering 2-D behaviors in the GCS X-Z plane 
 

Axisymmetric 
Axisymmetric element considering 2-D behaviors in the GCS X-Z plane 
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Solid 
Solid element considering 3 degrees of freedom per node 

 
Visco-elastic Damper 

Linear spring and (non) linear viscous damper combined in parallel and 
connected to a spring linking two nodes in all 6 degrees of freedom. An 
additional linear viscous damping coefficient for each dof in parallel with 
the system can be defined. 

 
Hysteretic System 

Hysteretic System consists of springs with the Uniaxial Plasticity property 
in all 6 degrees of freedom. An additional linear viscous damping 
coefficient for each dof in parallel with the system can be defined. 

 
Lead Rubber Bearing Isolator 

Similar to the Hysteretic System, it includes 2 inter-related shear 
deformation springs with the Biaxial Plasticity property. Independent 
linear elastic springs represent the remaining 4 degrees of freedom. An 
additional linear viscous damping coefficient for each dof in parallel with 
the system can be defined. 

 
Friction Pendulum System Isolator  

It includes 2 inter-related shear deformation springs with the Biaxial 
Plasticity property whose physical movements take the form of a 
pendulum (pot bearing). The axial deformation spring retains the property 
of a Gap spring with 0 internal gap. Independent linear elastic springs 
represent the remaining 3 degrees of freedom. An additional linear 
viscous damping coefficient for each dof in parallel with the system can 
be defined. 
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Analysis 
 
MIDAS/Gen provides three solvers for analysis. Select the analysis method 
from Analysis>Analysis Options. The default is the Skyline Solver. 
 
The Skyline Solver is generally used in most structural analysis programs. It can 
be used in virtually all cases regardless of the types and scales of analysis 
models or the system capacities. It is an optimized algorithm that can analyze 
most structural engineering problems within a short time frame. 
 
The Band Solver is more appropriate for an ABD (Almost Block Diagonal) 
stiffness matrix and can be used in all cases, similar to the Skyline Solver. 
 
The high performance Multi-Frontal Sparse Gaussian Solver (MFSGS) is a latest 
addition to the group of MIDAS solvers. The MFSGS uses an optimum frontal 
division algorithm to minimize the number of calculations for simultaneous linear 
equations. The MFSGS is especially useful for those finite elements that contain a 
large number of degrees of freedom. Structures with many nodes can be solved 
over 10 times faster depending on the cases. The MFSGS is a particularly useful 
solver for the detail analysis of a structure consisted of plate and/or solid elements. 
 
The analysis capabilities of MIDAS/Gen are as follows: Refer to “Structural 
Analysis” of the On-line Manual for details. 
 

 Static Analysis 
· Linear Static Analysis 
· Thermal Stress Analysis 

 
 Dynamic Analysis 

· Free Vibration Analysis 
· Response Spectrum Analysis (SRSS, CQC, ABS, Linear) 
· Time History Analysis 

 
 Geometric Nonlinear Analysis 

· P-Delta Analysis 
· Large Displacement Analysis 

 
 Boundary Nonlinear Dynamic Analysis 

· Gap 
· Hook 
· Visco-elastic Damper 
· Hysteretic System 
· Lead Rubber Bearing Isolator 
· Friction Pendulum System Isolator 
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 Buckling Analysis 
· Critical Buckling Load Factors 
· Buckling Modes 

 
 Heat Transfer Analysis (Conduction, Convection, Radiation) 

· Steady State Analysis 
· Time Transient Analysis 

 
 Heat of Hydration Analysis 

· Thermo-elastic Analysis (Temperature stress) 
· Maturity, Creep, Shrinkage & Pipe Cooling 

 
 Construction Stage Analysis 

· Time-dependent Material Properties 
· Boundary Group 
· Static Load Group 

 
 Pushover Analysis 

· Loading Applications as per Mode Shape and Static Load type 
· Generation of Capacity Spectrums & Demand Spectrums 

 
 Other Analysis Features  

· Calculation of Unknown Loads using optimization technique 
· Analysis of steel girders reflecting the section properties before and  

after composite action 
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Static Analysis 
 
 

1. Select Load>Static Load Cases to enter the load cases.  
 

2. Input the loads using the various static load input options in the Load 
menu. 

 
3. When geometric nonlinear elements are included in the model, a) 

reassign predefined load combinations as load cases in Load>Create 
Load Cases Using Load Combinations and b) select Analysis>Main 
Control Data to enter the number of iterations and a tolerance 
necessary for convergence. 

 
4. When the P-Delta effect is considered in the analysis, select Analysis> 

P-Delta Analysis Control to enter the number of iterations and a 
tolerance necessary for convergence. Enter the load cases and load 
factors for analysis. 

 
5. Select Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis. A message indicating the progress of analysis or 
the completion of analysis is displayed in the Message Window at the 
lower part of the screen. 

 
6. After completing the analysis, analyze the analysis results using the 

load cases or combinations and various post-processing functions in 
Results. 

 
 
 
 
Heat of Hydration Analysis 
 
 

1. Enter the time dependent material properties in Model>Properties> 
Time Dependent Material (Creep/Shrinkage) and Model>Properties> 
Time Dependent Material (Comp. Strength), and relate the general 
material properties to the time dependent material properties in Model> 
Properties>Time Dependent Material Link. 

 
2. Enter the data required for heat of hydration analysis in the sub-menu of 

Load>Hydration Heat Analysis Data following the procedure outlined 
in “Modeling Functions for Heat of Hydration Analysis”. 

All the messages 
pertaining to the 
analysis process are 
compiled automatically 
in the “fn.out” file. 
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3. Enter the integration factor, initial temperature, stress output position 

and whether or not to consider creep & shrinkage in Analysis> 
Hydration Heat Analysis Control. 

 
4. Carry out the analysis in the Analysis>Perform Analysis menu or by 

clicking  Perform Analysis. 
 

5. Once the analysis is completed, the results can be verified in contours, 
graphs, animations, etc. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Heat of Hydration analysis model of a bridge pier cap cast in sequence 
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Dialog boxes defining Heat & Time dependent material properties 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Construction Stage dialog box defining sequential construction joints 
(Define Elements & boundary conditions for each construction stage) 
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1st Stage 
 

 
 
 
 
 
 

 
2nd Stage 
 

 
 
 
 
 
 
 
 
 

3rd Stage 
 
 
 

Analysis results for each construction stage in graphs 
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Eigenvalue Analysis 
 
 

1. Enter the masses of the model using the mass input tools supplied by 
Model>Masses.  

 
2. Select Analysis>Eigenvalue Analysis Control to enter the data necessary 

for eigenvalue analysis such as the number of modes. 
 

3. Select Analysis>Perform Analysis or click  Perform Analysis to 
perform the analysis. 

 
4. After completing the analysis, verify the vibration mode shapes and 

natural frequencies (or natural periods) for each mode using Results> 
Vibration Mode Shapes or Results>Result Tables>Vibration Mode 
Shape. 

 
 
 
 
Response Spectrum Analysis 
 
 

1. Follow the steps 1 and 2 of Eigenvalue Analysis. 
 

2. Select Load>Response Spectrum Analysis Data>Define Response 
Spectrum Functions and click . Enter the function name and 
related spectrum function data in the Add/Modify Show Response 
Spectrum Functions dialog box.  

 
3. Use Load>Response Spectrum Analysis Data>Response Spectrum 

Load Cases to enter the Load Case Name. Then, select the function 
name from the Function Name List and enter the remaining data. 

 
4. Select Analysis>Response Spectrum Analysis Control to assign the 

Modal Combination Type and to specify the condition for the restoration 
of signs.  

 
5. Use Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis. 
 

6. Use the post-processing functions of Results to analyze or combine the 
analysis results. 

It is convenient to use 
the built-in design 
response spectra to 
specify Spectrum 
Function. The built-in 
design response 
spectra are as follows: 
· UBC 88-94 
· UBC 97 

MIDAS/Gen can restore 
the signs of the analysis 
results that have been 
combined by SRSS or 
CQC method. The 
results with the restored 
signs can then be used 
for foundation design 
and other member 
design sensitive to 
proper signs. 

Using Model>Masses> 
Loads to Masses, the 
desired loading 
condition of the static 
load data can be 
converted to nodal 
masses. 
This function is 
extremely useful for a 
seismic analysis where 
dead load is to be 
converted into mass. 
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Time History Analysis 
 
 

1. Follow the steps 1 and 2 of Eigenvalue Analysis. 
 

2. Select Load>Time History Analysis Data>Time Forcing Functions and 
click  or  to enter the data pertaining to 
Time Forcing Function related to Function Names in the dialog box.  

 
3. Select Load>Time History Analysis Data>Time History Load Cases to 

enter the Load Case Name, the Damping Ratio and the data required for 
the time history analysis process and the output.  

 
4. When dynamic nodal loads are entered as Time Forcing Function, use 

Load> Time History Analysis Data>Dynamic Nodal Loads to select 
the Load Case Name and Function Name from the Function Name List, 
and then enter the loading direction and arrival time. 

 
When ground motion is used as Time Forcing Function, use 
Load>Time History Analysis Data>Assign Ground Acceleration to 
select the Load Case Name and Function Name from the Function 
Name List, and then click  in Operations.  

 
5. Select Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis.  
 

6. Use the post-processing functions of Results to analyze or combine the 
time history and static analysis results. The absolute maximum values 
within the given time history are provided for all analysis results. Use 
Results>Time History Results to analyze the results at each time step. 
The history graphs and text type results may be produced. 
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Dynamic Boundary Nonlinear Analysis 
 
 

1. Enter the properties of nonlinear link elements in the Model> 
Boundaries>Nonlinear Link Properties menu. 

 
2. Define the nonlinear link elements in the model using Model> 

Boundaries>Nonlinear Link. 
 

3. Enter the mass data. 
 

4. Define the dynamic loads in the Load>Time History Analysis 
Data>Time History Functions dialog box. 

 
5. Enter the time history analysis conditions and various control data 

required to perform time history analysis in Load>Time History 
Analysis Data>Time History Load Cases. 

 
6. Enter the time load functions in the form of ground acceleration in 

Load>Time History Analysis Data>Ground Acceleration. 
 

7. Convert pertinent static loads into dynamic loads by multiplying the 
previously defined static loads by time functions in Load>Time History 
Analysis Data>Time Varying Static Loads. 

 
8. Enter the control data required to perform eigenvalue analysis in 

Analysis>Eigenvalue Analysis Control. 
 

9. Carry out the analysis in the Analysis>Perform Analysis menu or by 
clicking  Perform Analysis. 

 
10. Upon completing the analysis successfully, we can check the 

displacements and max/min member forces for the Time History load 
cases. We can also check the time history analysis results in 
Results>Time History Graph. 
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Dynamic boundary nonlinear analysis model of a structure connected to 
nonlinear link elements 
 

Dialog boxes for entering nonlinear properties of bearing isolators 
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Shear force-Deformation graph of bearing isolator obtained from dynamic 
boundary nonlinear analysis 
 
 
 
Buckling Analysis 
 
 

1. Static analysis results are required to provide the initial geometric 
stiffness matrix for the buckling analysis of a structure. Thus, the load 
cases for the buckling analysis must be specified first to analyze the 
buckling modes. Follow the procedure presented in Static Analysis 
above. 

 
2. Invoke the dialog box of Analysis>Buckling Analysis Control to enter 

the number of modes and the data necessary for convergence. Assign 
the load cases to be considered in the buckling mode analysis. 

 
3. Use Analysis>Perform Analysis or click  Perform Analysis to 

perform the buckling analysis. 
 

4. Use Results>Buckling Mode Shapes or Results>Result Tables> 
Buckling Mode Shape to verify the buckling mode shapes and the 
critical buckling load factors for each mode. 
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P-Delta Effect Analysis 
 
 
When considering the P-Delta effect in the static analysis and dynamic analysis 
processes, use Analysis>P-Delta Analysis Control to assign the load cases to be 
considered for the formation of the geometric stiffness matrix. In addition, enter 
the number of iterations and the tolerance for convergence. MIDAS/Gen only 
performs P-Delta effect analysis for structures modeled with truss, beam and 
wall elements.  
 
 
 
 
Geometric Nonlinear (Large Displacement) Analysis  
 
 
The Geometric nonlinear analysis function is applicable for static analysis and 
construction stage analysis. Prior to the analysis, assign the order of applying the 
loads to be used for the analysis in Load>Nonlinear Analysis Data>Loading 
Sequence for Nonlinear Analysis, followed by assigning the repetitive analysis 
and convergence conditions required to carry out the nonlinear analysis in 
Analysis>Nonlinear Analysis Control. 
 
Geometric nonlinear analysis is applicable for all the elements except for the 
solid element. 
 
 
 
 
Construction Stage Analysis 
 
 

1. Use the dialog box of the Analysis>Construction Stage Analysis 
Control menu when a construction stage analysis is sought for 
calculating vertical deformations due to the creep and shrinkage of 
concrete. Assign the time dependent material property types and specify 
the number of iteration and convergence condition required for creep 
calculation. 

 
2. Use Load>Construction Stage Analysis Data>Construction Stage 

Wizard for Building Structures, or define the construction stages 
including boundary and load conditions in the Define Construction 
Stage menu. 
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3. Select Analysis>Perform Analysis or click  Perform Analysis to 
perform the construction stage analysis. 

 
4. Once the analysis is successfully completed, we can verify displacements, 

member forces, stresses, etc. for each construction stage as well as the 
final construction stage in the Results menu. 

 
 
 
 
 
 
 
 
 
 
Simply specifying durations sequentially creates construction stages. 
New stages may be inserted, or the previously defined stages may be deleted. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Simple activation and deactivation of element, boundary and load groups 
compose the construction stages. 
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Real time display of a stage 
 
 
Pushover Analysis  
 
 

1. Specify the maximum numbers of Iterations/Increment steps and 
convergence tolerance in Design>Pushover Analysis Control. 

 
2. Define the Pushover load case and initial load in Design>Pushover 

Load Cases. 
 

3. Define the plastic hinge properties, which are to be applied to the model 
in Design>Define Hinge Data Type. 

 
4. Assign the defined hinge properties to each member in Design>Assign 

Hinge Data. 
 

5. Select Design>Perform Pushover Analysis to perform the pushover 
analysis. 

 
6. Verify Performance points using the Capacity spectrum and Demand 

spectrums obtained from Design>Pushover Curve 

Stage Tree 
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Composite Steel Beam Analysis considering Variation of 
Pre- and Post-Composite Section Properties  
 
 

1. Use Load>Static Load Cases to define the load cases and the loads 
applied to the pre-composite sections. 

 
2. Use Load>Composite Section Analysis Data>Pre-Combined Load 

Cases for Composite Section to assign the load cases applied to the pre-
composite sections for the analysis. 

 
3. Select Analysis>Perform Analysis or click  Perform Analysis to 

perform the analysis. 
 

4. Use the post-processing functions of Results to combine or analyze the 
analysis results. 
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Interpretation of  
Analysis Results 

 
 
 
 
 
 

Mode Switching 
 
MIDAS/Gen organizes the operating environment of the program by 
Preprocessing Mode and Post-processing Mode for user convenience and 
efficiency. 
 
All the data-entering tasks for modeling are possible only in the preprocessing 
mode. On the other hand, interpretation of analysis results such as combining 
loads, reactions, displacements, member forces and stresses is carried out in the 
post-processing mode. 
 
If the analysis is completed successfully without errors,  the preprocessing 
mode is switched automatically to  the post-processing mode. 
 
 
 
 

Load Combinations 
and Maximum/Minimum Values Extraction  

 
 
Combining Analysis Results 
 
 
MIDAS/Gen can combine all the results obtained from static, response 
spectrum, time history, heat of hydration, nonlinear and construction stage 
analyses by means of the Results>Combinations function. The combined results 
can be expressed in text or graph formats in each post-processing mode. Also, 
combining the load combination cases can create new load cases. 
 

Notice that the analysis 
results are removed 
when the modeling data 
are modified in the 
preprocessing mode 
after completing the 
analysis. However, the 
design data can be 
modified. 
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The following 4 methods are used to enter load combination data in 
MIDAS/Gen: 
 
 

1. The user directly specifies the load combination data. 
 

2. Load combinations are auto-generated by selecting one of the built-in 
design standards. 

 
3. Modifying the auto-generated load combinations in a spreadsheet 

format can also specify load combinations. 
 

4. A file, which already contains the required load combinations, is 
imported. 

 
 
 
MIDAS/Gen automatically generates pertinent load combinations pursuant to the 
following design standards: 
 

 Structural Steel Design Standards 
 

American Institute of Steel Construction, LRFD 
(AISC-LRFD93 & 2000 Load & Resistance Factor Design Part 6 
Specifications and Codes, 1993 & 2000) 

 
American Institute of Steel Construction, ASD 
(AISC-ASD89, Specification for Structural Steel Buildings: Allowable 
Stress Design, Part 5. Specifications and Codes, 1989) 

 
British Standard, Structural use of steel work in building 
(BS5950-90, Part 1. Code of practice for design in simple and 
continuous construction) 

 
ENV 1993-1-1 Eurocode3, Design of Steel Structures 
(Eurocode3, Part 1.1 General Rules and Rules for Building) 

 
Canadian Standards Association, Limit States Design of Steel Structures 
(CSA-S16-01) 

 
American Iron and Steel Institute, Cold-Formed Steel Design 
(AISI-CFSD86) 
 
TWN-ASD90, Taiwan Standard, Allowable Stress Design Specification 
and Commentary for Structural Steel Building, 2001 
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TWN-LSD90, Taiwan Standard, Limit States Design Specification and 
Commentary for Structural Steel Building, 2001 
 
IS:800-1984, Indian Standard, Code of Practice for General 
Construction in Steel (Second Revision), 1984 
 
 
 

 Reinforced Concrete Design Standards 
 

American Concrete Institute, Building Code Requirements for 
Structural Concrete and Commentary 
(ACI318- 02/89/95/99) 

 
Canadian Standards Association of Concrete Structures (CSA-A23.3-
94) 

 
British Standard, Structural use of concrete 
(BS8110-97, Part 1. Code of practice for design and construction) 

 
ENV 1992-1-1 Eurocode2, Design of concrete structures 
(Eurocode2, Part 1. General Rules and Rules for Building) 
 
TWN-USD92, Taiwan Standard, Design Specification and Commentary 
for Concrete Structures, 2003 
 
IS456:2000, Indian Standard, Plain and Reinforced Concrete Code of 
Practice (Fourth Revision), 2000 

 
 
 

 Steel – Reinforced Concrete Composite Design Standards 
 

Structural Stability Research Council, A Specification for the Design of 
Steel – Concrete Composite Columns, 1979 
(SSRC, 1979) 

 
TWN-SRC92, Taiwan Standard, Design Specification and Commentary 
for Steel Reinforced Concrete Structures, 2003 
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           Auto-generation of load combinations 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
          Modification of load combinations - Spreadsheet Form 
 

The user may find it more 
convenient to modify the 
auto -generated load 
combinations. 

By using Active Option, 
the load combination 
conditions can be 
applied or ignored. 
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MIDAS/Gen offers the following 5 types of load combinations for design 
convenience:  
 

General  
Use General to combine load cases to assess the serviceability or evaluate 
the analysis results without reference to a specific design standard.  

 
Steel Design 

Use Steel Design to design steel frame members with respect to the steel 
frame design standards.  

 
Concrete Design  

Use Concrete Design to design reinforced concrete members with respect 
to the RC design standards. 

 
SRC Design  

Use SRC Design to design steel frame-reinforced concrete composite 
members. 

 
Footing Design 

Use Footing Design to design spread footings and pile foundations. 
 
The user can either apply or ignore the load combinations during the design 
process.  
 
 
 
Extracting Maximum/Minimum Values 
 
 
By grouping several unit load cases, MIDAS/Gen can extract the maximum and 
minimum values of structural analysis results such as displacements, reactions, 
member forces, stresses, etc., using Envelope Type. 
 
The results produced by using Envelope Type as a load combination can be 
produced in graph or text formats in each post-processing mode. 
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Arch bridge BMD: Envelope max 
 
 

Analysis Results Verification 
 
The post-processing mode of MIDAS/Gen provides analysis results in graph or 
text formats for simple verification. 
 
Result supports the post-processing mode of MIDAS/Gen. The sub-menu types 
are as follows: 
 

Combinations 
Generate the load combinations 

 
Reactions  

Reaction Forces/Moments: reaction diagrams for supports  
Search Reaction Forces/Moments: verification of reaction forces at a 

specific support  
 

Deformations 
Deformed Shape: deformed shape of the model 
Displacement Contour: displacement contour diagrams 
Search Displacements: verification of displacements at a specific node 
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Forces 

Truss Forces: member force contour diagrams for truss elements 
Beam Forces/Moments: member force contour diagrams for beam elements 
Beam Diagrams: member force diagrams for beam elements 
Plate Forces/Moments: element force contour diagrams for plate elements 
Wall Forces/Moments: element force contour diagrams for wall elements 
Wall Diagrams: member force diagrams for wall elements 

 
Stresses 

Truss Stresses: stress contour diagrams for truss elements 
Beam Stresses: stress contour diagrams for beam elements  
Plane Stress/Plate Stresses: stress contour diagrams for plane stress 

elements and plate elements 
Plane Strain Stresses: stress contour diagrams for plane strain elements 
Axisymmetric Stresses: stress contour diagrams for axisymmetric elements 
Solid Stresses: stress contour diagrams for solid elements 

 
Heat of Hydration Analysis 

Heat of Hydration analysis results including stresses, temperatures, 
displacements, allowable tension stress, crack ratios and time history 
graphs 

 
Beam Detail Analysis 

Detail displacement, shear force/bending moment and maximum section 
stress distribution diagrams for a beam element  

 
Element Detail Results 

Member forces and stresses of elements for individual load cases or load 
combinations  

 
Local Direction Force Sum 

Compute the resultant forces of plate or solid elements by summing up 
their nodal forces in a particular direction 

 
Vibration Mode Shapes 

Natural frequencies and eigenvalue modes  
 

Buckling Mode Shapes 
Critical buckling factors and buckling modes 
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Time History Results 
Time History Graph and Time History Text for analysis results 

 
Stage/Step History Graph 

Graphs of analysis results for Construction stage, Geometric nonlinear or 
Heat of hydration analysis 

 
Unknown Load Factor 

Supply the design load factors satisfying the specified reactions, 
displacements, member forces of truss and beam elements, etc.  

 
Result Tables 

Supply spreadsheet tables containing the analysis results such as 
reactions, displacements, member forces, stresses, eigenvalue modes, 
story displacements, story shear forces, etc. 

 
Text Output 

Supply a text output file containing the analysis results such as reactions, 
displacements, member forces, etc. arranged by the load combinations and 
output contents chosen by the user. 

 
 
 
Post-Processing Procedure 
 
 
The general operating procedure related to the post-processing of MIDAS/Gen 
is as follows: 
 
 

1. Click  Post-processing Mode to switch to the post-processing 
environment. 

 
2. Use Results or the icons in the toolbars to recall the desired post-

processing function. 
 
3. Select the desired load case or combination when the dialog bar appears 

on the left of the screen. Click the  button located to the right of the 
load cases/combination selection list to enter a new load combination. 

 
4. Use the Components field to assign the desired displacement, member 

force or stress component. 
 

5. Use Type of Display to assign the contour, deformed shape, numerical 
values, etc. Click  to the right of the relevant selection field to change 
the details of the display if necessary. 

The toolbars for 
analyzing analysis 
results can be recalled 
into the screen by 
Customize in Tools> 
Customize>Tool bars. 
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Dialog bar of the post-processing and dialog box for the control of screen 
display  
 

6. For selectively displaying a part of the entire model, use View>Select to 
select the entities, and use View>Activities>Active to activate the entities. 
The selection feature can be used at any time since it is independent of 
the post-processing.  

 
7. Click  to display the post-processing results, reflecting the 

conditions assigned in the above procedure. 
 

8. When accessing another post-processing function, it is more convenient 
to use the Icon menu, the function list, or the post-processing tabs of the 
Dialog Bar rather than using the Main Menu. 

Access tab post-processing functions 
Function List



 
 
 
 
GETTING STARTED 
 

150 

Type of Display  
 
Multiple selections are possible. It controls the display of the post-processing 
results. 
 

Contour  Display the analysis and design results in the form of 
contour diagrams. 
 

  Assign the type of contour lines, the number of colors 
(Number of Colors), the range of color distribution 
(Customize Range), the type of colors (Color Table), 
the change of colors (Customize Color Table), the 
Gradation, etc.  

 

 
 
 
 
 
 
 
 
 

Contour Details dialog box 
 

Deform  Display the deformed shape. 
 

  Adjust the deformation scale (Scale Factor) of the 
deformed shape, or determine the display type of the 
deformed shape. 
MIDAS/Gen provides two types of deformed shapes. 
“Nodal Deform” reflects only the nodal displacements and 
“Real Deform” computes additionally the intermittent of 
beam elements between the end nodes. 

 

 
 
 
 
 

 
 
                        Deformation Details dialog box 

Notice that substantial 
time is required to print 
a contour processed 
with Gradation via 
Windows Meta File. 
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Values  Display the numerical values of displacements, member 

forces and stresses at the assigned location. 
 

  Assign the number of decimal points and specify the 
option of expressing the values in the exponential form. 
In addition, only the maximum/minimum values may be 
displayed. Use the Font tab of  Display Option to 
adjust the color and size of the numerical values. 

 
 

 
 
 
 
 
 
 
 
 
 
Value Output Details dialog box 

 
 

Legend 
 

 Assign the position and color of the legend that reflects 
all the reference items on the post-processing screen. 
 

   
 
 

 
 
 
 
Legend Details dialog box 

 

The color of legend can 
be adjusted through 
Display Option.  
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Animate  Simulate the deformation process of the model 

dynamically. 
 

  Specify whether or not the color of the contour diagram 
is to be changed according to the dynamic deformation 
process (Animate Contour). Also specify the iteration 
cycle of the dynamic deformation process as a half cycle 
or a full cycle. 
 
For reference, select the half cycle when simulating the 
deformed shape of the structure and select the full cycle 
when simulating the vibration modes or buckling modes. 
In AVI Options, assign the number of colors per pixel 
(Bits per Pixel) to set the dynamic base screen and the 
compression option of the screen data (Compressor). 
Specify the number of cutting frames (Frames per Half 
Cycle) and the number of frames per second (Frames per 
Second) to display. These items affect the quality, 
animation processing time per cycle, and also the quality 
of the dynamic screen image processing. When a 
construction stage analysis is performed, the animation 
by construction stages or by steps within a construction 
stage may be assigned. 

 
 

Animation Details dialog box 
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Undeformed  Display the deformed shape overlapped with the 

undeformed model. Use the Draw tab of  Display 
Option to control the display of the undeformed shape. 

 

Animation Detail dialog box 
 

Mirrored  Carry out the analysis using a 1/2 or 1/4 model and 
expand the results to create the results of the full model 
by plane symmetry. 
 

  Define the reference plane(s) about which the symmetry 
is created. 

 
 
 
 
 
 
 
 
 
Symmetric Model Mirror Detail dialog box  
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Cutting Diagram  Display the stresses in plate elements at specified 

cutting lines or planes. 
 

  Define the cutting lines or planes and select the 
direction of stresses for display. Assign the form of 
display type for the stresses (numerical values, graphs, 
min/max, etc.). 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Plate cutting Diagram dialog box 

 
 

Cutting Plane  Display the stresses in solid elements at specified 
cutting planes. 
 

  Define the cutting planes, the expression method for 
solid elements and the moving or rotating direction for 
animation. 

 
 
 



 
 
 
 

Interpretation of Analysis Results 
 

155 

 
 
 

 
 
 
 
 
 
Cutting Plane Detail dialog box 

 
 

IsoSurface  Display the IsoSurfaces of solid elements, which 
represent the surfaces of equal stresses for given stress 
values. 
 

  Specify the stress values for which the IsoSurfaces are 
to be displayed and assign the method of representing 
solid elements. 

 
 
 
 
 
 
 
 
 
 
 

 
 
 
IsoSurface Detail dialog box 
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Batch Output 
Generation 

 From the selected output categories, produce all graphic 
output at once by sequentially changing the load cases 
and combinations. 
 

  Select the screen output types and assign them as base 
files. 
 

  Assign base files, load cases/combinations, analysis 
relations, etc. to generate Batch Output. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
     Batch Output Generation dialog box  
 
 
 
 
Post-Processing Function Types 
 
 
Examples of results display and the types of post-processing functions in 
MIDAS/Gen are noted below. Use Type of Display to produce various types of 
Graphic Output. 
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Display of Reactions 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Reaction Forces/Moments: Vertical Reactions 
 
Display of Deformed Shape  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Search Displacements 

Select “Values” in Type 
of Display in the dialog 
bar to display the 
numerical values of the 
reactions. 

Click the mouse cursor 
over the desired node 
to display the relevant 
displacements in 
Message Window. 
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Select Legend.  
The color palette, 
relevant table of 
numerical values, 
model coordinate axes, 
file name, working time, 
etc., can be displayed 
on the left or right of the 
Model Window. 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Deformed Shape + Undeformed Shape 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Displacement Contour  

Click the  button to 
the right of Deform in 
Type of Display in the 
dialog bar to adjust the 
scale of the deformed 
shape. 

Select Undeformed to 
view the deformed 
shape overlapped with 
the undeformed model.  

Select  Perspective 
and  Hidden, then a 
very realistic contour 
will be displayed. 

Click  next to 
Contour in Type of 
Display of the dialog 
bar to adjust the 
division of contour, the 
types of colors and the 
gradient treatment. 
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Display of Member Forces 
 
 
 
 
 
 
 
 
 

Truss Forces  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Beam BMD 

With Truss Forces, the 
member force contour 
is displayed for only 
truss elements. For 
other elements, only the 
outlines are displayed. 
Using   Select 
Identity and Active, only 
truss elements can be 
displayed on the 
screen. 

Check ( ) in “Values” in 
Type of Display and 
assign “Max” in Output 
Section Location to 
display the maximum 
member forces for 
beam elements. 

With “5 Points” in  
 Display Options, 

the shear forces and 
bending moments are 
computed at the quarter 
points of the beam 
elements to represent 
the distribution.  

 
With “Exact” the shear 
forces and bending 
moments are computed 
over the entire lengths 
of the beam elements 
and SFD and BMD are 
displayed exactly. 
Select “Fyz” or “Myz” in 
Components to display 
the SFD/BMD about the 
strong & weak axes 
simultaneously. 
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Beam Forces/Moments: Axial Forces 
 
Display of Stresses 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Beam Stresses: Combined Stresses 

Selecting “Combined” in 
Components field, the 
combined stresses 
(axial stress + strong / 
weak axes bending 
stresses) applied to 
beam elements can be 
examined. 

Using Window>New 
Window, different types 
of windows can be 
displayed 
simultaneously. 
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Plane-Stress/Plate Stresses: von-Mises Stress Contour  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Plane-Stress/Plate Stresses: Principal Stress Vectors 

 
 

Select Hidden Option 
(Model) in the Draw tab of  

 Display Option and 
assign Plane Thickness 
in the Thickness field. 
Then, click  Hidden, 
to display the stress 
distribution of plate 
elements reflecting the 
thickness. 

With “Local” in the 
Stress Options field and 
“Vector” in the 
Components field, the 
principal stress contour 
is displayed as vectors. 

Select Window>New 
Window to display 
different post-
processing results 
simultaneously in 
separate windows.  
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Plane-Stress/Plate Stresses: Cutting Diagram 
 
 
 

Solid Stresses - Principal Stress Contour 

With Cutting Diagram, 
plate stresses can be 
displayed at the 
specified cutting lines in 
graphs. 
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Solid Stresses – Cutting Planes 
 
Display of Analysis Results for individual Elements  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Element Detail Results 

With Fast Query, 
analysis results for an 
element can be 
displayed in the post - 
processing mode.  
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Display of Detail Analysis Results for individual Beam Elements 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Beam Detail Analysis 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Beam Detail analysis: Normal Stress 

If a particular position 
on a beam element is 
specified, the bending 
stress, shear stress, 
effective stress, etc. 
occurring at that 
position can be 
evaluated. 

Beam Detail Analysis 
supplies, for a specific 
beam element, the 
detail displacement 
diagram, SFD/BMD, the 
section stress related to 
a particular section, the 
maximum stress 
distribution diagram 
over the entire length of 
the beam element, etc. 
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Beam Detail Analysis: von-Mises Stress 
 
Display of Local Direction Force Sum 

 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Local Direction Force Sum  

Upon selecting a 
particular point on a 
cross section, bending, 
shear and effective 
stresses, etc. can be 
checked in detail.  
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Display of Vibration Mode Shapes  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Vibration Mode Shapes 
 
Display of Buckling Mode Shapes 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

Buckling Mode Shapes 

Using Multi-Modes, you 
can analyze several 
mode shapes 
simultaneously. 

Select the View tab in 
 Display and use 

Description to include 
comments on the 
screen. Click the  
button to the right of 
Description to adjust 
the size, type and color 
of the fonts. 
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Pushover Analysis Results 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Construction Stage Analysis Results (Column Shortening Graphs) 
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Animation 
 
 
MIDAS/Gen provides the capability of animating static and dynamic analysis 
results. The animation reflecting dynamic effects of the analysis results can be 
extremely useful in analyzing the structural behaviors and creating presentation 
materials. Follow the directions below.  
 
 

1. Recall the functions (Beam Stresses, Vibration Mode Shapes, etc.), 
which yield deformed shapes, vibration modes, buckling modes, etc. 
and select the desired load case or mode. 

 
2. In Components, select the component of relevant analysis results.  

 
3. Select “Animate” in Type of Display, and choose additional selection 

items as necessary. 
 

4. Click . 
 

5. Select  Record in the animation control bar at the bottom of the 
working window. The Animation reflecting the items selected in Type of 
Display is displayed repeatedly on the working window. Use the  
button to the right of Animate to adjust the speed of animation. 

 
6. Select  Save in the animation control bar and enter the desired 

filename to save the played animation. If the extension of the file is not 
assigned explicitly, the “AVI” extension is imposed. Double-click to 
replay the saved animation after searching the relevant file in the folder. 

 
7. Select  Close to terminate the animation function. 

 
 
 
Please note that animation is not supplied in  Render View. 
 
 
 

The Icons controlling 
the animation during 
the animated simulation 
are as follows:  
 

 Play 
 Pause 
 Stop 
 Skip Back 
 Rewind 
 Fast Forward 
 Skip Forward 
 Save 
 Record 
 Close 
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Verification by Result Tables 
 
 
In Results>Result Tables, MIDAS/Gen provides Table Window in the 
spreadsheet form similar to that of Excel, which enables us to evaluate the 
analysis and design results at a glance. MIDAS/Gen provides the following 
verification capabilities for result tables:  
 

 Spreadsheets related to all the analysis and design results (displacements, 
member forces, stresses, reactions, vibration modes, buckling modes, 
heat of hydration results, inter-story drifts, story displacements, story 
shear, etc.) 

 
 A powerful Filtering function linking all types of selection functions 

 
 All types of Sorting functions (Multiple ascending/descending sorting 

rearranged in the order of priorities by material attributes) 
 

 Adjustment of text style (positions, formats of numerical values, 
assignment of effective decimal points, etc.) 

 
 Copy/Paste functions through the clipboard (assignment of all types of 

copy range) 
 

 Search text and numbers 
 

 Transfer data with other database S/W such as Excel  
 

 Elegant report output template forms 
 
 
 

 
 
 
 
Context Menu in Table Window 

 
Context Menu prompts when the mouse curser is right-clicked on the table 
window. If Graph, Filtering and Sorting supplied by Context Menu of Table 
Window are interactively used, the analysis results can be efficiently analyzed 
for different structural characteristics. The types and purposes of Context Menu 
in the analysis results table are as follows: 
Sorting Dialog 
 
Arrange the table data in columns. We can accomplish sorting the data in an 
ascending/descending order and rearranging the data columns in the order of 
priority. For example, sorting the member forces of beam elements by strong 

Refer to Getting 
started>Tables> 
Table Tool 
Directions of On-
line manual for 
detail information.  
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axis bending moments, weak axis bending moments and axial forces in a 
descending order displays the following:  
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Display of Table Sorting Dialog 
 
 
Style Dialog  
 
Adjust the column width, alignment, format of real numbers, decimal points, 
etc., in the table for display. 

 
 
 
 
 
 
 
 
 
 
Style Dialog 
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Show Graph 
 
25 types of graphs are provided for the table data output. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Display of Graph: Web Chart 
 
Active Records  
 
Produce the output data selectively by the attributes of elements (element types, 
types of material properties, section types, group, etc.), or produce the member 
forces or stresses of beam elements selectively by load cases/combinations, 
construction stages and positions (i-node, 1/4, 1/2, 3/4 & j-node). 
 
Where eigenvalue or buckling analysis has been performed, the output can be 
selectively produced by vibration or buckling modes. 
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     Records Activation dialog box 
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View by Load Cases 
 
Produce the member forces selectively by load cases/combinations. 
 

 
Result View Items dialog box  

 



 
 
 
 
GETTING STARTED 
 

174 

Design 
 
 
 
 
 
 

General 
 
The design features of MIDAS/Gen are used to design beams, columns, walls, 
footings and other structural elements in accordance with the designated design 
standards or to interpret the results of strength verification. As the design 
features are implemented only under the post-processing environment, the 
following process must be observed:  
 

 Complete the structural analysis model of the structure 
 

 Enter the loading conditions data 
 

 Perform the structural analysis 
 
 
Structural models prepared for member design or strength verification must 
reflect the following basic conditions: 
 

 Set the axial directions (element coordinate system x-axis) of columns 
and shear walls to be parallel with the GCS Z-direction for structural 
design. 

 
 Locate the reinforced concrete beam elements on a plane parallel with 

the GCS X-Y plane of the analysis model. 
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Design Criteria and Load Combinations 
 
 
The design features of MIDAS/Gen incorporate the following design criteria: 
 
 

 Steel structures design standards 
 

· Manual of Steel Construction, Load & Resistance Factor Design, the 
American Institute of Steel Construction (AISC – Part 6, LRFD93 & 
2000) 

 
· Manual of Steel Construction, Allowable Stress Design, the American 

Institute of Steel Construction (AISC - Part 5, ASD89) 
 

· Part 1. Code of practice for design in simple and continuous 
construction, British Standard (BS5950-90) 

 
· Part 1.1 General Rules and Rules for Building, Design of Steel 

Structures (ENV 1993-1-1 Eurocode 3) 
 

· Canadian Standards Association, Limit States Design of Steel 
Structures, 2001 (CSA-S16-01) 

 
· Cold-Formed Steel Design, American Iron and Steel Institute  

(AISI-CFSD 86) 
 

· TWN-ASD90, Taiwan Standard, Allowable Stress Design 
Specification and Commentary for Structural Steel Building, 2001 

 
· TWN-LSD90, Taiwan Standard, Limit States Design Specification 

and Commentary for Structural Steel Building, 2001 
 

· IS:800-1984, Indian Standard, Code of Practice for General 
Construction in Steel (Second Revision), 1984 

 
 

 RC (Reinforced Concrete) structures design standards 
 

· Building Code Requirements for Structural Concrete and Commentary 
(ACI318-89, 95, 99 & 02) 

 
· Canadian Standards Association, Design of Concrete Structures, 1994 

(CSA-A23.3-94) 
 

· Part 1. Code of practice for design and construction, British Standard 
(BS8110-97) 
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· Part 1. General Rules and Rules for Building, Design of concrete 
structures (ENV 1992-1-1 Eurocode 2) 

 
· TWN-USD92, Taiwan Standard, Design Specification and 

Commentary for Concrete Structures, 2003 
 
· IS456:2000, Indian Standard, Plain and Reinforced Concrete Code of 

Practice (Fourth Revision), 2000 
 
 

 SRC (Steel-Reinforced Concrete) composite structures design criteria 
 

· A Specification for the Design of Steel-Concrete Composite Columns, 
Structural Stability Research Council, US (SSRC79) 

 
· TWN-SRC92, Taiwan Standard, Design Specification and 

Commentary for Steel Reinforced Concrete Structures, 2003 
 

 
We may manually define the load combinations for design in Results> 
Combinations or use the load combinations generated automatically in 
accordance with the applicable design standards. For detail information, refer to 
“Combinations” in On-line Manual. 
 
In order to use the design features, we are required to specify the design 
parameters and load combinations in the process of design or strength 
verification. 
 
We can revert to the preprocessing mode to modify the model data based on the 
results of strength verification or member design. However, it is cautioned that 
the analysis results or member design (strength verification) results may be 
deleted in such a case. 
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Entering Design Parameters  
 
 
The Design menu provides the Design features of MIDAS/Gen and contains the 
following sub-menus: 
 

 General Design Parameter  
 

The commonly required design parameters are defined regardless of 
structural materials or member types. 

 
Definition of Frame  

Define the structure type as laterally braced or unbraced.  
Live Load Reduction Factor 

Provide the live load reduction factors for all columns, shear walls 
and footings.  

Unbraced Length 
Provide unbraced lengths or laterally braced lengths for members.  

Effective Length Factor 
Provide effective buckling length factors.  

Limiting Slenderness Ratio  
Provide the critical (maximum allowable) slenderness ratio.  

Moment Factor 
Provide moment factors. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
Composition of the design feature menu 

Refer to On-line Manual 
for detail information on 
the design parameters. 
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Moment Magnifier 

Provide moment magnifiers.  
Modify Live Load Reduction Factor  

Modify the live load reduction factors already specified, or provide 
the live load reduction factors for individual members.  

Modify Member Type 
Modify the member types that the program selected automatically.  

General Design Tables 
Arrange the design parameters, defined by the user, in a table format 
and modify or remove the pre-defined design parameters. 

 
 

 Steel Design Parameter 
 

The design standards and the design parameters are defined for steel 
structures. 

 
Design Code 

Assign the design standard.  
Modify Steel Material 

Modify the material properties.  
Bending Coefficient 

Provide the bending coefficients.  
Shear Coefficient 

Provide the shear coefficients.  
Specify Allowable Stress  

Provide the allowable stresses.  
Longitudinal Stiffener of Box Section 

Provide the lateral stiffener sizes and spacing for box sections.  
Steel Design Tables 

Arrange the design parameters in tables and modify or remove the 
pre-defined design parameters. 

 
 

 Concrete Design Parameter  
 

The design standards and the design parameters are defined for RC 
structures. 

 
Design Code 

Assign the design standards.  
Strength Reduction Factor  

Provide the strength reduction factors. 
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Modify Concrete Material 

Modify the material properties.  
Limiting Maximum Rebar Ratio  

Provide the maximum allowable rebar ratio.  
Design Criteria for Rebar  

Assign the sizes of rebars and the design method for shear walls.  
Modify Beam Section Data  

Specify or modify beam section data for strength verification.  
Modify Column Section Data  

Specify or modify column section data for strength verification.  
Modify Brace Section Data 

Specify or modify bracing section data for strength verification.  
Modify Wall Section Data 

Specify or modify shear wall section data for strength verification.  
Modify Wall Mark Data  

Specify or modify shear wall names.  
Concrete Design Tables 

Arrange the design parameters in tables and modify or remove the 
pre-defined design parameters. 

 
 

 SRC Design Parameter 
 

The design standards and the design parameters are defined for SRC 
(Steel–Reinforced Concrete) composite structures. 

 
Design Code 

Assign the design standards.  
Modify SRC Material 

Modify the material properties.  
Modify SRC Section Data  

Specify or modify SRC section data.  
SRC Design Tables 

Arrange the design parameters in tables and modify or remove the 
pre-defined design parameters. 

 
 Steel Code Check 

Verify strength for steel members. 
 
 

 Steel Optimal Design 
Perform optimal design for steel members. 

Modified section data 
are used only for design 
feature. They do not 
affect the stiffness data 
for analysis. 
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 Concrete Code Design Design RC members.  
Beam Design            Design beam members.  
Column Design            Design column members.  
Brace Design            Design bracing members.  
Wall Design            Design shear walls. 

 
 Concrete Code Check Perform strength verification for RC 

structures.  
Beam Checking            Verify strength for beam members.  
Column Checking              Verify strength for column members.  
Brace Checking            Verify strength for bracing members.  
Wall Checking            Verify strength for shear wall members. 

 
 

 SRC Code Check Perform strength verification for SRC 
members. 

 
 

 SRC Optimal Check  Perform optimal design for SRC members. 
 
 

 Footing Design  Design footings. 
 
 

 Section for Design  Inquire or modify section data. 
 
 

 Steel Design Result Verify design results for steel members. 
 
 

 Concrete Design Result Verify design results for RC members. 
 
 

 SRC Design Result  Verify design results for SRC members. 
 
 

 Perform Batch Design Perform a number of design tasks including 
structural analyses. 
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Procedure for Implementing the Design Features 
 
MIDAS/Gen designs the following types of members: 
 

 Steel members  
 RC members (including RC shear wall members)  
 Steel-Reinforced Concrete (SRC) members  
 Footings 

 
A common procedure for implementing the design features of MIDAS/Gen is as 
follows: 
 
 

1. Enter the design parameters 
Enter the design parameters using the sub-menus of Design. The data 
entry for design parameters is possible in both pre-processing and post-
processing modes. 

 
2. Enter the load combinations 

Enter the design load combinations using Results>Combinations. 
Modification factors must be incorporated in the design load combinations 
for seismic loads. Verify the pre-defined design load combinations for 
compatibility with the member design. 

 
The design load combinations are applied according to the design types 
noted below and classified by tabs in the dialog box.  

 
Steel Design  Design steel members 
Concrete Design Design RC members 
SRC Design  Design SRC members 
Footing Design Design footings 

 
3. Mode switching 

When the preparation for design or strength verification is completed, 
confirm the current mode. If the current environment is in the 
preprocessing mode, switch to the post-processing mode.  

 
4. Member design or strength verification  

Design or verify strength for members by selecting the design features 
in the sub-menus of Design for each type of structural material or 
member. 
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5. Check member design or strength verification results 
The design results will appear on the screen after member design or 
strength verification. The output results supplied by the strength 
verification feature for steel members are as follows:   

 Detail calculations of strength verification for individual members  
 Summary calculations of strength verification results for individual 

members/sections 
 

The output results supplied by the section design feature for RC 
members are as follows:  

 Detail calculations of strength verification for individual members  
 Summary calculations of automatic design results for individual 

members/sections 
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Detail calculations of strength verification for a steel member 
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Summary calculations of strength verification for a steel member 
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Detail calculations for a RC beam member 
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Summary calculations of automatic design for a RC column 
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Strength Verification for Steel Members 
 
 
The procedure for verifying strength for steel members is as follows. The user 
may specify all the members or select only a few members in the steel structure 
model for checking member strength. 
 
 

1. Specify selectively design parameters to be used in the design from the 
sub-menus in Design>General Design Parameter. 

 
Frame system 
Live load reduction factor 
Unbraced length or laterally braced length  
Effective buckling length factor 
Moment factor 
Moment magnification factor 
Member type 

 
2. Specify selectively design parameters to be used in the design from the 

sub-menus in Design>Steel Design Parameter. 
 

Design standard 
Material properties  
Bending coefficient 
Shear coefficient 
Allowable stress 
Allowable maximum slenderness ratio 
Longitudinal stiffeners of box section 

 
3. Verify the strength by selecting Design>Steel Code Check. 

 
4. The design results will appear on the screen after completing the 

strength verification. 
 

5. Using the  button in the results dialog box that contains the 
output results, the strength may be verified by specifying new section 
data for each section type. The modified section data may be reflected 
on the analysis model by clicking . Then, the analysis and 
design results are automatically removed. As the modified section data 
change the structure’s stiffness, the analysis and strength verification 
have to be performed once again to obtain appropriate design results 
corresponding to the modified model data. 

 
 
Refer to “Steel Code Check” section of On-line Manual for further detail. 
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Dialog box for the strength verification results of steel members  
 
 
Optimal Design of Steel Frame Members 
 
The optimal design feature of MIDAS/Gen optimizes the member sections, 
which determines the section dimensions automatically for the minimum 
sectional areas (minimum weights) satisfying the steel design standard and 
criteria specified by the user. In the optimal design process, the optimal section 
is determined by considering all the design parameters used for the strength 
verification process such as the design load combinations, section shape, 
unbraced length, lateral braced length, effective buckling length factor, bending 
coefficient, moment coefficient, yield strength of material, etc.   
 
The optimal design procedure is as follows:  
 

1. Verify strength for steel members.  
2. Specify the design constraints for each section property type for optimal 

design in Design>Optimal Design.  
3. Enter the number of iterations for optimal design and re-analysis.  
4. Examine the results using Graphic Output for evaluating the optimal 

design. 

A significant number of 
iterations may ensue 
during the optimal 
design process 
depending on the 
design conditions. The 
user is urged to limit the 
number of iterations to 
a reasonable number.  
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Refer to “Optimal Design” section of On-line Manual for more detailed 
information. 

 
Enter design constraints for optimal design 

 
Display of optimal design results 
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Display of optimal design graphic output  
 
 
Design of RC Members  
 
The RC (Reinforced Concrete) design feature of MIDAS/Gen designs the 
sections and verifies strength for either all RC members or only a few selected 
members. 
 
The section design or strength verification may be performed selectively as 
follows: 
 
 

 Section Design (calculation of required rebar quantities and automatic 
rebar placement) 

 
The section design feature calculates the required optimal rebar 
quantities and provides rebar placement by applying the factored loads 
based on the design load combinations of RC members and section 
dimensions specified or revised by the user. In other words, the section 
design feature is applicable where only the section dimensions exist 
without the reinforcing data. 
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 Strength Verification 
 

MIDAS/Gen assumes a member as a complete RC section when the 
user enters both section dimensions and rebar placement data. Only 
then, are the capacity calculated and the result compared to the design 
force. The strength (capacity) is calculated if all the required data for 
the section composition are provided, or else, the section will be 
designed. 

 
Make-up of a RC section 

Section shape and dimensions 
Sizes of rebars  
Number of rebars 
Positions of rebars  

 
 
The procedure for section design and strength verification for RC members is as 
follows: 
 
 

1. Enter selectively the design parameters to be used for the section design 
or strength verification from the sub-menus in Design>General Design 
Parameter. 

 
Section data entry for a beam member 
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Frame system 
Live load reduction factor 
Unbraced length or laterally braced length  
Effective buckling length factor 
Moment factor 
Moment magnification factor 
Member type 

 
2. Enter selectively the design parameters to be used for the section design 

or strength verification from the sub-menus in Design>Concrete 
Design Parameter. 

 
Design standard 
Strength reduction factor 
Material properties  
Limit for the maximum rebar ratio 
Sizes of rebars and design method for shear walls  
Enter or modify beam section data 
Enter or modify column section data 
Enter or modify bracing section data 
Enter or modify shear wall section data 
Enter or modify shear wall mark 

 

 
Section data entry for a column member 
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3. Design the sections or verify strength by using the sub-menus classified 
by the types of members in Design>Concrete Code Design as noted 
below. 

 
Design beam members Design 
Design column members Design  
Design bracing members Design 
Design shear wall members Design 
Strength verification for beam members Beam Checking 
Strength verification for column members Column Checking 
Strength verification for brace members Brace Checking 
Strength verification for shear wall members Wall Checking 

 
4. After completing the design of sections for each member type, check 

the section design and strength verification results displayed on the 
screen. 

 
 
Refer to “Concrete Code Design/Check” section of On-line Manual for further 
information. 
 

                       Section data entry for a shear wall member 
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Display of beam member section design results 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
Display of column member section design results  



 
 
 
 

Design 
 

195 

Design of Footings  
 
 
As the footings are generally placed at the nodes with restrained degrees of 
freedom due to the boundary conditions, the user may execute the footing design 
using the reactions at these nodes. The spread footings and pile caps with square 
or rectangular shapes in plan may be designed.  
 
The section design or the strength verification for footings may be performed 
selectively as follows: 
 
 

 Section Design   
MIDAS/Gen provides the optimal footing size, number of piles, 
footing thickness and required rebar quantities with respect to the 
reactions obtained from the analysis process and the design constraints 
specified by the user.  

 
 Strength Verification  

MIDAS/Gen examines the suitability of footings for the reactions 
obtained from the analysis process and the design constraints specified 
by the user. It calculates the required rebar quantities using the 
calculated reactions.  

 
 
The user may specify the design load combinations directly in Results> 
Combinations or use the combinations automatically generated in accordance 
with the applied design standard. The service load combinations for calculating 
the footing sizes and pile quantities, and the factored load combinations for 
calculating the footing thicknesses and required rebars, may be applied by 
clicking  in the Footing Design dialog box. 
 
The design parameters for footing design may be entered or modified by using 
the Footing Design dialog box. For those unspecified design parameters, the 
initial default values are used for section design or strength verification. 
 

The most effective 
procedure for footing 
design starts by 
obtaining a design 
through the automatic 
design feature and then 
continues with revising 
the design by 
accommodating user 
preferences and 
strength verifications. 
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The design procedure for footings is as follows: 
 
 

1. Enter the design load combinations in the Footing Design tab selected 
from Results>Combination. 

 
2. Enter the node numbers where the footings will be placed or click them 

on the screen displayed from Design>Footing Design. 
 

3. Enter the required design parameters for footing design and ensure the 
accuracy of the service load and factored load combinations.  

 
4. Click  for automatic design or click  for 

strength verification. 
 

5. The design results will appear on the screen when the design (strength 
verification) is completed.  

 
6. To design other footings, repeat the steps 2 to 5. 

 
 
 

 
Entry of footing design parameters 
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Display of footing design results  
 
 
 
Strength Verification and Optimal Design of SRC 
Members 
 
SRC (Steel-Reinforced Concrete) section shapes for which the strengths may be 
verified are as follows: 
 

 Steel encased in a rectangular concrete section (concrete filled or 
unfilled in the steel section)  

 Steel encased in a circular concrete section (concrete filled or unfilled 
in the steel section)  

 Rectangular steel section filled with concrete  
 Circular steel section filled with concrete 

 
The types of steel sections encased in concrete may be an H(I)-section, a 
rectangular section, or a circular section. Both rolled and built-up sections may 
be used. Composite sections must be symmetrical about both ECS y and z-axes. 
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The section design procedure for SRC members is as follows: 
 
 

1. Enter selectively the design parameters to be used for the design from 
the sub-menus in Design>General Design Parameter. 

 
Frame system 
Live load reduction factor 
Unbraced length and lateral braced length  
Effective buckling length factor 
Moment factor 
Moment magnification factor 
Member type 

 
2. Enter selectively the design parameters to be used for the design from 

the sub-menus in Design>SRC Design Parameter. 
 

Design standard 
Modify SRC material 
Enter of modify SRC section data 

 
3. Verify strength by selecting SRC Code Check. 

 
4. The strength verification results will appear on the screen when the 

strength verification is completed. 
 
 
Refer to “SRC Code Check” section of On-line Manual for further information. 
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Section design results for SRC columns 
 
The optimal design, for SRC members, searches for optimal steel sections 
without varying the RC sections. The remaining features are similar to that in the 
optimal design for steel members. 
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Production of Output 
 
 
 
 
 
 

Text Output 
 
The Text Output provides the structural analysis and design results in a text file 
format specified by the user. 
 
The principal features related to the text output of MIDAS/Gen are as follows: 
 
 

 Produce output for (Load Sets) individual groups of load combinations 
(it is possible to assign different load combinations for different output 
contents). 

 
 Produce selective output of member forces and stresses pertaining to 

specific material properties, section properties, element numbers, etc. 
 

 Produce the output of maximum and minimum values for each section 
property. 

 
 Produce nodal displacements and reaction forces. 

 
 Produce the output of Envelope and Summary for each element type. 

 
 Produce the output in ECS or GCS of each element. 
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Directions and Procedure of Usage 
 
 
The Text Output features operate on a method that accumulates the required 
information on a step-by-step basis for the final outcome. The procedure for 
using the Text Output features is as follows:  
 
Example: A load set for the evaluation of reactions, another load set for element 
output, and so on. Up to 3 load sets at a time may be specified. 
 
 

1. Assign Load Set. 
 

Select Results>Text Output to display the load combination selection 
dialog box for text output. 

 
 

 
 
 
 
 
 
 
 
 
 
 
 
 
Load set selection dialog box 

 
A Load Set is a collection of load cases/combinations for the desired 
output items for different results such as member forces, nodal 
displacements, reaction forces, etc. The user selects as many Load Sets 
as necessary in the load combinations selection dialog box. 
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Define the method of producing output for steps in Step Option where 
construction stage analysis or geometric nonlinear analysis has been 
carried out. Click , then the Load Set entry dialog box 
shown in the next figure will be displayed. 

 
 
 
 
 
 
 
 
 
Load Set entry dialog box  

 
Enter the Load Set name. A load set is registered when the desired load 
cases and/or load combinations are selected (checked) and  is 
clicked. Click  to modify the contents of a Load Set 
and click  to remove a registered Load Set. 

 
Once all the necessary load sets are defined, click  and access 
the Element Output Selection dialog box. 

 
2. Select Elements for Output. 

 
In the dialog box, assign the elements for output and select the output 
format. In Output Load Set for Element Output, select the load set for 
which element output will be produced among the registered load sets. 
Select the element types for which output will be produced by checking 
appropriate boxes. At this time, only the elements for which the output 
can be produced are activated in the dialog box.  

 
By clicking the  button to the right of the element type, detail 
specifications related to the element output may be selected.  
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Element Output Selection dialog box 
 
 

Detail Output Selection dialog box  
 

Two parts constitute the Element Selection Detail dialog box. The left 
section filters the selected items, and the right section assigns the output 
format and other items. 

 
Only the output for the elements conforming to the selected attributes 
among the filter items, ID, Section, Material, Story, Named Plane and 
Group will be finally produced.  
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Filter  : list of elements selected through the filter 

 
PreSel : list of elements already selected on the screen prior to  
              starting the Text Output feature 

 
The Text Output features operate on all the elements listed in the Filter 
and PreSel fields. 

 
3. Select Output for Nodal Displacements and Reaction Forces. 

 
After the selection for Element Output is completed, click the  
button to switch to the dialog box for output specifications for 
displacements and reaction forces. The usage of this dialog box is 
identical to that of Element Output Selection.  

 
 

Output Selection dialog box for displacements and reactions 
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Dialog box for items of results output  
 
 

4. Specify the sequence of output. 
 

Finally, specify the sequence of output and the output file name. 
 

It is possible to arrange the output sequence by Default or by Type. 
Select and drag the items individually with the mouse to modify the 
sequence. 

 
If Insert form feed at each output end is checked, a page form feed 
character (“ ”) is inserted at the end of each output item. Type the 
name and path of the output file in the File Name field and click 
the  button to create the file. Text Editor is executed 
automatically and the file is displayed on the screen.  
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Print Output 
 
MIDAS/Gen provides a collection of format choices for print outputs for user 
convenience. MIDAS/Gen prints output in a vector or in an image format.  
 
When the model window in preprocessing or post-processing mode is printed, 
the output is generated in a vector format. The output results provide uniform 
quality irrespective of output sizes. 
 
If the screen containing a rendering view is printed, the output is printed in an 
image format. Due to the characteristics of image output, the quality of the print 
output is determined by the resolution and the number of colors used in the 
window. The size of the output also affects the quality. 
 
 
Output Layout Setting 
 
 
MIDAS/Gen provides the  Print Preview feature that enables us to adjust the 
size and position of the output before printing. 
 
Select File>Print Preview or click  Print Preview. Then, the Print Preview 
window is displayed. 

 
Print Preview window 
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The dialog bar at the top of the screen is used to adjust the size and position of 
the output before printing. 
 
Clicking the buttons of each item with the mouse can set up a rough Layout, 
while specifying numbers in the Margin fields within the dialog bar can adjust it 
to a more precise layout. 
 
 

 
Dialog bar for Print Preview 
 
 
The following explains the dialog bar: 

 
Zoom In, Zoom Out Magnify or reduce the view, which has no effect 

on the true output. 
 

Combo Box Select Paper Size. 
 

Landscape/Portrait Horizontal or vertical printout 
 

Draw Rect Border line insertion option 
 

HORZ Alignment (justified) to Center, Left & Right 
 

VERT Alignment (justified) to Center, Top & Bot. 
 

Keep Ratio Option to maintain horizontal/vertical ratio when 
changing the printout size 
 

Fit to Paper Fit the contents to the selected paper size. 
Selecting Fit to Paper disables Margins/Sizes 
 

Print Resume printing. 
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Output Color Setting 
 
MIDAS/Gen provides both color and black-and-white printing options for user 
convenience. By setting the Black/White Printing option, the object is printed in 
black and white based on the set up in MIDAS/Gen in lieu of printing the 
current colors of the working window.  
 
The Color Selection Option is independent of the printer types, and it may be 
freely set according to the user’s intent. 
 
The method of setting output color is as follows: 
 
Select View>Display Option or  Display Option, then the dialog box shown in 
the figure below will be displayed. The Draw tab displays the dialog box that 
defines the color selection method. Select Print Color Option and set the print 
option in Option Value as shown in the figure below. 
 
Among the Color Print Options, Color Printing (View) produces the contents in 
the window colors, and the colors may be selected in Color tab from the Display 
Option dialog box. Color Printing (Setting) is adjusted in Print Color tab from 
the Display Option dialog box, and the colors in the model window and the 
output may be set independently.  
 
      
 
 
 
 
 
 
 
 
 
 
 
   Display Option dialog box 
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Text Editor 
 
 
 
 
 
 

Principal Features of Text Editor 
 
MIDAS Text Editor works together with the MIDAS Family Program as a 
document editor that conveniently edits relevant input/output text files. 
 
In Windows environment, the Text Editor may be used as a common text editor 
that provides the basic editing features such as compose, save and print text 
documents (may be used as a substitute for Windows memo pad). 
 
To run MIDAS Text Editor, execute  tedit.exe in the program folder of 
MIDAS/Gen, or select Tools>Text Editor from the Main Menu of 
MIDAS/Gen. 
 
The basic functions of Text Editor are as follows: 
 
 

 Create and edit document files  
 

 Search function, and header and footer inserts  
 

 Insert page split ( )  
 

 Print layout setting  
 

 Preview print output 
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Document Output Using Text Editor 
 
When a new document has been composed or a document has been loaded in the 
editor by the Text Output function of MIDAS/Gen, the document may be edited 
and printed. 
 
 
Font Type and Size Setting 
 
 
Selecting View>Configure menu or  Configure Language displays the dialog 
box shown below. 
 
The desired font and size may be specified by clicking the  button on 
the right of the dialog box. Text Editor supports a limited number of font types 
with fixed pitch. 
 

 
Dialog box for font and color settings of Text Editor 
 
 
Page Split 
 
 
When a new page is desired at a specific line on the page, place the cursor at the 
desired position and press  Page Split. If the page split character “ ” is 
inserted at the position of the mouse cursor, the page is automatically divided at 
the position of the page split character for printing. The “ ” character does not 
appear on the printed sheets. 
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Header and Footer Insertion 
 
 
Selecting File>Header & Footer Setup menu or clicking  Heading Footing 
displays the dialog box shown below. 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 
 

 
 
 
 

Dialog box for header and footer insertion 
 
Check Print Header and fill in the entry fields to print the header. 
 
Check Print Footer to print the footer with the page number and date. 
 
The Page Number Position option selects the position at which the page number 
will be printed. The position is either in the middle or on the right at the bottom 
of the page. 
 
The Page Number Setting option defines the numbering style. 
####: Print the page number beginning with the Base Page Number. 
####/####: Print the current page number and the total number of pages. 
 

The Base Page 
Number is literally the 
first page (page 1) of 
the document from 
which the page 
numbering starts 
sequentially. 
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Page Setup 
 
 
Selecting the File>Page Setup menu displays the Page Setup dialog box. This 
dialog box defines the size of printed forms, the orientation and the margins. 
 
 

                     Page Setup dialog box 
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Print Preview 
 
 
When all the print settings are complete, it is advisable to verify the layout of the 
print settings. Select the File>Print Preview menu or click . Once the print 
settings are verified, start printing by clicking the  button. 
 

Print Preview window 



 
 
 

216 



 

217 

Graphic Editor 
 
 
 
 
 
 

Principal Features of Graphic Editor 
 
MIDAS Graphic Editor works together with the MIDAS Family Program. It is 
a vector-based graphic editor program that edits and prints various graphic files. 
 
Various titles and comments may be added to the graphic documents with the 
BMP or EMF (Enhanced Metafile) extensions that MIDAS/Gen created. Such 
editing capabilities provide high quality documents for reports or presentation 
materials. 
 
In order to execute MIDAS Graphic Editor, execute  gedit.exe in the program 
folder of MIDAS/Gen or select Tools>Graphic Editor from the Main Menu of 
MIDAS/Gen. 
 
The principal features of Graphic Editor are as follows: 
 
 

 Drawing various images 
 

 Various editing functions  
 

 Importing external files (BMP, EMF) 
 

 Saving files in BMP & EMF formats or in its inherent type 
 

 Print Layout and Print preview functions 
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Usage 
 
Refer to the Graphic Editor section of the On-line Manual for further details 
regarding the image and editing functions of the Graphic Editor. 
 
 
Open an Image File 
 
 
This opens graphic files (BMP, EMF) created by MIDAS/Gen. 
 

 Open 
Click  to display the dialog box. After selecting the file format 
(BMP, EMF), move the file to the desired folder. Select a file name and 
click the  button. 

 
 

Open Graphic File view 
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 Insert Image 
If the cursor is in a stand-by state for image insertion, move the cursor 
to the desired position and insert the image by left-clicking the mouse. 

 
 Adjust Size and Position 

Adjust the position of the image by holding and dragging the center of 
the image with the mouse. Adjust the size of the image by dragging a 
corner. 

 
 
Create Image Setting and Add Title 
 
 

 Transparent Color Setup 
This is a tool that makes the desired color transparent. It is very useful 
when printing an image with a black background.  

 
Select an opened image by clicking the image once and right-click the 
mouse. Then select Component Properties. The dialog box shown in 
the figure below is displayed. Check Transparent under Bitmap 
Properties in General and select the black color, then the background 
becomes transparent. 

 
 
 
 
 
 
 
 
 
 
 
 
 
    Component Properties dialog box 
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Example of black background changed to transparent color 
 
 
 

 Image Framework 
The image framework may be defined by clicking  Rectangle. After 
selecting each rectangle, right-click the mouse to open the Context 
Menu. Select Properties in the Context Menu, then the thickness and 
color of the lines or the color of the face may be adjusted by the 
Component Properties dialog box. 

 
 Adjust the Overlapping Order of Images 

In Graphic Editor, the image drawn first is behind those drawn later. 
The overlapping order adjustment feature rearranges the overlapping 
order. Selecting Order>Send to Back in the Context Menu or Bring 
Forward can adjust the overlapping order. 
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Framework generated by Rectangle Image edited with Component Properties 
(2 rectangles) 
 

Example of a later-drawn rectangle brought backward by the overlapping 
order adjustment function 
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 Input of Text 
The graphic editor allows the user to add titles or explanatory texts. 
Clicking  Text brings the cursor into a stand-by state for text input. 
At this time, move the cursor to the desired position and left-click the 
mouse. A text input element appears with “Text” written inside. 

 
The desired text may be entered after double-clicking “Text”. Once the 
desired text has been typed in, click elsewhere on the window away 
from the text field to prompt the end of input. Now, right-click the 
mouse on the Text element, select Properties in the Context Menu, and 
edit the text properties to the desired format. The component properties 
such as the type, size and color of font, the format of the framework, 
etc., may be assigned. Even the text may be rotated such that the text is 
read vertically. 

 
 

Addition of title on an image 
 
 



 
 
 
 

Graphic Editor 
 

223 

 Insert Explanatory Lines 
By using the Line and Polyline commands and the text input function, 
explanatory lines to help clarify the image are inserted. 
 
The Selection menu at the bottom of the screen determines the drawing 
method of the extremity and line shapes of Line or Polyline. For 
drawing a new, straight line, the line begins with the selected shape at 
the Start Point and ends with the selected shape at the End Point. If 
Orthogonal is checked, the shortest perpendicular lines linking the start 
and end points are drawn. By applying such a method, explanatory lines 
may be inserted in the drawing. First, place the start point in Circle and 
the end point in Arrow, and input Polyline. If an additional text is 
inserted to the right, the explanatory line is now completed. 

 
 
 

Example of explanatory lines 
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Print Preview and Page Setup 
 
 

 Print Preview 
When the drawing is complete, the layout of the drawing for printing 
may be verified in advance by Print Preview. The printing is executed 
identically to the print preview displayed on the screen. 

 
 Page Setup 

Adjust the size, direction and margins of the printed forms. 
 
 
 

Print Preview 
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APPENDIX A. Principal Features of MIDAS/Gen 
 
 
 
Graphic Visualization and Model Verification 
 
 

 Provision for all types of menu systems for user convenience (Tree 
Menus, Full Down Menus, etc.) 

 
 Multi-window multitasking feature 

 
 Various window manipulation capabilities: Zoom, Pan, Rotate, View 

Point, Dynamic View, etc. 
 

 Various representation schemes for modeled elements: Wire Frame, 
Slice, Surface, Solid Shape, etc. 

 
 Selective model representation feature (Active/Inactive) 

 
 Query features related to the input data (Attributes for nodes and 

elements) 
 

 Dynamic auto-display feature for input contents (Dynamic Label) 
 

 Various functions (Select) for the selection of input entities (Single, 
Window, Polygon, Intersect Line, Plane, Volume, Identity, Previous, 
Recent Entities, Group, etc.) 

 
 Unlimited repetitions of Undo/Redo and the provision of List  

 
 Various data formation references and functions (UCS, Grid Point, 

Grid Line, Snap, etc.) 
 

 Unrestricted unit specification and conversion  
 

 Integration of a number of separate models into a unit model (Merge 
Data File) 

 
 Import/Export capabilities with other S/W (STF, AutoCAD, 

MIDAS/SDS, SAP2000, STAAD, MSC.Nastran, etc.) 
 

 Graphic Editor capability 
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 Text Editor capability 
 

 Various data input functions (A string of data entries distinguished by   
“ , ” or “blank”, computation capability using arithmetic operators and 
scientific functions, etc.) 

 
 Capabilities supplying various graphic formats  

 
 Table Window representation features (input, modify, duplicate, edit 

and data exchange with Excel) 
 

 On-line Manual feature 
 

 Input/Output in text-format of the model data (Import, Export, MGT 
Command Shell) 

 
 Customization of Short-cut keys  

 
 
 
Model Generation 
 
 

 Convenient data entry (UCS, grid system, many types of snap 
functions, etc.) 

 
 Various Structure Wizard capabilities (Beam, Column, Arch, Frame, 

Truss, Shell Structures) 
 

 Automatic generation of nodes (Create, Delete, Translate, Rotate, 
Mirror, Project, Divide, etc.) 

 
 Automatic generation of elements (Create, Delete, Translate, Rotate, 

Mirror, Project, Extrude, Curve, etc.) 
 

 Wall combination number (Wall ID) auto-generation 
 

 Selective duplication capabilities of attributes (load cases, boundary 
conditions, etc.) while duplicating nodes and elements 

 
 Material and section properties input functions, with built-in section 

databases (AISC, JIS, etc.) 
 

 Time dependent material properties input 
 

 Non-prismatic (tapered) section assignment 



 
 
 
 

APPENDIX A. Principal Features of MIDAS/Gen 
 

227 

 Sectional Property Calculator (Auto-calculation of stiffness data for an 
arbitrary section) 

 
 Input data for boundary conditions (Support, Beam and Plate End-

release, Rigid End Offset, etc.) 
 

 Rigid Link feature (Master and Slave Nodes)  
 

 Input data for specification of masses (Nodal masses, Floor Diaphragm 
Masses and automatic conversion of loading data into nodal mass data) 

 
 Input data for design (Unsupported lengths, effective coefficients for 

buckling lengths, other data related to optimal design, etc.) 
 

 Auto-generation of building (Consideration for varying story heights, 
material properties and section properties) 

 
 
 
Load Generation 
 
 

 Input data for nodal concentrated loads (Forces, Moments) 
 

 Element loading input functions (GCS, ECS-based input functions)  
 

Beam loads In-span concentrated loads, uniformly 
distributed loads, non-uniformly distributed 
loads, pre-stress loads  

Floor plate loads Automatic conversion of floor plate loads 
into beam loads or wall element loads  

Plane loads Loads applied at specific locations of plate 
and solid elements  

Pressure loads Edge Pressure, Surface Pressure and 
Potential Pressure loads (Hydrostatic and 
soil pressures)  

Wind loads IBC2000, UBC97, ANSI94, BS6399 
(1997), Eurocode-1 (1992), KS2000, JIS87  

Equivalent static 
seismic loads 

IBC2000, UBC91, UBC97, ATC3-06, JIS94, 
KS2000  

Temperature loads Nodal temperature loads and Temperature 
gradient loads  

Forced displacement 
loads at supports  
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 Input data for dynamic loads  
Response Spectrum, Time Forcing Functions, Sinusoidal Forcing 
Function, Earthquake Acceleration, Delay Time, etc. 

 
 Automatic generation of earthquake loads 

18 types of built-in seismic accelerations records (El Centro, San 
Fernando, Kobe, etc.)  
6 types of built-in design response spectra (UBC91/97, ATC3-06, 
Newmark, KS2000, etc.)  
Automatic computation of the earthquake response spectrum related to 
a given seismic acceleration record  

 
 
 
Analysis 
 
 

 Finite element library 
Compression-only, Tension-only, Gap, Hook, Cable, Truss, General 
Beam, Tapered Beam, Wall (In-plane/Out-plane Bending), Plane 
Stress, Plate (Thin/Thick), Plane Strain, Axisymmetric, Solid Element 
(Hexagon, Wedge, Tetrahedron) 

 
 Analysis capabilities 

Linear Static Analysis including Thermal Stress Analysis  
Heat of Hydration Analysis  
Analysis reflecting Time Dependent material Properties  
Linear Dynamic Analysis 

Free Vibration Analysis 
(Natural Frequencies, Vibration Modes) 

Response Spectrum Analysis 
(SRSS, CQC, ABS, etc., including the recovery of Signs after 
Modal Combination) 

Time History Analysis   
Geometric Nonlinear Analysis  

(Large Displacement, P-delta Effect, Tension/Compression-only, 
Gap, Hook, Cable)  

Linear Buckling Analysis 
(Critical Buckling Forces and Buckling Modes)  

Pushover Analysis 
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 Other analysis capabilities  
Analysis considering construction stages (Column Shortenings due 
to Elastic and Time Dependent properties such as change of modulus of 
elasticity, creep and shrinkage)  
Analysis considering variations in section properties due to pre and post 
composite action of a composite structure  
Analysis for an unknown loading condition using optimization technique  
Unlimited numbers of nodes and elements   
Unlimited numbers of static unit load cases and load combinations  
Combining static and dynamic analyses   

 
 
 
Output Verification 
 
 

 Automatic load combination in accordance with the specified design 
standard 

 
 Deformed shape and numerical values (provision for displacements 

along the length between the ends of a beam element including contour 
lines and maximum values) 

 
 Member force diagrams and numerical values (including contour lines 

and maximum values) 
 

 Stress distribution and principle stress diagrams for plate and solid 
elements (including contour lines and maximum values) 

 
 Shear force and bending moment diagrams for beam elements (member 

force diagrams and contour lines) 
 

 Reaction diagrams and numerical values at supports  
 

 Animated simulation for variation process related to deformations and 
member forces or stresses (AVI Animation display) 

 
 Detail analysis results for each beam element (detail deformed shape, 

shear force and bending moment diagrams, maximum–stress envelope 
diagrams and stress distribution contours at a specific section) 

 
 Numerical values and contours related to strength results of beam and 

truss elements  
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 Dynamic simulation of vibration shapes and buckling shapes for each 

mode  
 

 Time history analysis results in graphic format 
 

 Pushover analysis results including Demand and Performance spectrums 
 

 Production of analysis results of construction stages 
 
 
 
Output Envelope/BOM, etc. 
 
 

 A feature which produces the maximum/minimum numerical values for 
each multiple load combination case related to all the analysis results  

 
 A feature which lists the material quantities (member lengths, coated 

surface, weight and volume) for all the members included in the 
analysis model  

 
 
Design  
 
 

 Structural steel design standards  
Manual of Steel Construction, Load & Resistance Factor Design, the 
American Institute of Steel Construction (AISC-LRFD93 & 2000)  
Manual of Steel Construction, Allowable Stress Design, the American 
Institute of Steel Construction (AISC-ASD89)  
Part 1. Code of practice for design in simple and continuous 
construction, British Standard (BS5950-90)  
Part 1.1 General Rules and Rules for Building, Design of Steel Structures 
(ENV 1993-1-1 Eurocode 3)  
Canadian Standards Association, Limit States Design of Steel 
Structures, 2001 (CSA-S16-01)  
Cold-Formed Steel Design, American Iron and Steel Institute  
(AISI-CFSD86)  

 
 Reinforced Concrete (RC) design standards  

The RC Structure Design Criteria of the American Concrete Institute 
(ACI318-89, 95, 99 & 02)  
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Canadian Standards Association, Design of Concrete Structures, 1994  
(CSA-A23.3-94)  
Part 1. Code of practice for design and construction, British Standard 
(BS8110-97)  
Part 1. General Rules and Rules for Building, Design of concrete 
structures (ENV 1992-1-1 Eurocode 2)  

 
 Structural Steel-Reinforced Concrete design standards  

The Allowable Stress Design Method, the SSRC of US (SSRC79)  
 

 Design capabilities  
Structural steel strength verification for each design standard  
Structural steel–RC composite column (SRC) member strength verification  
Supply of graphs for analyzing analysis results (by members and by 
section types)  
Display of graphics for visual assessment of strength verification results  
Weight optimization of steel members per section type and automatic 
renewal of section properties  
Execution of optimal design via automatic iteration process of Structural 
analysis, Strength verification and Selection of optimal section   
Supply of graphs to assess optimization design process of steel structure   
Supply of weight distribution diagrams for combined stress ratios and 
supply of average safety factor graphs   
Strength verification of plate girders  
RC member design with respect to each design standard (computation 
of reinforcement)  
Automatic and precise computation of required reinforcing steel 
obtained from stress-strain analysis and P-M interaction diagrams for 
the design of RC members  
Output of rebar sizes and spacing based on the required reinforcement 
automatically-computed   
For the design of slender column and bracing members, the required 
rebar is computed by automatic calculation of moment magnification 
factors and the required moment capacities considering the slenderness 
effect.  
For the design of shear wall members, the bending moments about the 
weak axis are computed reflecting the slenderness effect and the 
reinforcing steel is computed accordingly.  
The end reinforcing bars are computed automatically for shear wall 
design.   
Design of spread footings and pile foundations 
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Possibility of assigning the structural system (lateral support/ non-
lateral support) for each structural direction   
Automatic computation of effective buckling length factors (K-Factor)  
Output of strength verification calculations and the summaries of all 
types of design results  
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APPENDIX B. Toolbars and Icon Menus 
 
 
File Toolbar 
 

 
 

 New Open a new file. 
 

 Open Open a saved file. 
 

 Save Save the current working file. 
 

 Cut Cut. 
 

 Copy Copy. 
 

 Paste Paste. 
 

 Delete Delete the selected nodes or elements (possible to 
use the Delete key). 
 

 Undo Cancel the latest input items entered during the 
modeling process and restore the model to the 
previous state. 
 

 Redo Restore the tasks cancelled by the Undo function. 
 

 Print Print the currently active window. 
 

 Print Preview View the window for printing prior to actual 
printing. 
 

 On-line Manual Request for assistance. 
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Grid & Snap Toolbar 
 

 
 

 Point Grid Display point grids (Toggle On/Off). 
 

 Set Point Grid Setup point grid environment (Toggle On/Off). 
 

 Line Grid Display line grids (Toggle On/Off). 
 

 Set Line Grid Setup line grid environment (Toggle On/Off). 
 

 Point Grid Snap Apply snap function to the closest point grid. 
(Toggle On/Off) 
 

 Line Grid Snap Apply snap function to the closest line grid  
(Toggle On/Off). 
 

 Node Snap Apply snap function to the closest node 
(Toggle On/Off). 
 

 Element Snap Apply snap function to the closest element 
(Toggle On/Off). 
 

 Snap All Apply all the snap functions. 
 

 Snap Free Cancel all the snap functions. 
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UCS/GCS Toolbar 
 

 
 

 X-Y Define a plane parallel to GCS X-Y plane as UCS 
x-y plane. 
 

 X-Z Define a plane parallel to GCS X-Z plane as UCS 
x-y plane. 
 

 Y-Z Define a plane parallel to GCS Y-Z plane as UCS 
x-y plane. 
 

 Three Points Define a plane determined by 3 points in GCS as 
UCS x-y plane. 
 

 Three Angles Define a UCS by rotating GCS X, Y and Z-axes by 
specified angles. 
 

 Named Plane Define a UCS x-y plane by Named Plane 
previously assigned by the user. 
 

 Set UCS by Current UCS Define a UCS by relocating the origin of the 
predefined UCS or rotating the predefined UCS 
about UCS x, y and z-axes by specified angles. 
 

 UCS Apply User Coordinate System. 
 

 GCS Apply Global Coordinate System. 
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Zoom & Pan Toolbar 
 

 
 

 Zoom Fit Fit the currently active model to the size of the 
Model Window. 
 

 Zoom Window Magnify the rectangular area outlined by the 
mouse. 
 

 Zoom In Magnify the model window proportionally. 
 

 Zoom Out Reduce the model window proportionally. 
 

 Auto Fitting Activate the Zoom Fit function automatically to 
accommodate varying model sizes. 
 

 Pan Left Move the model to the left by a certain distance. 
 

 Pan Right Move the model to the right by a certain distance. 
 

 Pan Up Move the model upward by a certain distance. 
 

 Pan Down Move the model downward by a certain distance. 
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View Point Toolbar 
 

 
 

 Redraw  Redraw the screen by applying the current View 
Point and Display Option. 
 

 Initial View Revert to the initial stage of opening file in the 
case of preprocessing mode. Revert to the model 
view stage after deleting the analysis results in the 
case of post-processing mode. 
 

 Iso View Display the model in a 3-D isometric view. 
 

 Top View Display the model in the X-Y plane with the view 
point from the (+) Z-axis direction. 
 

 Right View Display the model in the Y-Z plane with the view 
point from the (+) X-axis direction. 
 

 Front View Display the model in the X-Z plane with the view 
point from the (–) Y-axis direction. 
 

 Angle View Display the model relative to GCS with a specific 
view point. 
 

 Rotate Left Rotate the model to the left. 
 

 Rotate Right Rotate the model to the right. 
 

 Rotate Up Rotate the model upward. 
 

 Rotate Down Rotate the model downward. 
 

 View Previous Restore the View Point immediately prior to the 
latest change. 

 

Redraw is used to 
remove the Dynamic 
Label, which displays 
automatically the Label 
for the latest input or to 
remove the residual 
image on the screen. 
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Stage Toolbar 
 

 
 

 Define Construction 
Stage 

Define analysis models for each construction stage. 

 
 
 
 
 
 
Selection Toolbar 
 
 

 
 Select  

 
 Select Identity – 
Elements 

Select elements by attributes. 
 
 

 Group Select a Group among the groups predefined by the 
user. The groups may be defined relative to the 
geometric shapes or structural characteristics. 
 

 Select Single Select/unselect one node or one element at a time 
with the mouse. 
 

 Select Window Select the nodes and elements within a rectangular 
area defined with the mouse. 
 

 Select Polygon Select the nodes and elements within a polygonal 
area defined with the mouse. 
 

 Select Intersect Select the elements intersecting a series of specific 
straight lines drawn with the mouse. 
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 Select Plane Select all the nodes and elements included in a 
specific plane. 
 

 Select Volume Select all the nodes and elements included in a 
specific volume. 
 

 Select All Select all the nodes and elements displayed in the 
current window. 
 

 Select Previous Reselect the last-selected nodes and elements. 
 

 Select Recent 
Entities 

Select the nodes and elements most recently 
created. 
 

 Unselect Window Unselect the presently selected nodes and elements 
within a rectangular area defined with the mouse. 
 

 Unselect Polygon Unselect the presently selected nodes and elements 
within a polygonal area defined with the mouse. 
 

 Unselect Intersect Unselect the presently selected elements intersecting 
a series of specific straight lines drawn with the 
mouse. 
 

 Unselect Plane Unselect all the presently selected nodes and 
elements included in a specific plane. 
 

 Unselect Volume Unselect all the presently selected nodes and 
elements included in a specific volume. 
 

 Unselect All Unselect all the nodes and elements displayed in 
the current window. 
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Activation Toolbar 
 

 
 

 Active Activate and display only the selected nodes and 
elements. 
 

 Inactive Activate and display only the unselected nodes and 
elements. 
 

 Inverse Active Activate the inactive nodes and elements. 
 

 Active All Activate and display all the nodes and elements 
currently modeled. 
 

 Active Identity Activate the nodes and elements related to the 
assigned UCS x-y plane, Named Plane, Story or 
Group. 
 

 Active Previous Revert to the previous state of activation. 
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View Control Toolbar 
 

 
 

 Shrink Display the elements smaller than the true sizes 
(Shrink the elements from nodes). 
 

 Perspective Display a perspective. 
 

 Hidden Display the elements to appear as real shapes by 
removing the hidden lines, reflecting the sectional 
shapes and the thickness of the elements. 
 

 Render View Display the model in a Hidden state with shading. 
 

 Rendering Option Adjust the Render View for special shading effects 
in detail. 
 

 Display A feature that enables the user to verify the input 
state related to all types of attributes such as 
loadings, support conditions, node or element 
numbers, material properties and section names, 
etc. 
 

 Display Option A feature that enables the user to control the 
representation format (color, font size, etc.) related 
to all the graphics and texts in the working window 
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Change Mode Toolbar 
 

 
 

 Analysis Perform structural analysis. 
 

 Preprocessing Mode Switch to the preprocessing mode. 
 

 Post-processing 
Mode 

Switch to the post-processing mode. 
 

 
 
 
Label Option Toolbar 
 

 
 

 Node Number Display the node numbers. 
 

 Element Number Display the element numbers. 
 
 
 
Dynamic View Toolbar 
 

 
 

 Zoom Dynamic Magnify/Reduce the model in real time as desired 
by dragging the mouse. 
 

 Pan Dynamic Move (up, down, left and right) the model in real 
time as desired by dragging the mouse. 
 

 Rotate Dynamic Rotate the model in real time as desired by 
dragging the mouse. 



 
 
 
 

APPENDIX B. Toolbars and Icon Menus 
 

243 

Node Toolbar 
 

 
 
 

 Create Nodes Create nodes. 
 

 Delete Nodes Delete nodes. 
 

 Translate Nodes Move or duplicate existing nodes by equal or 
unequal spacing. 
 

 Rotate Nodes Move or duplicate existing nodes by rotating about 
a specified axis. 
 

 Project Nodes Duplicate nodes by projecting on a specified line 
or surface. 
 

 Mirror Nodes Duplicate nodes symmetrically with respect to a 
specified plane. 
 

 Divide Nodes Divide nodes. 
 

 Merge Nodes Merge all the nodes within a given tolerance. 
 

 Scale Nodes Magnify or reduce the distances between nodes in 
a specified direction. 
 

 Compact Node 
Numbers 

Remove the unused node numbers and renumber 
the remaining nodes sequentially. 
 

 Renumber Node ID Renumber nodes. 
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Element Toolbar 
 

 
 

 Create Elements Create elements. 
 

 Create Line 
Elements on Curve 

Create line elements along a curve. 
 
 

 Delete Elements Delete elements. 
 

 Translate Elements Move or duplicate existing elements by equal or 
unequal spacing. 
 

 Rotate Elements Move or duplicate existing elements by rotating 
about a specified axis. 
 

 Extrude Elements Create elements by translating existing nodes into 
line elements, line elements into planar elements 
and planar elements into solid elements. 
 

 Mirror Elements Move or duplicate elements symmetrically with 
respect to a specified plane. 
 

 Divide Elements Divide elements. 
 

 Merge Elements Merge continuously linked elements into a single 
element. 
 

 Intersect Elements Divide elements automatically at their intersection 
points. 
 

 Change Element 
Parameters 

Modify the attributes of the modeled elements. 
 
 

 Compact Element 
Numbers 

Remove the unused element numbers and renumber 
the remaining elements sequentially. 
 

 Renumber Element 
ID 

Renumber elements. 
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Result Toolbar 
 

 
 

 Reaction Forces / 
Moments 

Verify support reactions by different components 
based on the numerical values and sizes of arrows. 
 

 Search Reaction 
Forces/Moments 

Verify reactions at a specific support by numerical 
values. 
 

 Deformed Shape Verify the deformed shape of the model. 
 

 Displacement 
Contour 

Verify the deformed state of the model by contour 
lines. 
 

 Search 
Displacements 

Verify the displacements of a specific node by 
numerical values. 
 

 Truss Forces Verify the axial forces in tension or compression 
elements by contour lines. 
 

 Beam Forces / 
Moments 

Verify the member forces in beam elements by 
contour lines. 
 

 Beam Diagram Verify the shear forces or the bending moments in 
beam elements. 
 

 Plate Forces / 
Moments 

Verify the member force distribution per unit 
length produced in plate elements by contour lines. 
 

 Wall Forces / 
Moments 

Verify the member force distribution per unit 
length produced in wall elements by contour lines. 
 

 Wall Diagram Verify the shear force and bending moment 
diagrams in wall elements. 
 

 Truss Stresses Verify by contour lines the axial stresses in trusses, 
tension-only elements, compression-only elements, 
cable elements, etc. 
 

 Beam Stresses Verify the stresses in beam elements by contour 
lines. 
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 Plane/Plate Stresses Verify the stresses in plane stress or plate elements 
by contour lines or vectors. 
 

 Plain Strain 
Stresses 

Verify the stresses in plane strain elements by 
contour lines or vectors. 
 

 Axisymmetric 
Stresses 

Verify the stresses in axisymmetric elements by 
contour lines or vectors. 
 

 Solid Stresses Verify the stresses in solid elements by contour 
lines or vectors. 
 

 Vibration Mode 
Shapes 

Verify the vibration mode shapes and natural 
frequencies of the model. 
 

 Buckling Mode 
Shapes 

Verify the buckling mode shapes and critical 
buckling load factors of the mode. 
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Property Toolbar 
 

 
 

 Material Enter the material properties of elements. 
 

 Time Dependent 
Material 
(Creep / Shrinkage) 

Define the material data related to time variant 
concrete creep and shrinkage. 
 
 

 Time Dependent 
Material 
(Comp. Strength) 

Define the change in modulus of elasticity of 
concrete with time. 
 
 

 Time Dependent 
Material Link 

Relate the time dependent material data to the 
general material properties. 
 

 Change Element 
Dependent Material 
Property 

In the case CEB-FIP is used to define Time 
Dependent Material Property, the geometric shape 
coefficient (h) may be changed. 
 

 Section Enter the section properties of linear elements. 
 

 Section Stiffness 
Scale Factor 

Specify scale factors for the stiffness components 
of line elements. 
 

 Tapered Section 
Group 

Group non-prismatic members so that the variable 
section is defined irrespective of the number of the 
elements constituting the variable section. 
 

 Thickness Enter the thickness data for plate elements. 
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Query Toolbar 
 

 
 

 Query Nodes Verify attributes for nodes. 
 

 Query Elements Verify attributes for elements. 
 

 Node Detail Tables Verify attributes for selected nodes in table format. 
 

 Element Detail 
Tables 

Verify attributes for selected elements in table 
format. 
 

 Design Parameter 
Detail Tables 

Verify the design parameters for selected elements 
in table format. 
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APPENDIX C. List of Shortcut Keys 
 
Main Menu Parent Menu Children Menu Shortcut Key 

New Project   +  

Open Project   +  

Save   +  

File 

Print   +  

Undo   +  

Redo   +  

Cut   +  

Copy   +  

Paste   +  

Delete   

Edit 

Find   +  

Redraw   
Initial View   +  

Fit  +  

Window  +  +  

In  +  

Zoom 

Out  +  

Left  +  

Right  +  

Up  +  

Pan 

Down  +  

Iso  +  +  

Top  +  +  

Bottom  +  +  

Left  +  +  

Right  +  +  

Front  +  +  

View 

View Point 

Rear  +  +  
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Main Menu Parent Menu Children Menu Shortcut Key 

Rotate Left  +  +  

Rotate Right  +  +  

Rotate Up  +  +  

View Point 

Rotate Down  +  +  

Previous View Status   +  

Shrink Elements   +  

Perspective View   +  

Remove Hidden Lines   +  

Render View   
Element Type  +  +  

Material  +  +  

Section  +  +  

Thickness  +  +  

Named Plane  +  +  

Select Identity 

Structure Group  +  +  

Select Single   +  +  

Select All   +  +  

Select Previous   +  

Select Recent Entities   +  

Active  
Inactive  +  

Active All  +  

Activities 

Active Identity  +  

View 

Display   +  

Arch  +  +  

Frame  +  +  Structure Wizard 

Truss  +  +  

Create Nodes  +  +  

Delete Nodes  +  +  

Translate Nodes  +  +  

Model 

Nodes 

Rotate Nodes  +  +  
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Main Menu Parent Menu Children Menu Shortcut Key 

Project Nodes  +  +  

Mirror Nodes  +  +  

Divide Nodes  +  +  

Merge Nodes  +  +  

Compact Numbers  +  +  

Nodes 

Nodes Table  +  +  

Create Elements  +  

Delete Elements  +  

Translate Elements  +  

Rotate Elements  +  

Extrude Elements  +  

Mirror Elements  +  

Divide Elements  +  

Intersect Elements  +  

Change Element 
Parameters  +  

Compact Numbers  +  

Elements 

Elements Table  +  +  

Material Table  +  +  

Section Table  +  +  Properties 

Thickness Table  +  +  

Supports Table  +  +  

Beam End Release 
Table  +  +  Boundaries 

Rigid Link Table  +  +  

Mass Nodal Masses Table  +  +  

Define Structure 
Group   +  

Model 

Check Structure Data Check and Remove 
Duplicate Elements  

Static Load Cases   
Nodal Loads Table  +  +  Load 

Load Tables 
Beam Loads Table  +  +  
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Main Menu Parent Menu Children Menu Shortcut Keys 

Load Load Tables Floor Loads Table  +  +  

Analysis Perform Analysis   
Results Combinations   +  

Preprocessing Mode   
Mode 

Post-processing Mode   +  

Project Status   +  

Query Nodes   Query 

Query Elements   +  

MCT Command Shell   +  

Text Editor   +  Tools 

Graphic Editor   +  

New Window   +  Window 
Full Screen   +  

Help Index   
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   +   +  

 Active All Select All Select Identity Element Type 

 Previous View Status Bottom Select Identity Material 

 Copy  Select Identity Section 

 Active Identity Beam End Release 
Table Select Identity Thickness 

 Display Rear Select Identity Named Plane 

 Find Front  

   Select Identity Structure 
Group 

 Remove Hidden Lines   

  Iso  

 Perspective View   

 Shrink Elements   

  Left Material Table 

  Beam Loads Table Elements Table 

 New Project Nodal Loads Table Nodes Table 

 Open Project Floor Loads Table  

 Print  Supports Table 

 Select Previous   

 Select Recent Entities Right Rigid Link Table 

 Save Select Single Section Table 

 Project Status Top Thickness Table 

 Full Screen  Nodal Masses Table 

 Paste   

 New Window Structure Wizard-Arch  

 Cut Structure Wizard-Frame  

 Redo Structure Wizard-Truss  

 Undo   
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    +  

  Create Elements Create Nodes 

  Delete Elements Delete Nodes 

  Translate Elements Translate Nodes 

  Rotate Elements Rotate Nodes 

  Extrude Elements Project Nodes 

  Mirror Elements Mirror Nodes 

  Divide Elements Divide Nodes 

  Intersect Elements Merge Nodes 

  Change Element Parameters Compact Numbers 

 Zoom Fit Compact Element Numbers  
 
 Function  + Function 

 Help Structure Group 

 Active Inactive 

 Redraw Initial View 

 Query Nodes Query Elements 

 Perform Analysis Text Editor 

 Render View Graphic Editor 

 Preprocessing Mode Post-processing Mode 

   

 Static Load Cases Combinations 

   

   

 Check and Remove Duplicate Elements MCT Command Shell 
 
 Shortcut Key  Shortcut Key 

Zoom Fit  +  Pan Down  +  

Zoom In  +  Delete  
Zoom Out  +  Rotate Right  +  +  

Pan Left  +  Rotate Left  +  +  

Pan Right  +  Rotate Up  +  +  

Pan Up  +  Rotate Down  +  +  
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